View Full Version : Squeezecenter won't start anymore

2008-08-06, 05:28
Since I've upgraded from Squeezecenter 7.0.1 to 7.1 it won't start anymore. It worked once but the next day, after a reboot, the icon in the system tray keeps saying that Squeezecenter is starting. But it never completes. No visible errors.

Then I tried to start it from the command line and this was the answer:

[08-08-06 14:01:22.9167] Slim::Utils::MySQLHelper::startServer (272) Warning: Couldn't install MySQL as a service! Will run as a process!
[08-08-06 14:01:25.1668] Slim::Utils::Misc::msg (1356) Warning: [14:01:25.1667]
mkdir C:\ProgramData\SqueezeCenter\Cache\Artwork: File exists at /<C:\Program Fi
les\SqueezeCenter71\server\squeezecenter.exe>Cache/FileBackend.pm line 222

I first installed v7.1 on top of 7.0.1
Then I removed Squeecenter complete and installed v7.1 again. I got an installation error about "Could not create file that already exists". I looked into the directory and it was empty so no idea where this message came from. But I couldn't install it to the default location so I changed the location to c:\Program Files\Squeezecenter71. Install went fine but it still won't start.

Anyone can help?

I am using Vista Ultimate


2008-08-06, 12:00
I've got exactly the same problem.

I was running 7.0.1 and though I'd upgrade to 7.1 to see if that solved the problem. Guess what. It didn't.

Why do Logitech have so many issues. I upgraded to the Squeezebox Duet from the Wireless DJ because the WDJ packed up totally.

Now I've got this problem. I could scream!!!!

Can anyone help before I package this thing up and ship it back!

Arrrrrrrggggggggggggghhhhhhhhhh!!!!!!!!!!!!!!!!!!! !!!!

2008-08-06, 12:09
> Now I've got this problem. I could scream!!!!

Shut down SC, remove the SqueezeCenter/Cache folder (in the All User
profile), start again.


2008-08-06, 12:49

Have you done this? Does it work?

If so, do I delete the entire folder named 'cache' in the SqueezeCenter folder or just certain elements of it? Not sure.

Thanks for the reply.

2008-08-06, 13:36
You can delete the entire folder, it rebuilds when you start SC again.
Oh do like this STOP SC delete cache START SC, then it will automatically start a rescan (as you no longer have any dB etc) so web Ui can be a litle slow to show, as the machine is busy scanning.

2008-08-07, 09:12
I've tried this and re-started SC.

I opened task manager to see the application start up. It gets to around 99,000k (usually runs in excess of 100,000k when working properly) and then disappears from task manager. SC fails to run.

Any other suggestions?

I have tried un-installing 7.1 and re-installing it. No joy.

2008-08-07, 15:05
The provided suggestions didn't work for me either.
So I did a System restore and intalled 7.1 again. That did help.

2008-08-08, 19:25
I have the same problem on a Squeeze Box duet using a Dell Insperion laptop with Windows Vista Home Premium, 32 bit. Had no problem with old version of SqueezeCenter on my desktop PC, but with version 7.1 it will not load on my laptop. I tried a factory reset of my controller and had no luck. I cannot remove the SqueezeCenter/Cache folder (in the All User profile) and restart because there is no cache yet- the program has not successfully loaded once so it never built the cache folder. I also tried a full uninstall and reinstall. I am able to connect to squeezecenter on line, but the handset cannot find my PC as a server because squeezecenter never loads. Any ideas? Thanks in advance!

2008-08-23, 10:28
I'm having the same "won't start" problem any more ideals.
Using Vista, SS 6.5 ran fine I uninstalled Norton and reinstalled sqeezecenter many times and still SC tray just blinks "starting.

2008-08-23, 21:16

I had the same issue recently but difference being that mine worked and then stopped working.

It turns out that my AVG antivirus was out of date. If I turned this off, SQ worked. So I updated AVG to V8.0 and now all is happy again

Hope this helps others


2008-08-24, 02:07
Hi all,

I'm new on this forum, i recently bought a Duet and had the same prob.
Now i'm using the beta:
SqueezeCenter-versie: 7.2 - 22756 @ Tue Aug 19 02:03:07 PDT 2008 - Windows XP - NL - cp1252 and that works fine.


2008-08-24, 05:51
Still not starting, tried 7.2,7.1 & 7.0 with no luck.

Phil Leigh
2008-08-24, 08:05
Still not starting, tried 7.2,7.1 & 7.0 with no luck.

Are you sure you have totally uninstalled Norton?
Have you checked the event viewer in Control Panel - Admin Tools (or whatever the equivalent is in Vista) for anything strange?

2008-08-24, 08:40
I sent a Event File to SD support, waiting to hear if somethings not right.

2008-08-24, 10:08
I don't know if this is it or will help.

! Information

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
<Provider Name="MySQL" />
<EventID Qualifiers="49152">100</EventID>
<TimeCreated SystemTime="2008-08-24T15:50:48.000Z" />
<Security />
- <EventData>
<Data>C:\PROGRA~1\SQUEEZ~1\server\Bin\MSWIN3~1\mysqld.ex e: Shutdown complete</Data>

! Error

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
<Provider Name="MySQL" />
<EventID Qualifiers="49152">100</EventID>
<TimeCreated SystemTime="2008-08-24T15:50:48.000Z" />
<Security />
- <EventData>

2008-08-26, 04:11
I had exactly the same issue on Vista Ultimate when upgrading from 7 to 7.1 and was only able to resolve it by completely uninstalling 7, rebooting, then installing 7.1.

I have to say my heart sinks whenever I upgrade Squeezecentre (and, previously, Slimserver) as I have found it to be the most troublesome software to upgrade I have. Having said that, it's usually rock solid once it's working correctly.


2008-08-26, 16:59
I've uninstalled and installed 30X with no luck. I just don't know what to do.

2008-08-27, 16:23
Found this thread after experiencing the same problem yesterday. Apparently "MySQL" was corrupted. I uninstalled 7.01 but the old MySQL folder wasn't removed. When I tried installing 7.1 (using folder Squeezecenter), the old MySQL folder still caused problems (Squeezecenter wouldn't start). I re-installed 7.1 using a new destination folder (e.g. Squeezecenter1) and it worked fine.

I can't remove the old folder no matter what I try.

I'm also using Vista on a Dell Inspiron.

2008-08-27, 18:17
Found this thread after experiencing the same problem yesterday. Apparently "MySQL" was corrupted. I uninstalled 7.01 but the old MySQL folder wasn't removed. When I tried installing 7.1 (using folder Squeezecenter), the old MySQL folder still caused problems (Squeezecenter wouldn't start). I re-installed 7.1 using a new destination folder (e.g. Squeezecenter1) and it worked fine.

I can't remove the old folder no matter what I try.

I'm also using Vista on a Dell Inspiron.

I was hoping it would work but no luck, SC tray still says "starting".

2008-08-29, 13:35
Did a clean install of the new 7.2 and still the same problem, won't start (SC tray says "starting").

2008-08-29, 13:55

Don't know if that will help, but I'm experiencing a weird issue here that *might* be related.

I have been using 7.0.1 since it was out, with a "normal" Duet experience.

I updated to 7.2 a couple days ago. Since then, my Duet would find SC and play local music, but anything related to Internet (Extras/news feeds, web radios etc.) would fail. Also, the bottom of the web page showing SC was carrying an error message related to DNS.

I have been hunting for a potential cause for this. I have suspected that Logitech has modified the startup sequence for SC when run as a service (which is my case).

Just to check, I went to XP admin tools, stopped the SC service and restarted it, and everything worked again.

Cold rebooted the machine, again everything outside of my local music was not available. Stop/start SC service, and works again.

This is 100% reproducible here.

So I suspect that whatever modification was made to the startup sequence of SC when run as a service, has SC start too early, and in my case before the routing/firewall service (Kerio Winroute) which also runs on this machine (which is the internet gateway for my home LAN). When this happens, SC will bind to bad net links. Stop/start SC service cures the problem.

Maybe you guys are facing some form of the same issue, where SC starts too early on your machines.

Related or not, this is something that needs a fix.


2008-08-30, 04:18
Same problem as everyone.

I am running SC 7.2 with WinXP SP3.
With the 7.0.1, everything was working fine. I upgraded to 7.1 last week, then the problem occurred. The icon tray stays on "SqueezeCenter starting"...I thought upgrading to 7.2 would fix this problem, but it remains the same.

Is this problem taken into account ? I haven't seen any information about it here. It is really annoying, I can't play my music...

I did not try to desinstall and install again, or in another directory as it seems not to be really efficient.

Thanks for any advice, or any news about a fix.

2008-08-31, 04:58
OK problem solved.

I didn't want to wait for any possible answer.
I chose to uninstall completely SqueezeCenter 7.2 and install it again. It works.

The complete process I wen through :
- uninstall SqueezeCenter with Add/Remove programs Windows tool,
- clean the registry (i'm not sure this is necessary, but...) I use RegCleaner, it is free. Perform the complete scan : Tools->Registry cleanup->Do them all. Then check all the keys (Select->All) and click 'Remove selected',
- restart the computer,
- install SqueezeCenter 7.2.

I have my music back !!!