PDA

View Full Version : [SLIM] Squeezebox/External DAC and FLAC drop-outs



Auricle
2004-03-22, 20:15
On March 18, 2004 6:53:14 PM CST Harry McQuillen <lists (AT) spunturtle (DOT) net>
wrote:
> Does anyone have this working with a decent DAC?

This discussion has been quite interesting as I'm encoding my library
using FLAC and intend to use the SB and an external DAC...

I connected the SB to my Akai S3200XL sampler for some listening tests
over the weekend. This sampler has both optical and electrical digital
inputs. Both optical and digital connections worked just fine, despite
the fact that I only had an "audio" patch cable to use for the
electrical connection. The only time the sampler complained about the
lack of signal from the SB was before playing any audio. After that -
even when the SB was turned "off" - the sampler was receiving the
44.1KHz carrier.

I've tried both wired and wireless connection, but spent most of the
time in wireless mode with the SB about 18 inches from the access point
(~80% signal strength, WEP enabled). Sporadically (perhaps once every
hour or two), I'd get an audio drop out which corresponded with the
buffer level dropping too low. I suspect this is due to interference
with the wireless signal, but I'd have to monitor the wireless signal
with a history graph on my PowerBook to get a better idea. I tried
increasing wireless network traffic by doing a backup of my PowerBook
during playback. During the backup, the audio stuttered quite a bit
(due to buffer starvation) but returned to normal once the backup
finished. I experienced one other audio drop out after repeatedly
skipping through tracks in the playlist - forcing the buffer to empty
and refill repeatedly. Most of the time, however, the audio was rock
solid (and sounded great).

I will most likely use wired ethernet for the SB, but wanted to see
what problems I might encounter using Wi-Fi.

Interestingly, the server was quite busy during all of this:
distributed (protein) folding clients running (nice -19), email, web
surfing, FLAC encoding, etc. I didn't notice any hiccups even with a
high system load (2-4). Overall, I was quite pleased with the
robustness of this configuration.

> Also, anyone have FLAC working on the Mac?

Yes, the above server is a dual 1GHz PowerMac, 10.3.3... flac
installed via Fink (fink.sourceforge.net).

--jeff

--
auricle (AT) io (DOT) com

Dirk P. Fromhein
2004-03-22, 20:45
Auricle wrote:

> On March 18, 2004 6:53:14 PM CST Harry McQuillen
> <lists (AT) spunturtle (DOT) net> wrote:
>
> Does anyone have this working with a decent DAC?
>

I'm not sure what you would consider "decent", but I *love* my McCormack
($1,200 range new). I just got a new Theta (in the $1,000 range) that
also sounds great.

Both have been hooked up to my squeese box (wireless) and both sound
fantastic. Never an issue, I've ripped everything as a WAV (yes I
know... I have a couple of 200G drives in a RAID 0 array).

I prefer the McCormack, but it's a pretty close call with the Theta.
The rest of my system is McIntosh Amps, and a combination of Martin
Logan and Infinity RS1b speakers (using an active crossover).

It's a tough call... but the only thing that sounds better than my
squeese box + McCormack is my McIntosh CD player... the midrange is just
very open and sweet.

So I would say I have it "working" with a "decent" DAC. :-)

Cheers,
Dirk