View Full Version : Controller software update

2008-08-02, 12:24
Sorry for posting these questions, but I'm a novice in this area...
I have a Duet, with Squeezecenter running on a Qnap TS-209 Pro.

1. When upgrading SC to 7.1 a few days ago from http://www.slimdevices.com/su_downloads.html (Perl code; version reads 7.1-22170 after updating), I was under the impression that the Controller should also be updated to get some new functionality?

2. I have tried to update the Controller via the Settings -> Advanced menu. The Controller indicates new software "version ?" is available. When trying to update, the display reads "copying update" for a few seconds, then I get an error message, and am told to try again or contact support. FW still reads 7.0.1 r2448; is this the latest official release of software for the Controller?

3. I have found indications on this forum, that the main release number should be the same for Controller and SC. I have also found some software updates (jive_7.x_rxxxx.bin) which I believe are for the Controller on http://update.slimdevices.com/update/firmware/
In case an update should be done; which one is the correct for me? The latest one under 7.1?

4. I guess that the Controller searches for updates in a directory in the SC installation, and updates when new files are posted there. Can I download the correct *.bin file, put it in the correct directory, and try the manual update again, or do I have to use the SD-card method described in other posts on the forum?

I hope someone is able to help with these questions...

2008-08-04, 08:40
I have had the same issue for awhile now. Every time I try to update the controller, it seems to fail. I gave up after trying it 3 or 4 times, but would love to know if there is something I could do to solve the problem.

2008-08-05, 08:25
Just to follow up, I updated my SC from 7.0 to 7.1 -22254 and that seems to have solved the problem. As soon as the update was completed my controller started the whole update cycle and to my amazement it completed the cycle without incident so I now have a fully up to date remote. I suggest that anyone who is having this issue update to 7.1. Now if I could only get Rhapsody to work...

2008-08-06, 12:53
Just a status report on my questions:

I have downloaded and installed a newer version of SC ,7.1.1-22377.tgz (Perl code) from http://downloads.slimdevices.com/nightly/latest/7.1/, hoping that my controller would now automatically update, but no luck. Trying to update manually also produced the same dismal result as before...

Having found some more info on the forum on this topic, I decided to try another approach. I downloaded the file "jive_7.1_r2749.bin" from http://update.slimdevices.com/update/firmware/7.1.1/, and used WinSCP to copy this file into the controller memory as "/mnt/mmc/jive.bin", ([Settings > Advanced > Remote Login > Enable SSH] gave me the controller IP-address and passwd, user is root).

Choosing [Settings > Advanced > Software Update > Update from SD card] on the controller updated the unit correctly. I read somewhere that the .bin-file had to be removed manually after installation, but on my unit it was deleted automatically...

I still don't know whether this combination of SC/controller firmware is "correct", but it seems to work OK. A colleague at work is running SC on a regular Linux server, and he claims his system updated automatically after installing the 7.1, so it may be an issue with the Perl version?)

I have found a small problem with the new firmware in my setup, though; the controller regularly lose the wireless connection after a while, and a reset is required. (This may be an issued with my WLAN router... Haven't had the energy to dive into the problem yet...)
But after turning off the power saving options under [Settings > Advanced > Factory Test > Power management], it has not happened again... I generaly keep the controller in its cradle on a small table beside my "comfy chair" anyway, so life on battery power is not a big issue yet. (This may change when the controller audio output is enabled in a later update...)

2008-09-03, 01:21
I tried the same update procedure as described above (copy jive.bin to /mnt/mmc) but I do not see a menu item that allows me to update from SD card. Btw, jive.bin is a folder containing several files and not one single - is that correct?

2008-09-03, 12:59
For many weeks now I have been unable to update my Duet to the latest software which seems a pretty common problem on this forum.
Having tried everything I have found an INSTANT solution.
I simply registered my Duet on my already existing Squeezenetwork accout, & within minutes the upgrade was updating my Duet.
Job Done