PDA

View Full Version : Access to Music Folders Windows/Linux



Tim Marino
2004-03-21, 16:43
GREAT!! Thanks guys, the smbmount did the trick. Ok it
had me fooled for a few minutes because I needed to
create the directory first but shortly thereafter I
had music playing!

But, is there a way to make this smbmount automatic?
If so how do I respond to the password prompt I got
when I issued the command.

I am going to try to document my experiences for other
unix newbies making the switch from Windows.
Slimserver seems to run much better on *nix.

--- Jack Coates <jack (AT) monkeynoodle (DOT) org> wrote:
> On Sat, 2004-03-20 at 15:08, alexd wrote:
> > On Sat, 2004-03-20 at 10:25 -0800, T
> ...
> > Mount the windows share with smbmount on the linux
> box. Ie
> >
> > smbmount //server/share /mnt/share
> >
> > and before you do that, make sure the mount point
> (/mnt/share) is world
> > readable. Then point slimserver at /mnt/share and
> all should be fine and
> > dandy.
> >
> > alexd
>
> one thing on permissions, it would be better to take
> the trouble to make
> the directory group-writable by slimserver, or
> change the
> saved-playlists entry in server settings to another
> directory. Otherwise
> it will complain.
> --
> Jack at Monkeynoodle Dot Org: It's A Scientific
> Venture...
>
************************************************** ********************
> * "Sendmail administration is not black magic.
> There are legitimate *
> * technical reasons why it requires the sacrificing
> of a live *
> * chicken." -- Unknown
> *
>
************************************************** ********************
>
>

Stephen Ryan
2004-03-21, 19:11
On Sun, 2004-03-21 at 18:43, Tim Marino wrote:
> GREAT!! Thanks guys, the smbmount did the trick. Ok it
> had me fooled for a few minutes because I needed to
> create the directory first but shortly thereafter I
> had music playing!
>
> But, is there a way to make this smbmount automatic?
> If so how do I respond to the password prompt I got
> when I issued the command.
>
> I am going to try to document my experiences for other
> unix newbies making the switch from Windows.
> Slimserver seems to run much better on *nix.

There is; add the following to /etc/fstab and the smbmount will be done
automatically at boot:

//servername/path /path/where/you/want/it/mounted smbfs username=smbusername,password=smbpassword,uid=nnnn ,gid=nnnn 0 0

The UID= and GID= should be the user ID and Group ID on the Linux system
that you want the files to show up as (look in /etc/passwd and
/etc/group to see what the numeric ids are there).

There are a few other options that you can add, but those are the ones
that I've been using on my little home network with some success.
--
Stephen Ryan
Digital Rights Management is bad for all of us:
http://www.bricklin.com/robfuture.htm

Jack Coates
2004-03-21, 19:19
On Sun, 2004-03-21 at 15:43, Tim Marino wrote:
> GREAT!! Thanks guys, the smbmount did the trick. Ok it
> had me fooled for a few minutes because I needed to
> create the directory first but shortly thereafter I
> had music playing!
>
> But, is there a way to make this smbmount automatic?
> If so how do I respond to the password prompt I got
> when I issued the command.

yes, but it's easier on some distros than others. Try investigating the
GUI configuration tools for whatever you're using, but this is basically
what they'll setup:
[jack@cletus jack]$ grep smbfs /etc/fstab
\\fs1\shared /mnt/shared smbfs
user,uid=501,username=jack,gid=501,credentials=/etc/samba/auth.rad.jack
0 0

[jack@cletus jack]$ cat /etc/samba/auth.rad.jack
username = jack
domain = CORP
password = password

--
Jack at Monkeynoodle Dot Org: It's A Scientific Venture...
************************************************** ********************
* "Brainiac's daughter made me a suit of bricks and mortar and a *
* matching stove pipe hat, oh yes, Brainiac's daughter took me on a *
* sleigh ride underwater and I'm crazy for girls like that." *
* -- Brainiac's Daughter from Chips From The Chocolate Fireball by *
* The Dukes of Stratosphear *
************************************************** ********************