PDA

View Full Version : SSOD + Synology DS107+ lecture AAC impossible



jaquierp
2008-07-28, 09:53
Hum, désolé si ce "topic" a déja été ouvert.

Mon problème :
1) Il m'est impossible de pouvoir ecouter des morceaux AAC stockés sur mon NAS avec le SSOD et le squeeze center "http://192.168.1.2:9000/".
Les autres morceaux (MP3) passent sans autre..

Ma config :
1)Je tourne le dernier SSOD sur un Synology DS107+...avec une "squeezebox" connectée à mon système audio

Workaround et tests effectués (avec même localisation des sources soit le NAS):
1) Si j'utilise la distrib pour une installation "PC" (au lieu du perl/NAS) tous passe (en laissant le pc allumé of course )


Vu que le point "pas pc allumé" m'a fait passer d'un LACIE au Synology (pour avoir le SSOD dessus) je suis en attente de support éclairé ;-)

Phil

sebp
2008-07-29, 10:16
Je n'utilise ni format AAC, ni NAS Synology, mais à ma connaissance, les formats Apple ne sont pas gérés nativement par la Squeezebox.
SqueezeCenter a besoin de convertir ces fichiers au format WAV pour qu'ils puissent être lus, et requiert pour cela la présence d'exécutables externes sur le serveur.

Vérifie sous Réglages > Avancé > Types de fichier que le conversion des formats Apple Lossless et Apple AAC n'est pas sur "Désactivé", et que les exécutables requis pour effectuer la conversion sont bien présents sur ton NAS.

jaquierp
2008-07-29, 11:41
Bien vu

Effectivement "apple AAC ou film" est "deactivé"....???? (je connaissais pas cette option)

Comment faire pour les activer avec la version du SSOD (avec la version PC l option est "Activée"). Limitation de la version SSOD de squeezecenter ?

PS Idem Window media et Wavpac.

Merci d'avance

Phil

sebp
2008-07-29, 11:58
Aide-toi ...
http://oinkzwurgl.org/ssods_faq#toc18

jaquierp
2008-07-29, 23:10
Hello j'ai effctivement vu ce tips mais c'est du chinois pour moi...;-))))

Je crois comprendre qu'il faut rajouter ces 3 éléments (voir ci dessous) mais OU et COMMENT ?

Est-ce bien cela pour permettre une lecture de mes fichiers AAC (pourquoi la procedure mentionne AAC+ au lieu d' AAC ? )

Merci d'avance pour ton aide precieuse "o" gourou ;-)

Philippe

************************************

1)You can play AAC+ files using this custom-types.conf types :

aap-audio/aacp,audio/aac audio

2) and this custom-convert.conf rules
aap wav * *[mplayer-stdout] -ac faad -demuxer aac -really-quiet -vc null -vo null -cache 64 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=- $FILE$ 2>/dev/null aap mp3 * *
[mplayer-stdout] -ac faad -demuxer aac -really-quiet -vc null -vo null -cache 64 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=- $FILE$ 2>/dev/null | [lame] --silent -r -x -q $QUALITY$ -b $BITRATE$ - - 2>/dev/null
aap flc * *
[mplayer-stdout] -ac faad -demuxer aac -really-quiet -vc null -vo null -cache 64 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=- $FILE$ 2>/dev/null | [flac] -cs --totally-silent --endian=little --channels=2 --sign=signed --bps=16 --sample-rate=44100 --compression-level-0 - - 2>/dev/null

3) and this addition to stings.txt (isn’t there a custom-strings.txt?)

AAP EN AACplus

************************************

sebp
2008-07-29, 23:35
Je ne peux malheureusement pas t'en dire plus, vu que je n'utilise pas SSOD, sinon que ça a l'air d'avoir un rapport avec un plugin nommé AlienBBC.
Une recherche de "custom-types.conf" sur ces forums donne des résultats qui devraient t'aider un peu.