PDA

View Full Version : no scroll on display, big or little



Pat Farrell
2004-03-18, 20:36
Hi All,

In trying to isolate why I can't get my Sqbx's display to scroll,
I've tried a couple of things, and am still getting no scroll.

First, I'm running the current CVS version on a Fedora/Linux system.
Player firmware is reported to be 8. SlimServer version
is reported as 5.1.1. I did the CVS update yesterday late evening.

Player display setting is "tracknum - title - artist - album
which should scroll with nearly any album, and both Big and small
display.

Screensaver delay timing is 30
Scroll Pause 0.001
(altho other values seem to make zero difference).
Scroll Rate 0.15
Screensaver: Now Playing

The display never scrolls.

Any ideas?

Thanks
Pat

kdf
2004-03-18, 22:44
Quoting Pat Farrell <pfarrell (AT) pfarrell (DOT) com>:

> Hi All,
>
> In trying to isolate why I can't get my Sqbx's display to scroll,
> I've tried a couple of things, and am still getting no scroll.
>
> First, I'm running the current CVS version on a Fedora/Linux system.
> Player firmware is reported to be 8. SlimServer version
> is reported as 5.1.1. I did the CVS update yesterday late evening.
>
> Player display setting is "tracknum - title - artist - album
> which should scroll with nearly any album, and both Big and small
> display.
>
> Screensaver delay timing is 30
> Scroll Pause 0.001
> (altho other values seem to make zero difference).
> Scroll Rate 0.15
> Screensaver: Now Playing
>
> The display never scrolls.
>
> Any ideas?
The only thing I can think of is that you have somehow set the animation
settings off. Think this has been removed in recent nightlies, because its
confusing. I can't recall off the top of my head where it was in settings, or
if it was player or server setting. If it was server, likely it was under
performance or bahavior. Failing finding it, look for slimserver.pref and load
that into a text editor and search for 'animation'.

-kdf

Pat Farrell
2004-03-18, 23:12
At 12:44 AM 3/19/2004, kdf wrote:
> >> In trying to isolate why I can't get my Sqbx's display to scroll,
>The only thing I can think of is that you have somehow set the animation
>settings off. If it was server, likely it was under
>performance or bahavior. Failing finding it, look for slimserver.pref and
>load
>that into a text editor and search for 'animation'.


the line in my current slimserver.conf was
animationLevel = 0

Looking thru my collection of old and dead configuration files, I see
some setings to 1 and some to 3.

I'll try some random values and see if I can figure these out.

The only references I can find to animation in the help HTML are in the
input.html in EN/html/docs and it doesn't address what the meanings of
these settings are. I also don't see where in either the Default or
Fishbone skin that one can set them.

If there is documentation on this, a pointer would be appreciated.
If not, I may try to write up whatever I find.

Thanks
Pat

kdf
2004-03-18, 23:25
Quoting Pat Farrell <pfarrell (AT) pfarrell (DOT) com>:

> At 12:44 AM 3/19/2004, kdf wrote:
> > >> In trying to isolate why I can't get my Sqbx's display to scroll,
> >The only thing I can think of is that you have somehow set the animation
> >settings off. If it was server, likely it was under
> >performance or bahavior. Failing finding it, look for slimserver.pref and
> >load
> >that into a text editor and search for 'animation'.
>
>
> the line in my current slimserver.conf was
> animationLevel = 0
>
> Looking thru my collection of old and dead configuration files, I see
> some setings to 1 and some to 3.
>
> I'll try some random values and see if I can figure these out.
>
> The only references I can find to animation in the help HTML are in the
> input.html in EN/html/docs and it doesn't address what the meanings of
> these settings are. I also don't see where in either the Default or
> Fishbone skin that one can set them.
>
> If there is documentation on this, a pointer would be appreciated.
> If not, I may try to write up whatever I find.

I think this setting has been removed, so it will be a moot poitn for future
official releases. Try using 3, or even removing the animationlevel line
altogether. That should help.

cheers,
kdf

Pat Farrell
2004-03-19, 00:09
At 01:25 AM 3/19/2004, kdf wrote:
>Quoting Pat Farrell <pfarrell (AT) pfarrell (DOT) com>:
> > I'll try some random values and see if I can figure these out.
> >
> Try using 3, or even removing the animationlevel line altogether.

Three works fine.

>I think this setting has been removed, so it will be a moot point for future
>official releases.

Naturally, since I'm starting to understand that part :-)

Pat

kdf
2004-03-19, 00:42
Quoting Pat Farrell <pfarrell (AT) pfarrell (DOT) com>:

> At 01:25 AM 3/19/2004, kdf wrote:
> >Quoting Pat Farrell <pfarrell (AT) pfarrell (DOT) com>:
> > > I'll try some random values and see if I can figure these out.
> > >
> > Try using 3, or even removing the animationlevel line altogether.
>
> Three works fine.
yup, that's what I have. I'd advise against updating daily right now as there is
a lot of work going on. However, joining the checkins list will help. This way,
you will see the changes and the notes for each.

>
> >I think this setting has been removed, so it will be a moot point for
> future
> >official releases.
>
> Naturally, since I'm starting to understand that part :-)

yeah, it was timed that way ;)

the server code has quite a history, and it also moving at a very quick pace. It
takes some time to get up to speed. I've been contributing for around a year
now, and there are still parts of the code I can only stare at blankly. :)
-kdf