PDA

View Full Version : Linux setup problem



Dave Rodger
2004-03-18, 19:50
Hey--

I have maybe a newbie problem--I'm trying to switch my Slimp3 setup from my
XP box (where it works fine, but seems to be resource-intensive, and gives
me "poky" remote response occasionally) to my Linux machine. I've installed
the new version (5.1.1) using the RPM installer, on my RedHat installation.

When I open a browser, and go to localhost:9000/log.txt, I see this message:
2004-03-18 21:40:09.7856 Your MP3 directory needs to be configured. Please
open your web browser,
2004-03-18 21:40:09.7922 go to the following URL, and click on the "Server
Settings" link.

2004-03-18 21:40:09.7926 The URL to access the SlimServer is now:
http://spirit:9000/

When I go to that URL, I see the web interface. I try to change my Your
Music Folder directory to this:
/home/jukebox/mp3
And I get this response:
Oops - "/home/jukebox/mp3" doesn't seem to be a valid directory. Try again.

This is a directory on my system; in /home/jukebox, if I do ls -l I get
this:
[root@spirit jukebox]# ls -l
total 1648
drwxrwxr-x 4 jukebox jukebox 4096 Mar 17 21:35 mp3
This seems like it must be a user/permissions issue--but I don't know where
to look. Can anyone give me any guidance, or where in the FAQ I might
check?

Thanks.

-dave

Jack Coates
2004-03-18, 21:24
On Thu, 2004-03-18 at 18:50, Dave Rodger wrote:
....
> This is a directory on my system; in /home/jukebox, if I do ls -l I get
> this:
> [root@spirit jukebox]# ls -l
> total 1648
> drwxrwxr-x 4 jukebox jukebox 4096 Mar 17 21:35 mp3
> This seems like it must be a user/permissions issue--but I don't know where
> to look. Can anyone give me any guidance, or where in the FAQ I might
> check?

The slimserver RPM install sets it up as user slimserver. Options:

chown -R slimserver:slimserver /home/jukebox

That's the easy way, but you might have gripes from other software (for
instance msec on a Mandrake system will complain and change it back, or
if you have software that runs as user jukebox it won't be happy.)

vi /etc/groups and add slimserver to the jukebox group.

I haven't tested to see if slimserver is happy with just having group
permission, but it should work.
--
Jack at Monkeynoodle Dot Org: It's A Scientific Venture...
************************************************** ********************
*"There are problems in these times, but woo! None of them are mine!"*
*-- Beginning to See The Light by The Velvet Underground *
************************************************** ********************