View Full Version : Duet connection problem

2008-07-19, 10:06
I am having trouble connecting my Squeezebox duet to my squeezecenter. I have tried everything I can think of. Please help. Here is my setup:

ReadyNAS NV+ 4.01c1-p1 firmware, running squeezecenter 7.0.1, ip
Linksys WRT54GS 1.0 router with Sveasoft Talisman 1.0.5 (wireless security WPA-PSK with TKIP)
Router ports 9000, 9090, 3483 open, allowing both TCP and UDP and directed to readyNAS
SMC GS8 gigabit 8-port switch
Duet squeezebox IP:, firmware: 23, ip when connected on squeezenetwork:
Duet controller IP:, firmware: 7.0.1 r2448

When I run through the setup, I use a wired Ethernet connection for the squeezebox. The squeezebox connects to the Ethernet fine (blue light), it sees the squeezenetwork, and it sees the ReadyNAS. I can connect to the squeezenetwork no problem. It is unable to make a connection to the ReadyNAS squeezecenter. I have verified that the ReadyNAS squeezecenter is running, and it similarly does not see the squeezebox player.

I then setup softsqueeze 3.6 on a windows PC, and it is able to connect to the readyNAS squeezecenter without a problem.

To test if this is a readyNAS problem, I then installed squeezecenter 7.0.1 on my Windows Vista PC. I redirected the ports 9000, and 3483 to point to the PC (ip I went through windows Vista firewall control panel and added those ports, and allowed squeezecenter.exe as a program.

Same problem. The squeezebox (as reported on the controller) sees the Vista squeezecenter, but when I try to connect, it is unable to make a connection. The PC softsqueeze, however, is able to connect without a problem.

I just purchased the duet 3 days ago. I have spent many hours trying to figure out the problem and have read through hundreds of forum chains. I am about ready to give up. Please help. When I first turned on the duet, it went through the startup steps, and then wanted to do a firmware update on both the controller and the squeezebox. I let it do the firmware update, but this seemed to take over an hour to complete. I donít know if this is typical, but it seemed unusually long.

I have also tried these steps:

Install ReadyNAS squeezecenter 7.0.0
Install ReadyNAS squeezecenter 7.0.1 from Logitech web site
Install ReadyNAS squeeze center 7.0.0.ntgr1 from netgear support forum
Install ReadyNAS squeeze center 7.0.1.ntgr1 from netgear support forum
Countless reboots, and power ups of all components (router, ReadyNAS, duet, PC)
Connect squeezebox and readynas directly to linksys router (instead of through 8-port switch)