PDA

View Full Version : Missing controller menu items



Calodoucas
2008-07-12, 13:56
Just set up my new controller and the display is missing menu items when it connects to my squeezebox.

I am running Squeezecenter 7.0.1

Any ideas?

Thanks.

davep
2008-07-12, 17:47
Not completely sure of your problem but if you go to the Settings menu from the Controller Home screen you will see an item named "Home Menu". Clicking on that presents you with a list of all of the possible menu entries and enables you to select/deselect them for inclusion in the main menu as you wish.

davep

Calodoucas
2008-07-13, 06:36
Thanks Davep.

I should probably give more details.

I set up my Controller without any difficulties until the point where I was asked to a choose player. I selected my player, to be presented with the 'Connecting to player' screen. The controller stayed on this screen for hours just looping. I've tried again and again going through the set up process only to be met with the same problem. I can cancel the looping 'Connecting' screen by turning on my squeezebox with the old remote. This leaves me with a 'Home' screen on the controller with the following menu items:

Now Playing
Settings
Extras
Turn On/Off 'Name of player'

If I select 'Settings' I get:

Screen
Music Source
Advanced

So, basically, my problem is I have no menu items presented that give me access to my music library apart from 'Now Playing'. Very frustrating.

I'd really appreciate any help.


My set up is:

SqueezeCenter 7.0.1
Squeezebox Classic
Controller
OS X 10.4.11

schiegl
2008-07-13, 07:09
Hi,

Is your SqueezeCenter protected by a password? If it is, try again without one.

kind regards,
Markus

Calodoucas
2008-07-13, 07:14
Thanks Markus.

My SqueezeCenter isn't protected by a password.

Any other ideas?

Many thanks.

Calodoucas
2008-07-13, 15:02
Anyone got any further suggestions on this?

Thanks

ModelCitizen
2008-07-13, 20:34
It sounds like your Controller firmware update might have failed. It should take less than a minute for the new firmware to install. Can you hold the left arrow button to return to a larger menu?

Is it connected to your network?

You could try a factory reset and then attempt to upgrade the firmware again (in the hope that it'll work this time).

Hold down the "+" key while rebooting to peform a factory reset.

MC

Calodoucas
2008-07-14, 04:34
Thanks for the comments.

Yes, my controller is connected to the network.

I tried the factory reset and went through the whole process of upgrading firmware and going through the set up process again.

I just get the same issue - a looping screen 'Connecting to 'player name' that last indefinitely. The only way out of the loop is to switch on/off my player with the old remote, which leaves me with a Home menu displaying the following:

Now Playing
Settings
Extras
Turn On/Off 'Name of player'.

Really frustrating!!!!

ModelCitizen
2008-07-14, 07:10
Hmmm. Odd. It does sound like the firmware is not updating correctly. Maybe you should attempt to ring support. Possibly you have a faulty unit.

MC

Calodoucas
2008-07-14, 09:23
Thanks MC.

I've logged a request with email support. Hopefully they can help.

Cheers, M

Calodoucas
2008-07-15, 06:29
Still no nearer a solution on this.

No feedback from customer support either. Can anyone help?

Sorry to moan but the issue is really frustrating as the Controller is useless without being able to navigate to my music library.

bklaas
2008-07-15, 11:17
Can you access your music library from the webUI? That is, http://squeezecenter.ip.address:9000
(replace squeezecenter.ip.address with the ip of your squeezecenter)

On the controller, what do you see when you enter Settings->Music Source? Anything?

7.0.1 *should* work, but since you're stuck, I might suggest giving 7.1 a try. The problem you are describing makes me think that something is amiss with your controller's connection to SC, and that has been reworked quite a bit in 7.1. Note: after upgrading to 7.1 SC and restarting, a new firmware will be pushed to your controller as well (that's a good thing).

hope that helps,
#!/ben

Calodoucas
2008-07-15, 11:38
Thanks Ben,

I'll give it a try!

I've just spent some time on the phone with customer support who seem to be baffled. They are calling back.

To answer your questions:

Yes I can access my music via the webUI (and my squeeze 3 with old remote).

Settings>Music Source>My computer

I can play the last played track via the Controller but that's it as I don't have the relevant menu items to navigate further!

Thanks for your suggestion.

M

bklaas
2008-07-15, 11:45
Just to clarify, if you press and hold the "back" key on the controller, do you then see a menu item that says "Choose Player"? If so, when entering Choose Player do you see your SB3 in the list? If so, does selecting it result again in the "endless spinny"?

If you can provide it, can you post the full revision details for both your controller (Settings->Advanced->About) and for your SqueezeCenter (Settings->Status). Thanks-

cheers,
#!/ben

Calodoucas
2008-07-15, 11:57
Thnaks Ben, I'll get that info shortly.

In the meantime, what is the best place to download 7.1?

Thanks, M

bklaas
2008-07-15, 12:07
get SC from here:
http://www.slimdevices.com/downloads/nightly/latest/7.1/

then after SC restart, your controller when it connects (and I guess in your case it will be "if it connects") SC will tell the controller about the 7.1 code to upgrade to.

caveat: I'm really not sure 7.1 will fix it, because the problem you describe hasn't been widely reported in 7.0.1. But...7.1, while beta, should be fairly stable, so IMO it can't hurt.

cheers,
#!/ben

Calodoucas
2008-07-16, 03:19
Ben,

I installed 7.1 only to be met with more issues I'm afraid.

There seems to be issues installing 7.1 on OS X - after installation SC wouldn't restart at all.

To cut a very (very) long story short, I clean installed 7.0.1 after stripping SC off my computer and my Controller worked perfectly first time!

After a long and late night setting everything back up I had to shut down before SC had completed a full scan of my music library. This morning SC is refusing to complete a re-scan. I'll pursue this new issue this evening.

At least the Controller now functions perfectly.

Many thanks for all your help, really appreciate it.

Mike

hasemike
2008-08-19, 22:52
I add to this thread because i have exactly the same problem with my controller. Running squeezecenter 7.1, but mostly connecting to squeezenetwork. The problem comes and goes and only a full factory reset of the controller will bring back things to normal.

Also i noticed that the receiver is off when this happens, squeezenetwork sees the receiver as disconnected.

I already tried another router, and now i will install 7.01 on my pc to see if this helps. Also will try a firmware update. The 7.01 does not even startup correctly at the moment, i will try a reinstall of it on the pc.

I am really getting a bit frustrated with this product, since i got it last week it has been nothing but problems, losing connections, this weird menu problem, receiver going offline, install problems with squeezecenter. I feels like a beta product for a lot of money :(