PDA

View Full Version : .NET conflict



entrecour
2008-07-12, 03:49
I am running SC 7.0.1 - 19522 on Vista SP1 32bit.

I have just had to install .NET 1.1(and associated SP and Security update) which is needed by McAfee backup and restore.

After doing this I get a .NET conflict "An unhandled exception has occurred in your application.... .....Only one usage of each socket address (protocol/network address/port) is normally permitted"

SC was working perfectly fine before I installed .NET 1.1, but now it is stopped unless I restart the machine in which case SC starts but McAfee backup will not start.

So it seems to me that this could be a conflict between SC and McAfee Backup with .NET 1.1.

Has any one seen this problem before?

Is it possible to change the socket address for SC to avoid the conflict?

All guidance constructive appreciated.

Phil Leigh
2008-07-12, 04:00
All guidance constructive appreciated.


http://blogs.msdn.com/dgorti/archive/2005/09/18/470766.aspx

entrecour
2008-07-12, 05:58
http://blogs.msdn.com/dgorti/archive/2005/09/18/470766.aspx

Thanks Phil.

I am wondering if that blog entry is for Vista considering the date and that I can't find the MaxUserPort key in the registry.

Phil Leigh
2008-07-12, 08:04
Thanks Phil.

I am wondering if that blog entry is for Vista considering the date and that I can't find the MaxUserPort key in the registry.

Could be but the issue looks very similar and other McAfee user have reportd the same problem. Basically this is a McAfee+Windows issue rather than an SC one.

entrecour
2008-07-12, 14:10
Thanks Phil, I think you are right. I have read a few threads on this in the McAfee support forum. I'll contact their tech support about this.

mherger
2008-07-13, 02:49
> Thanks Phil, I think you are right. I have read a few threads on this in
> the McAfee support forum. I'll contact their tech support about this.

As McAfee Backup is using the same port SC tries to use (9000) there's a conflict. Edit server.prefs and replace httpport 9000 with 9001 or something. Then restart SC. You'll be able to access it using http://localhost:9001 (or whatever port your chose).

--

Michael