PDA

View Full Version : Sever idle but using a lot of processor time



Nick F Ryman-Tubb at MindsI
2004-03-14, 11:55
Dean

It seems to be hogging the processor again - when I restart my server. I am
on a 2.8Ghz XP Pro PC, 1Gb RAM. The slimsvc.exe is taking some 86% of CPU
time (and 44Mb memory) and has been doing this for about 30 mins since
restart. There is almost nothing else running on the PC at all (not that it
would get a chance). I have all the various cache options turned on in
"server settings".

How can I tell what it is doing? Is there a status page to view what the
server is doing, as 30 mins is a LOT of processing. It must be processing my
files again (but there was no need!). I have approx 5,500 songs, about 21Gb
(all MP3).

It has just dropped to 25% and has been at that for the last 20 mins! Any
ideas how I can find out what the server is doing (I see the memory
allocated is creeping up, now at 46.104Mb).

It is frustrating at start up!

Nick


-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com]On Behalf Of dean
blackketter
Sent: 12 March 2004 21:30
To: Slim Devices Discussion
Subject: [slim] Sever idle but using a lot of processor time


That's very strange, it shouldn't use more than 1% of CPU time when
idling. Is it possible it's still scanning your music library or
importing the iTunes Music Library or MoodLogic information?

-dean

On Mar 12, 2004, at 1:25 PM, Nick F Ryman-Tubb at MindsI wrote:

> I have noticed that despite none of the Squeeze boxes being turned "on"
> (just displaying time), the slim-server seems to be using 30%+ of my
> processor time. I have an XP box 2.8Ghz, 1GB RAM, but I am not sure
> why a
> server which ought to be idle is using so much processing time being
> idle?
> I am on version 5.1.1 and wonder if there was perhaps a problem here?
>
> Nick
>
> <winmail.dat>

kdf
2004-03-14, 12:07
Quoting Nick F Ryman-Tubb at MindsI <nrt (AT) mindsitech (DOT) com>:

> Dean
>
> It seems to be hogging the processor again - when I restart my server. I am
> on a 2.8Ghz XP Pro PC, 1Gb RAM. The slimsvc.exe is taking some 86% of CPU
> time (and 44Mb memory) and has been doing this for about 30 mins since
> restart. There is almost nothing else running on the PC at all (not that it
> would get a chance). I have all the various cache options turned on in
> "server settings".
>
> How can I tell what it is doing? Is there a status page to view what the
> server is doing, as 30 mins is a LOT of processing. It must be processing my
> files again (but there was no need!). I have approx 5,500 songs, about 21Gb
> (all MP3).
>
> It has just dropped to 25% and has been at that for the last 20 mins! Any
> ideas how I can find out what the server is doing (I see the memory
> allocated is creeping up, now at 46.104Mb).
>
> It is frustrating at start up!

This is probably the music scan. You can go into server settings, additional,
performance, and set MP3 Tag Cache to on. This may help. To see more of what
is going on, open a command prompt (start, run.., cmd.exe). run c:\program
files\slimserver\server\slim.exe --d_info.

-kdf