View Full Version : 7.0.1 would crash 30-50 seconds after start

2008-07-03, 08:22
I have upgraded to 7.0.1 SqueezeCenter on a fully updated/patched G5/10.4 desktop.

When I try to start the server, the following two entries appear in the SqueezeCenter/server.log:

[08-07-03 10:10:45.9217] DBIx::Migration::migrate (115) Warning: Database error: Can't DROP 'thumb'; check that column/key exists at /Users/leo/Library/PreferencePanes/SqueezeCenter.prefPane/Contents/server/CPAN/DBIx/Migration.pm line 115.

[08-07-03 10:10:45.9236] Slim::Schema::forceCommit (1368) Warning: Trying to commit transactions before DB is initialized!

The strange this is that the offending file (CPAN/DBIx/Migration.pm) does not exist; in fact the entire DBIx directory doesn't exist in the tree.

I tried to downgrade to an earlier version (~6) with no success.

Any suggestions?

Phil Leigh
2008-07-03, 08:34
is this you again?

and this person had the same problem

2008-07-03, 16:20
Yes Phil, that was my post as well. First with 7.0 and now with 7.0.1, I cannot run the server. I tried to search for similar problems described in the forum. While some come close to mine, no solution seems to be working.

Then I tried to downgrade to 6.5.4. Well, it starts fine now but it cannot see all the music in my iTunes library. (I run iTunes 7.6.2 (9)). All music files are on the local drive of the machine where the server is running.

This has been a heck of a frustrating experience. One day, SlimServer tells me that there is a new version and prompts me to install it. I do so (version 7) and it wont start any more. I downgrade to what worked before and can't find the music anymore. In the meantime I am staring at $1,000 worth of squeezeboxes around the house that sit dark and useless. It's quite frustrating.

2008-07-03, 21:28
> Then I tried to downgrade to 6.5.4. Well, it starts fine now but it

Please try to remove _any_ trace of 6.5 before installing 7.x. Search your
filesystem for folders called SlimServer and remove them. Eg. in
/lib/cache etc.


2008-07-04, 18:11
Thanks Mike, but there is no /lib directory in the OSX tree. If by /lib/cache you meant /Library/Caches/, there is not a single object therein associated with slimserver.

Any other ideas?

2008-07-04, 18:16
have you tried the 7.1 beta?

2008-07-06, 18:08
Yes, I have tried the current beta version. It crushes too. -leo