PDA

View Full Version : streaming aac files over the internet



William McCallum
2004-03-12, 23:59
I can use iTunes to open an mp3 stream to my slimserver from a remote
computer, and listen to my mp3 files. However, when I try to listen to
files that are in the aac format, iTunes keeps pausing to refill the
buffer.

I solved a similar problem with the Squeezebox by installing lame and
adding a configuration file as explained on the slimserver website.
This causes slimserver to convert aac to mp3 on the fly before sending
it to the Squeezebox.

I suspect my problem with internet streaming is the same, and that
slimserver is not converting aac files when it streams them. The key
line in the configuration file for the squeezebox problem was

mov mp3 squeezebox *
$mov123$ $FILE$ | $lame$ --silent -b 320 -r $-x$ - -

I thought of trying to make a similar line with the word "squeezebox"
replaced by "http", to tell slimserver to convert files before
streaming them to the web, but this didn't work.

Does anybody have any other ideas?

Thanks,
Bill McCallum

dean
2004-03-13, 07:37
Hi Bill,

A line like that should work, but you probably don't want to stream at
320kbps. The default configuration is this one:

mov mp3 * *
$mov123$ $FILE$ | $lame$ --silent -b $BITRATE$ -r - -

which uses the bitrate setting in the player settings to determine what
bitrate to use when streaming. You can change it there or add a new
line:

mov mp3 http *
$mov123$ $FILE$ | $lame$ --silent -b 96 -r - -

Which would stream at a fixed 96kbps.



On Mar 12, 2004, at 10:59 PM, William McCallum wrote:

> I can use iTunes to open an mp3 stream to my slimserver from a remote
> computer, and listen to my mp3 files. However, when I try to listen to
> files that are in the aac format, iTunes keeps pausing to refill the
> buffer.
>
> I solved a similar problem with the Squeezebox by installing lame and
> adding a configuration file as explained on the slimserver website.
> This causes slimserver to convert aac to mp3 on the fly before sending
> it to the Squeezebox.
>
> I suspect my problem with internet streaming is the same, and that
> slimserver is not converting aac files when it streams them. The key
> line in the configuration file for the squeezebox problem was
>
> mov mp3 squeezebox *
> $mov123$ $FILE$ | $lame$ --silent -b 320 -r $-x$ - -
>
> I thought of trying to make a similar line with the word "squeezebox"
> replaced by "http", to tell slimserver to convert files before
> streaming them to the web, but this didn't work.
>
> Does anybody have any other ideas?
>
> Thanks,
> Bill McCallum
>
>

William McCallum
2004-03-13, 19:12
Thanks, that worked.

On Mar 13, 2004, at 7:37 AM, dean blackketter wrote:

> Hi Bill,
>
> A line like that should work, but you probably don't want to stream at
> 320kbps. The default configuration is this one:
>
> mov mp3 * *
> $mov123$ $FILE$ | $lame$ --silent -b $BITRATE$ -r - -
>
> which uses the bitrate setting in the player settings to determine
> what bitrate to use when streaming. You can change it there or add a
> new line:
>
> mov mp3 http *
> $mov123$ $FILE$ | $lame$ --silent -b 96 -r - -
>
> Which would stream at a fixed 96kbps.
>
>
>
> On Mar 12, 2004, at 10:59 PM, William McCallum wrote:
>
>> I can use iTunes to open an mp3 stream to my slimserver from a remote
>> computer, and listen to my mp3 files. However, when I try to listen
>> to files that are in the aac format, iTunes keeps pausing to refill
>> the buffer.
>>
>> I solved a similar problem with the Squeezebox by installing lame and
>> adding a configuration file as explained on the slimserver website.
>> This causes slimserver to convert aac to mp3 on the fly before
>> sending it to the Squeezebox.
>>
>> I suspect my problem with internet streaming is the same, and that
>> slimserver is not converting aac files when it streams them. The key
>> line in the configuration file for the squeezebox problem was
>>
>> mov mp3 squeezebox *
>> $mov123$ $FILE$ | $lame$ --silent -b 320 -r $-x$ - -
>>
>> I thought of trying to make a similar line with the word "squeezebox"
>> replaced by "http", to tell slimserver to convert files before
>> streaming them to the web, but this didn't work.
>>
>> Does anybody have any other ideas?
>>
>> Thanks,
>> Bill McCallum
>>
>>