PDA

View Full Version : Problem



captain-insano
2008-07-02, 22:31
My squeezebox seems to have always had a problem when I ran it wireless. Well I have a new server and wireless router and am still getting this error in the log file.

[08-07-02 23:17:56.5711] Slim::Player::Source::errorOpening (1645) Error: While opening current track, so mark it as already played!
[08-07-02 23:17:56.5715] Slim::Player::Source::errorOpening (1645) Backtrace:

frame 0: Slim::Utils::Log::logBacktrace (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Player/Source.pm line 1645)
frame 1: Slim::Player::Source::errorOpening (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Player/Squeezebox2.pm line 610)
frame 2: Slim::Player::Squeezebox2::failedDirectStream (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Networking/Slimproto.pm line 561)
frame 3: Slim::Networking::Slimproto::_disco_handler (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Networking/Slimproto.pm line 381)
frame 4: Slim::Networking::Slimproto::client_readable (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Networking/Select.pm line 243)
frame 5: (eval) (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Networking/Select.pm line 243)
frame 6: Slim::Networking::Select::select (slimserver.pl line 503)
frame 7: main::idle (slimserver.pl line 43)
frame 8: PerlSvc::Startup (perlsvc line 851)
frame 9: PerlSvc::_startup (slimserver.pl line 0)
frame 10: (eval) (slimserver.pl line 0)

[08-07-02 23:19:09.1044] Slim::Player::Source::errorOpening (1645) Error: While opening current track, so mark it as already played!
[08-07-02 23:19:09.1050] Slim::Player::Source::errorOpening (1645) Backtrace:

frame 0: Slim::Utils::Log::logBacktrace (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Player/Source.pm line 1645)
frame 1: Slim::Player::Source::errorOpening (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Player/Squeezebox2.pm line 610)
frame 2: Slim::Player::Squeezebox2::failedDirectStream (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Networking/Slimproto.pm line 561)
frame 3: Slim::Networking::Slimproto::_disco_handler (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Networking/Slimproto.pm line 381)
frame 4: Slim::Networking::Slimproto::client_readable (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Networking/Select.pm line 243)
frame 5: (eval) (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Networking/Select.pm line 243)
frame 6: Slim::Networking::Select::select (slimserver.pl line 503)
frame 7: main::idle (slimserver.pl line 43)
frame 8: PerlSvc::Startup (perlsvc line 851)
frame 9: PerlSvc::_startup (slimserver.pl line 0)
frame 10: (eval) (slimserver.pl line 0)

[08-07-02 23:19:57.1482] Slim::Player::Source::errorOpening (1645) Error: While opening current track, so mark it as already played!
[08-07-02 23:19:57.1486] Slim::Player::Source::errorOpening (1645) Backtrace:

frame 0: Slim::Utils::Log::logBacktrace (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Player/Source.pm line 1645)
frame 1: Slim::Player::Source::errorOpening (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Player/Squeezebox2.pm line 610)
frame 2: Slim::Player::Squeezebox2::failedDirectStream (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Networking/Slimproto.pm line 561)
frame 3: Slim::Networking::Slimproto::_disco_handler (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Networking/Slimproto.pm line 381)
frame 4: Slim::Networking::Slimproto::client_readable (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Networking/Select.pm line 243)
frame 5: (eval) (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Networking/Select.pm line 243)
frame 6: Slim::Networking::Select::select (slimserver.pl line 503)
frame 7: main::idle (slimserver.pl line 43)
frame 8: PerlSvc::Startup (perlsvc line 851)
frame 9: PerlSvc::_startup (slimserver.pl line 0)
frame 10: (eval) (slimserver.pl line 0)

Can anyone give me some guidance? I am lost. I have the option of hooking the Squeezebox to the server directly. My server specs AMD64 4400 with 2GB of DDR1066. Running on Windows 2003 Server. My music folder is on two mirrored 500GB drives. When I listen to Internet radio the music stops and the screen on my Squeezebox gets garbled. Thanks in advance for any suggestions.

Phil Leigh
2008-07-03, 08:41
need more info:
what OS
what version of SC
what format are your files?
what happens on the display and in the web GUI?

have you run the server and network health test?

captain-insano
2008-07-17, 14:13
OS is Windows 2003 Server
Squeezecenter is 7.0.1
Files are in FLAC format
The Display becomes garbled
In Squeezecenter I notice nothing. Sorry it took me so long to reply i have been on a much needed vacation. Network test says signal is ok. Where is the server test located?

Just curious about the network test. When I scroll to it initially it selects 64kpbs and the graphic appears to fill up and reports 100% Average:100%. However when I scroll down to select the faster speeds the graphic stays pegged and reports the 100% Average:100% graphic. It appears the network test runs for 64kbps and not the others. Is there another button I need to push on the remote?

Phil Leigh
2008-07-17, 23:15
in the web Gui, click on the HELP icon, then select server & network health
and then select the rate. You need >=100 @ 1500kbps for flac.
If that is OK, then use the Performance Monitoring option to check that the server and SB are talking happily...

captain-insano
2008-07-18, 10:35
I found the network test last night finally. I ran the test at 5000kbps. Here is a screenshot of the test. It appears to be ok or am I wrong?

captain-insano
2008-07-18, 15:42
I finally saw what was on the display. Connection reset by localhost was the message at the top, the analog vu meters, the disc number and the title is also displaying. It remains like this for a few seconds then defaults back to the vu meters which are not moving. I have the system set to use the analog vu meters will playing.

captain-insano
2008-07-24, 22:42
Any suggestions? Or it appears the log file is about as useless as a windows error message?

graham_alton
2008-08-11, 00:25
Have you got this sorted out yet? I'm seeing the same error "Error: While opening current track, so mark it as already played!" while running my SqueezeBox Duet with a Linux server, I've tried various combinations of Fedora 9 and Ubuntu 8.04 with SqueezeCenter 7.0, 7.01, 7.1, 7.2 and even 7.3 but they all barf.