View Full Version : Install on linux: wrong GPG keys

2008-06-22, 08:08
When I try to install Squeezecenter 7.0.1 via yum update (following the description on the wiki page) I get the following error:

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
squeezecenter noarch 7.0.1-1 squeezecenter-release 18 M

Transaction Summary
================================================== ===========================
Install 1 Package(s)
Update 0 Package(s)
Remove 0 Package(s)
Total download size: 18 M
Is this ok [y/N]:
Downloading Packages:
warning: rpmts_HdrFromFdno: V3 RSA/MD5 signature: NOKEY, key ID c3cdadd1
Public key for squeezecenter-7.0.1-1.noarch.rpm is not installed
Retrieving GPG key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-SqueezeCenter
Importing GPG key 0xC3CDADD1 "Logitech <gpg@slimdevices.com>"
Is this ok [y/N]: Key imported successfully
Import of key(s) didn't help, wrong key(s)?

And squeezecenter does not install. Does somebody now what is going wrong, and how I can fix this? Many thanks.

Mark Miksis
2008-06-22, 08:47
What version of squeezecenter-repo do you have installed? Make sure it's 1-4. There were some problems back when the repos were first set up where the keys got changed so older repo RPMs have bad keys.

2008-06-22, 08:53
It is the 1-4 version

Mark Miksis
2008-06-22, 09:22
OK, you have the right key. I just tested this and it works fine for me. Maybe you have a corrupt download. Try:

yum clean all
yum install squeezecenter

What Linux distro is this?

2008-06-22, 09:37
The distro is CentOS 4.6.
I tried the install after a clean as you suggested, but I get the same error message.

Mark Miksis
2008-06-22, 10:38
OK, I can reproduce this on CentOS 4.6. I have no clue what's wrong, but I'll file a bug. In the meantime, you can get SC installed by disabling the gpgcheck. Edit /etc/yum.repos.d/squeezecenter.repo and change gpgcheck=1 to gpgcheck=0.

2008-06-22, 11:16
Ok. Many thanks for your help!