PDA

View Full Version : lot's of backgroud noise like tape hiss



funkahdafi
2008-06-14, 13:50
Hi,

I recently noticed that a lot of my tracks being played over a Duet (server 7.01 on mac os x) have a lot of backgrond noise, like white static or as if you would play old tapes.

When listening to these tracks with iTunes or whatever, I don't get that noise.

I think I can pretty much rule out bad encondings. They are all high quality rips directly from digital media like CD or from iTunes store. Also, the Duet is connected via digital link, not analog, so I think I can also rule out bad cables or analog interferences.

Maybe this is related, but I really have to pump up the volume of the speakers/stereo connected to the Duet. As if the server would send the tracks at really low volume. Maybe the static is coming from that.

Any ideas what might be wrong here?

Thanks
Sascha

bigfool1956
2008-06-14, 14:07
Have you accidentally turned down the volume?

funkahdafi
2008-06-14, 14:53
what do you mean? where? on the controller? no.

andynormancx
2008-06-14, 15:09
Do you have the Volume Adjustment turned on, if so try turning it off.

funkahdafi
2008-06-14, 15:13
Do you have the Volume Adjustment turned on, if so try turning it off.

tried that already. doesn't help.

I think it's only with mp4 files. I don't seem to have his issue with mp3.

pablolie
2008-06-14, 16:09
what is your amp or loudspeaker setup? also, have you modified the gain settings either in the files themselves or in SC (preamp volume control being a possible culprit?)?

funkahdafi
2008-06-15, 01:35
what is your amp or loudspeaker setup? also, have you modified the gain settings either in the files themselves or in SC (preamp volume control being a possible culprit?)?

not that I knew of. I didn't know you can do that in SC. Where is it?

funkahdafi
2008-06-15, 01:36
never mind, I found the setting. however, regarding to the tooltip help for that this is only applied to analog outputs. I am using digital outputs.

Mnyb
2008-06-15, 01:55
Do you use "fixed" digital output ? or do you use volume control with the digital output ?

Mnyb
2008-06-15, 01:57
And the gain settings for files is not only for analog outputs ?
they would aply if you allow digital volume control.

funkahdafi
2008-06-15, 01:58
And the gain settings for files is not only for analog outputs ?
they would aply if you allow digital volume control.

well I just repeat what the documentation says: for analog output only.

Yes, I am using volume control because that's what I need.

Mnyb
2008-06-15, 02:44
Where is your normal listening volume ? Your hopefully aware of that the digital volume is reducing bits so the noisefloor is creeping closer.
What amp or dac is the SB connected to you could just try the volume on that instead, and use the full volume of the SB to see if the problem goes away.

I don't have the spec for the SB digital volume in my head. In conjuction with the built in dac i think it operates from 24bits so this will only be a problem with low volumes.
I don't know how the bit reducing thing works from the digital out I asume it starts with 16bits and lowers from there, I'm not aware off any uppsampling in the SB

Do you have a very loud system ? with lots off gain and efficient speakers.

funkahdafi
2008-06-15, 02:59
Where is your normal listening volume ? Your hopefully aware of that the digital volume is reducing bits so the noisefloor is creeping closer.


No, I am not aware of this. What exactly does it mean?



What amp or dac is the SB connected to you could just try the volume on that instead, and use the full volume of the SB to see if the problem goes away.


It doesn't matter to what it is connected to. I have three SBs around the house. One is connected to a high end Denon AVR4306, the other to an Apple Hifi speaker system, third is not relevant right now. I get the hiss on all the amps, no matter how I tune them (tried upping the volume on the SB and lowering it on the amp, and vise versa).

Also, I really would like to press that this only happens on MP4 files, not on MP3. Looks to me as if there is something wrong with the MP4 decoding.

Also, might the wireless connection introduce noise? I feed the SB over WiFi.



I don't have the spec for the SB digital volume in my head. In conjuction with the built in dac i think it operates from 24bits so this will only be a problem with low volumes.


It is very present at any volume combination. No matter what I do. The noise only start when a track actually start playing. When the track is finished, there is no more noise. There is also no noise when paused/stopped.



Do you have a very loud system ? with lots off gain and efficient speakers.

In one case, yes. Denon AVR4306 feeding large Dynaudio Contour high end speakers.

I really appreciate you trying to help me here! :-)

Sascha

Mnyb
2008-06-15, 03:14
Aaaa only for MP4 files then I'm totaly lost here ? (sorry i did'nt notice)

but i'm strongly suggest that you fix the volume for the SB connected to the AVR4306 this setting is per player so it won't affect the other zones.
Drawback is that you have to use the Denons volume for the main rig.

SPDIF (the digital or coax) have no metadata so it's just a raw 16/44 or whatever bit stream so the only way to accomplish "volume" is to reduce bits.
So the SB can not "tell" the Denon what volume to play, you have to alter the data.

Sorry I have no MP4 or m4a files ? there must be something awol with the decoding/encoding I use only flac.

btw.
The big Dynaudio is nice :-) I use a MeridianG68J and a SiriuS DMX200 to a pair of Contour 4.0 as front pair, an old model but very good.

Mnyb
2008-06-15, 03:17
I last note How do you transcode ?

mp4 is not native to the SB3 so it's trancoded on the server.
I suggests transcoding to flac.

this will be a lossy encoding to lossles trancode.

mp4 to mp3 tracoding is lossy to lossy and this IS known to introduce artefacts.

check your file types settings.

funkahdafi
2008-06-15, 03:18
Dynaudio rocks :-)) I also have an old model (the 3.3) but I am more than happy with them.

Ok, so digital output is actually bad if I get it right. Reducing the bits sucks. I am going to switch to analog. Maybe this will eliminate the problem.

Cheers!

funkahdafi
2008-06-15, 03:20
I last note How do you transcode ?

mp4 is not native to the SB3 so it's trancoded on the server.
I suggests transcoding to flac.

this will be a lossy encoding to lossles trancode.

mp4 to mp3 tracoding is lossy to lossy and this IS known to introduce artefacts.

check your file types settings.

I am using the default setup, so I guss it's already transcoding to flac. Didn't chang anything there.

Mnyb
2008-06-15, 03:32
I would not say that digital out is bad I use that as the dacs in my meridian is superior to the SB3, but i don't use the volume control.
So the digital out is the preferred output to HT equipment as most HT amps digitize it's analog inputs anyway, any kind of processing including subwofer filter is done digital, so I think digital is better.
I use my Meridian preamp for volume. and has the SB volume for that player on fixed.

You could go analog if your Denon has analog bypass, but as you said you have the noise on other players around the house, so i'm guessing this won't solve our problem

And as you said theres something with your mp4 decoding if its fine with mp3 or flac or WAV, theres nothing wrong with your amp conection with digital if it works with all other files but mp4.

I know tw**t about mp4 so whats the bitrate how are these ripped ?
You might want to send a file to a forum member that does use mp4.
I have a clarkconnect linus server, so i doubt that i can play these without severe fidling with it, the AAC options in Advanced > filetypes is greyd out on my server so i can not listen to any of your files.

funkahdafi
2008-06-15, 03:42
The thing is... I want to use the volume control of the SB. If I have to go to the amp and fiddle with the volume there, that doesn't make much sense to me. Destroys the whole concept of the Duet (one controller for everything). I have the Duet controller and want to do everything from there. And if digital volume control is cutting out bits, that's a total no go for me. So I will definitely switch to analog.

I checked the MP4 transcoding settings. It says it is using mov123 for the transcoding. There is no other setting available.

The other thing is I am using Mac OS X on intel processors. With each new release of SqueezeCenter I have to change the setting for the transcoding from little endian to big endian because the SC people just don't get it that little endian was used back on the PowerPC days (might be the other way around, from big to little, I don't remember). If I don't do that, all my MP4 don't play at all. Maybe it's got omething to do with that.

Mnyb
2008-06-15, 04:06
Well it depend's i dont know much about the denon.
So you have to try, beware that with some level mismatch you might be trowing away more SN ratio or bit's by going Digital > analog <digital and analog to the speakers.

As i said the analog volume on the SB is also digital but probably at a higher bit rate 24bit (soon some senior forum member IS coming to browbeat me about this :) ).

What is best in practice you have to experiment with.
But don't automatically sneeze at bit reducing, it can be better than the alternative.
And at 24 bit it is better than analog volume, it's whats my preamp is doing anyway (it's upsampling everything to 24/96 prior to processing )

But my experience is that most Analog to digital converters in HT amp's is rather lowfi you use it for ye olde VHS and tape deck and similar uncritical applications.

And my kitchen setup with an SBR is done so that volume off my active speakers is such that when the SBR volume is maxed out it is roughly as loud as i ever want to play. So adjust the volume on the amps conected to the SB to use as much of it's range as possible that's best practice afiak.

toby10
2008-06-15, 04:09
..........You might want to send a file to a forum member that does use mp4. I have a clarkconnect linus server, so i doubt that i can play these without severe fidling with it, the AAC options in Advanced > filetypes is greyd out on my server so i can not listen to any of your files.

Funkahdafi: I'd try Mnyb's suggestions so you can eliminate the mp4 files as a possible cause. You can fiddle with settings till your fingers turn blue, but if the files have *hiss* encoded in them then you just waisted a lot of time.

- try digital volume control to FIXED (temporary while you diagnose problem)
- send a known *hissy* mp4 to another user for evaluation

Phil Leigh
2008-06-15, 04:49
IMHO the problem is nothing to do with the OP's hardware. This is obviously the case since he has no problems except with M4a files.

Also this is nothing to do with the SB volume/gain controls - you don't get "hiss" by reducing the bit depth - you get a grungy sound at very very low volumes.

I would check that these files are not encoded with SoundCheck (Apple replaygain). Also check that replaygain is turned off in SC (settings - players - audio.

An example file would be helpful...how did you rip/encode these m4a files?

radish
2008-06-15, 06:14
Just to correct a few things regarding the volume control on the SB. Yes it is digital, yes it works by "throwing away" bits, but the output is 24bit not 16bit and the decrease in SNR shouldn't be noticeable with moderate use. The recommendation is do setup the amp so it's about right with the SB at max, and then use the SB for fine control.

funkahdafi
2008-06-15, 06:41
Hi,

to clarify:

These files are top notch quality. They play without any hiss on any other player (like from within iTunes or on my iPod or through Winamp on Windows). So it's only on the SB Duet where the files are causing problems.

ReplayGain is turned off in SC.

I also don't seem to have had this problem a while back, so I am guessing it was introduced with one of the recent SC upgrades. I tried 7.1 today, but I get the same thing.

The noise also seems to dynamically adjust. e.g. in portions of the track that have limited volume, the noise is going down. When the track builds up, the noise builds up. I have attached a track to this thread which will perfectly show this behavior in the first couple of seconds of the track, where two or three chords of piano are played, with silence inbetween them. As soon as the piano chors hits the silence, you can hear how the noise increases and then goes down again once the piano chord is over.

Please note that SC is running on Mac OS X (Intel based). Maybe that's of importance. Every new version of SC that is released for Mac has the wrong conversion setting in the convert.conf. It is telling FLAC to use big endian instead of little endian. Big endian is not working on Intel based processors, it is only working on PPC processors. See my seperate thread for this in the developer subforum. Maybe this is related.

funkahdafi
2008-06-15, 06:44
since the file is too big for the forum, I uploaded it here:

http://drop.io/r9tahqg

Eric Seaberg
2008-06-15, 08:21
I DL'd the file and it looks and sounds OK here... WOW! Something that actually has DYNAMICS and isn't squared off at the top!!

Not sure what to say about the hiss... it's not in the track!

andynormancx
2008-06-15, 11:03
Also no hiss when played back on my Duet.

pablolie
2008-06-15, 11:54
File sounds fine on my setup.

So the hiss starts when you play this file, and the setup is silent otherwise, or is there a high noise floor all the time? Is there hiss when powering off the Squeezebox? Make sure there are no adverse power effects.

andynormancx
2008-06-15, 13:46
File sounds fine on my setup.

So the hiss starts when you play this file, and the setup is silent otherwise, or is there a high noise floor all the time? Is there hiss when powering off the Squeezebox? Make sure there are no adverse power effects.

He already said that the hiss stops when he pauses.

funkahdafi
2008-06-15, 20:27
File sounds fine on my setup.

So the hiss starts when you play this file, and the setup is silent otherwise, or is there a high noise floor all the time? Is there hiss when powering off the Squeezebox? Make sure there are no adverse power effects.

No. As I said earlier.

No noise when paused, stopped or turned off. Hiss is only present when playing MP4 files (mov123 to flac conversion). Everything else is perfect, no noise when playing other formats.

pablolie
2008-06-15, 22:35
for what it is worth, i noticed that the AAC did not play on my Linux based server at first. i have standardized my music collection on flac and mp3, so it is not a big deal, but it did surprise me. thus i did some searching on these forums, and saw there are issues with AAC with some regularity. the AAC played on my Linux server after installing some additional modules; and i have never had issues on my other, Vista based server. however it seems obvious it is not the favorite music format for the squeezebox. a possible suggestion -albeit inconvenient- is to reinstall Quicktime and then Squeezecenter from scratch. there are threads indicating that has helped some other Windows and Mac based installations before.

seanadams
2008-06-15, 22:59
Based on the comments here it seems pretty clear that this is a server side problem with mp4 decoding. There's nothing involving volume settings or cabling that could cause noise to occur for only one format.

To the people who just said that it sounds OK on their system: what is your OS and CPU type?

If there is some byte ordering or alignment issue, it is conceivable that perhaps the top 8 bits are OK and the lower 8 bits are garbage. That would case a lot of white hiss, while still hearing the music over it.

funkahdafi
2008-06-15, 23:14
Based on the comments here it seems pretty clear that this is a server side problem with mp4 decoding. There's nothing involving volume settings or cabling that could cause noise to occur for only one format.

To the people who just said that it sounds OK on their system: what is your OS and CPU type?

If there is some byte ordering or alignment issue, it is conceivable that perhaps the top 8 bits are OK and the lower 8 bits are garbage. That would case a lot of white hiss, while still hearing the music over it.

That really sounds like it makes sense. As I said, this problem was only introduced recently, I think it started with some of the early 7.x builds.

Maybe there is some sort of incompatibility between the mov123 component and the recent Mac OS updates (10.5.x, Quicktime 7.x).

Plus there is this problem with big vs. little endian being set the wrong way in the default convert.conf file, for which I already opened a bug (nr. 8434).

If anyone from Slimdevices, ehrm, Logitec for that matter, needs more detailed information about my setup, please let me know. I am happy to help and get this fixed, because at least 50% of my music collection are AAC/MP4 and it's really no fun right now.

andynormancx
2008-06-16, 00:58
To the people who just said that it sounds OK on their system: what is your OS and CPU type?
XP on Intel.

Phil Leigh
2008-06-16, 05:57
XP on Intel/AMD is OK.

rdefelice
2008-06-16, 10:36
I am also experiencing this issue. I can second that I believe it has to do with the transcoding of the audio on the server side. In my setup, I've got two players: a duet receiver and squeezeslave running on my media center pc that also runs SqueezeCenter.

Every AAC file I play on the duet receiver sounds fine (no transcoding on the server), but I hear a hiss when I play it via squeezeslave (which requires the server to transcode the AAC to MP3 before sending it to the player).

I've tried upping the LAME quality setting, but it has no effect. Anyone have any ideas?

Specifics on my setup:
SqueezeCenter/squeezeslave:
Gentoo Linux
SqueezeCenter 7.0
squeezeslave 0.7.5
LAME 3.97

relevant parts of my convert.conf:

mov mp3 * *
[faad] -w -f 2 $FILE$ | [lame] --resample 44100 --silent -q $QUALITY$ -b $BITRATE$ -r - -
mov wav * *
[mplayer] -novideo -ao pcm:nowaveheader:file=/dev/fd/4 $FILE$ 4>&1 1>/dev/null
mov aif * *
[mov123] $FILE$

Nonreality
2008-06-16, 11:13
It's simple. Apple doesn't like you playing their encodings on a Squeezebox. Using a none Apple product, shame on you. If you keep doing it they will self destruct.

ChrisOwens
2008-06-16, 13:03
I went ahead and created a bug for this issue:

http://bugs.slimdevices.com/show_bug.cgi?id=8444

Eric Seaberg
2008-06-16, 19:37
To the people who just said that it sounds OK on their system: what is your OS and CPU type?

I'm running SqueezeCenter Version 7.0.1 - 19352 because the 'official' 7.01 doesn't work with some of my plug-ins and certainly creates other problems.

I'm running on a Mac MINI with OS 10.4.11 and haven't had problems playing anything. Even 'gapless' playback hasn't been an issue with ALAC files (my preferred encode type). Everything works, including sync between my Transporter and SB3 playing ALAC files. It's all good.

(I've spent a lot of time cleaning up my home network which, I believe, makes ALL the difference with this stuff).

funkahdafi
2008-06-17, 07:48
I went ahead and created a bug for this issue:

http://bugs.slimdevices.com/show_bug.cgi?id=8444

Thanks for opening the bug Chris. Why did you target the resolution for the 7.2 release? Isn't that kind of far away?

rdefelice
2008-06-17, 08:17
I am also experiencing this issue. I can second that I believe it has to do with the transcoding of the audio on the server side. In my setup, I've got two players: a duet receiver and squeezeslave running on my media center pc that also runs SqueezeCenter.

Every AAC file I play on the duet receiver sounds fine (no transcoding on the server), but I hear a hiss when I play it via squeezeslave (which requires the server to transcode the AAC to MP3 before sending it to the player).

I've tried upping the LAME quality setting, but it has no effect. Anyone have any ideas?

Specifics on my setup:
SqueezeCenter/squeezeslave:
Gentoo Linux
SqueezeCenter 7.0
squeezeslave 0.7.5
LAME 3.97

relevant parts of my convert.conf:

mov mp3 * *
[faad] -w -f 2 $FILE$ | [lame] --resample 44100 --silent -q $QUALITY$ -b $BITRATE$ -r - -
mov wav * *
[mplayer] -novideo -ao pcm:nowaveheader:file=/dev/fd/4 $FILE$ 4>&1 1>/dev/null
mov aif * *
[mov123] $FILE$


I've done a bit more research, and I now believe that faad may be to blame. I'm running version 2.0-r13, and while playing around with it on the command line I noticed that it outputs differently depending on whether you give it the option to write the output to stdout or let it write the file to disk itself. I was able to get a clean transcode to mp3 from AAC by running the following commands:

faad song.m4a
cat song.wav | lame --silent -q 8 -b 192 - song.mp3

However, when I run this, I get an mp3 with the aforementioned background static:

faad -w song.m4a | lame --silent -q 8 -b 192 - song.mp3

So I now believe the problem is introduced when faad is told to output to stdout rather than to write to a file. Can anyone recommend a version of faad or an equivalent binary that outputs cleanly to stdout?

-r

rdefelice
2008-06-17, 08:28
I've done a bit more research, and I now believe that faad may be to blame. I'm running version 2.0-r13, and while playing around with it on the command line I noticed that it outputs differently depending on whether you give it the option to write the output to stdout or let it write the file to disk itself. I was able to get a clean transcode to mp3 from AAC by running the following commands:

faad song.m4a
cat song.wav | lame --silent -q 8 -b 192 - song.mp3

However, when I run this, I get an mp3 with the aforementioned background static:

faad -w song.m4a | lame --silent -q 8 -b 192 - song.mp3

So I now believe the problem is introduced when faad is told to output to stdout rather than to write to a file. Can anyone recommend a version of faad or an equivalent binary that outputs cleanly to stdout?

-r

After finding faad to be the culprit, I downloaded and compiled a new version (2.6.1) and it works beautifully even when outputting to stdout. This has solved my problem with the background noise/hiss. I hope this helps those of you who are experiencing the same problem.

-r

bpa
2008-06-17, 08:31
A lot of people use faad without any problem so it may be a build issue rather faad per se. Your version of faad seems to be very old - 2.5 is the current version.

You should compare the output of faad between command line and pipe (i.e binary comapre song.wav and songstd.wav) to comfirm there is a difference.

faad song.m4a

faad -w song.m4a >songstd.wav

rdefelice
2008-06-17, 08:51
A lot of people use faad without any problem so it may be a build issue rather faad per se. Your version of faad seems to be very old - 2.5 is the current version.

You should compare the output of faad between command line and pipe (i.e binary comapre song.wav and songstd.wav) to comfirm there is a difference.

faad song.m4a

faad -w song.m4a >songstd.wav

The only reason I had the old version is because that was actually marked as the current stable version in Gentoo. Version 2.6.1-r1 was masked because it was considered unstable, but I forced the upgrade and it is working great for me so far.

Just for the record, I did compare the output as you described and while the file sizes only differed by 1 byte, the contents were very different after the first few bytes.

-r

funkahdafi
2008-06-17, 08:53
@rdefelice: No offense, but could you please open another thread for this? I am more than sure that your problem is a different one than mine. I am not even using faad or Linux.

Thanks

bpa
2008-06-17, 08:57
A workaround (pending proper solution) to the hiss problem on OSX might be to try to use faad instead of mov123.

rdefelice
2008-06-17, 09:21
@rdefelice: No offense, but could you please open another thread for this? I am more than sure that your problem is a different one than mine. I am not even using faad or Linux.

Thanks

Sorry. Didn't mean to hijack your thread, but I do believe our problems are somewhat related. I would maybe try to find a replacement for mov123 on OSX. You might want to give faad 2.6.1 a try.

-r

funkahdafi
2008-06-17, 09:23
Any instructions on how to use faad? Is it even available for Mac?

Phil Leigh
2008-06-17, 09:32
Any instructions on how to use faad? Is it even available for Mac?

I believe Faad is available for OS X

rdefelice
2008-06-17, 09:40
Any instructions on how to use faad? Is it even available for Mac?

If you have darwinports installed, you can get it that way. See
http://faad2.darwinports.com/ for more info.

If you prefer not to use darwinports and have the developer tools installed, you can download the source code from http://www.audiocoding.com/downloads.html. Once you grab the zip or the .tar.gz file, you can decompress it and follow the instructions in the README.linux file. I just confirmed it compiles just fine in OSX for me.

Once you install it, change your convert.conf so that it uses faad instead of mov123 under the "mov mp3 * *" entry. Also, you might need to play with the -r and -x flags in the lame usage flags depending on what byte order faad outputs on your system.

-r

funkahdafi
2008-06-17, 10:14
If you have darwinports installed, you can get it that way. See
http://faad2.darwinports.com/ for more info.

If you prefer not to use darwinports and have the developer tools installed, you can download the source code from http://www.audiocoding.com/downloads.html. Once you grab the zip or the .tar.gz file, you can decompress it and follow the instructions in the README.linux file. I just confirmed it compiles just fine in OSX for me.

Once you install it, change your convert.conf so that it uses faad instead of mov123 under the "mov mp3 * *" entry. Also, you might need to play with the -r and -x flags in the lame usage flags depending on what byte order faad outputs on your system.

-r

As a matter of fact I have darwinports installed :)

But did I get it right that by using faad I will re-encode to MP3? I really don't want to do this...

While we are at it: How does SC decide which entry in the convert.conf to use? I can setup multiple decoding entries for a single file type (same thing in the SC webinterface, where I have three choices per filetype). How do I tell which one is being used?

Thanks, btw...

rdefelice
2008-06-17, 10:25
As a matter of fact I have darwinports installed :)

But did I get it right that by using faad I will re-encode to MP3? I really don't want to do this...

While we are at it: How does SC decide which entry in the convert.conf to use? I can setup multiple decoding entries for a single file type (same thing in the SC webinterface, where I have three choices per filetype). How do I tell which one is being used?

Thanks, btw...

I may be wrong (please someone speak up if I am), but I believe that SC decides which transcoding option to use based on the capabilities of the player and a few rules. For players that don't natively support AAC I think it prefers to go mov->mp3 rather than mov->wav to reduce the amount of data streaming over the network to the player from SC. Streaming uncompressed audio over the network might choke a slower wifi network, for example. You can create custom rules for certain players given the player name and/or mac address if you want to force it to stream a certain format to a specific player, but I don't really know how to make a certain format the default.

The easiest way I know of to tell what SC is doing for transcoding is to look at the running processes while a song is playing. If faad and lame are both running, chances are it's doing mov->mp3. I'm sure there's an easier way, but I don't know what it is yet.

-r

funkahdafi
2008-06-17, 10:31
Can faad just decode to WAV or something else uncompressed (FLAC, whatever)?

bpa
2008-06-17, 10:41
faad just decodes to WAV. Depending on what the user has chosen SC will either leave it as WAV, or use Flac to re-encode to Flac or lame to re-encode into MP3.

SC will normally do MOV->Flac as compressed lossless is most efficient use of bandwidth and buffering with no loss of quality

If MOV->FLAC is disabled in FileTypes then SC will do MOV->WAV.

If Bit rate limiting is enabled for the player MOV->MP3 will superceded the previous rules.

Nonreality
2008-06-17, 12:47
Is there a reason not to just transcode to flac? That way you wouldn't lose anything unless you have other players that don't support it and you need to use.

funkahdafi
2008-06-17, 22:46
well I would love to encode to flac. But I need some help setting it up with faad.

Once this is configured, is there a way I can prevent SC upgrades from overwriting my convert.conf?

Nonreality
2008-06-17, 23:22
well I would love to encode to flac. But I need some help setting it up with faad.

Once this is configured, is there a way I can prevent SC upgrades from overwriting my convert.conf?I meant actually switching the files to flac. Just convert all your aac files to flac that way you won't lose anything and then you can play them and have fast forward and rewind capabilities. They won't be true lossless but will sound as good as they can with no transcoding to another lossy format problems.

funkahdafi
2008-06-17, 23:30
I meant actually switching the files to flac. Just convert all your aac files to flac that way you won't lose anything and then you can play them and have fast forward and rewind capabilities. They won't be true lossless but will sound as good as they can with no transcoding to another lossy format problems.

Oh ok... Got it :) Can't do that though. I am one of those retarded mac fanboys who uses iTunes to manage his music collection :-D iTunes + flac = no.

funkahdafi
2008-06-25, 23:28
Are there any updates on this? There is still tons of noise here and I don't want to mess around with faad and the config files. This should work fine right out of the box....

bpa
2008-06-26, 00:09
It is worthwhile to try the "faad" solution if only to identify the source of the noise.

If the noise is eliminated when using faad rather than mov123 is used then the problem is probably in Apple QuickTime libraries. Quicktime problems have happened on some Windows installations and have been fixed in a later QuickTime point release.

If the "faad" solution does not get rid of the noise - then it is clear the noise is introduced elsewhere in the decoding process.

funkahdafi
2008-06-26, 00:22
It is worthwhile to try the "faad" solution if only to identify the source of the noise.

If the noise is eliminated when using faad rather than mov123 is used then the problem is probably in Apple QuickTime libraries. Quicktime problems have happened on some Windows installations and have been fixed in a later QuickTime point release.

If the "faad" solution does not get rid of the noise - then it is clear the noise is introduced elsewhere in the decoding process.

Ok I can try, but someone needs to help me set up the right configuration. I have faad installed on my Mac, but what do I need to put in the convert.conf?

bpa
2008-06-26, 00:35
From thr Wiki entry on AAC. There is a 50:50 chance the byteorder of WAV stream is needs to be changed as I don't know the endianness of OSX on Intel.

Please note - it is a tab char before [faad] not spaces.



# Transcoding for AAC files.
mov flc * *
[faad] -w -f 2 $FILE$ | [flac] -cs --totally-silent --compression-level-0 --endian little --sign signed --channels 2 --bps 16 --sample-rate 44100 -
mov mp3 * *
[faad] -w -f 2 $FILE$ | [lame] --resample 44100 --silent -q $QUALITY$ -b $BITRATE$ -x -r - -
mov wav * *
[faad] -w -f 2 $FILE$



Don't change convert.conf. If you put these lines in the custom-convert.conf file in the same folder as convert.conf. SC will reads the custom file after the the convert.conf and use the faad rules. Restart SC and check Setting/Advanced/Filetype that faad is being used for mov.

Using custom-convert.conf has the advantage
* Easy to remove the change by renaming or deleting custom file.
* changes remain after updates of SC as SC does not chage custom files.

funkahdafi
2008-06-26, 02:43
Thank you very much for the detailed response. I am going to try this and let you know what happens. Appreciate it!

Sascha

Nonreality
2008-06-26, 03:29
SPDIF (the digital or coax) have no metadata so it's just a raw 16/44 or whatever bit stream so the only way to accomplish "volume" is to reduce bits.
So the SB can not "tell" the Denon what volume to play, you have to alter the data.
Sorry this is a bit late but had a question about this post. If this is so, why does replay gain function correctly through the digital outputs? Is it reducing the bits as per the replaygain tag to achieve it? Does this mean that in a perfect world you wouldn't want to use replay gain if you are using the digital outputs? I know in reality it's only about a 7-10% decrease and shouldn't affect any quality but in a perfect listening area with perfect ears and a perfect system, I guess it could. I have my SB3 hooked up both ways and can't really tell the difference but seem to like the analog better overall for no reason that I could explain. I do seem to notice that the bass is a bit more defined and crisp through the digital outputs on music from artists like Massive attack so I do switch imputs for some music. I think the dac in the SB3 and my Yamaha RX-V1800 are about the same.

Mnyb
2008-06-26, 03:59
Ooops somebody citing me :)in the same tread, I was told that the digital volume for the DIGITAL output (spdif) also works with 24bits just as at DAC's for the analog out ?
If so i wont worry a bit ? 24bit is beyond any hardware and human beings ability's. and is probably better than most analog volume controls.

but does the SB3 realy has the processing power to sample rate convert 16bit to 24bit ? surprise me again please :)
the digital filter before the dac's might do that in hardware ?

But I'm using fixed volume and no gain whatsoever, i've tried to run dts encoded stuff as flac and wav and it's works flawlessly. This indicates that the bits are "untouched" the bitstream is as encoded nothing altered changed or added, which in my book is very very good. It just passes trough the SB3 (mind that no squeezebox can decode dts or dolby) if the SB tries to "do" something with a format it don't understand it would result in white noise ? *

Anyhow i use fixed to the hifi rig and variable for other stuff I don't think this can be heard in *couch* "normal" equipment.

/Mikael

*PS i tried dts stuff as a scheme to verify if my whole system is bitperfect.
*PPS i have an digital preamp so want to reduce the number of unknowns and do my processing at one place.

radish
2008-06-26, 06:48
Is it reducing the bits as per the replaygain tag to achieve it?

It's using the digital volume control, so yes the data is being scaled. "Reducing the bits" is a rather crude way of putting it though :)



Does this mean that in a perfect world you wouldn't want to use replay gain if you are using the digital outputs?

Depends on your definition of "perfect world". If you want bitperfect output then yes, you should disable RG and put the output volume to 100%. However, the audible effect of moderate digital level adjustment is arguable and given the very well documented effect of volume on perceived sound quality you may find things sound better properly normalised, particularly if you play mixed tracks from different albums/artists.


in the same tread, I was told that the digital volume for the DIGITAL output (spdif) also works with 24bits just as at DAC's for the analog out ?

Yes, the digital output is always 24-bit, and the volume control is done in the 24-bit domain. The DAC is also 24-bit.


but does the SB3 realy has the processing power to sample rate convert 16bit to 24bit ? surprise me again please :)

Lossy formats like mp3 are decoded directly into 24-bit, lossless 16-bit formats (e.g. ripped FLACs) are padded with a 0 byte in the LSB. It's not an expensive operation :)


But I'm using fixed volume and no gain whatsoever, i've tried to run dts encoded stuff as flac and wav and it's works flawlessly. This indicates that the bits are "untouched" the bitstream is as encoded nothing altered changed or added, which in my book is very very good
The decoder is just ignoring the padding byte and looking at the "real" 16-bits of data.

Mnyb
2008-06-26, 08:00
Thanks radish i'm informed, padding ok :)

funkahdafi
2008-06-30, 14:09
From thr Wiki entry on AAC
[...]


Ok so I tried the fadd stuff. Put it into custom-convert.conf as you said and restarted the server. Now everything in the file type section of the web inerface is greyed out. See attached screeshot.

I also tried commenting out everything related in the convert.conf, just to make sure, but I get similar results.

bpa
2008-06-30, 14:20
Greyed out means SC couldn't find the faad application you just installed. So either the faad applications is called something other than faad or else it is not installed in a directories which Sc looks.

Was the application called faad or faad2 ? If it is called faad2 then the custom-convert.conf needs to have [faad2] and not [faad].

funkahdafi
2008-06-30, 14:31
Greyed out means SC couldn't find the faad application you just installed. So either the faad applications is called something other than faad or else it is not installed in a directories which Sc looks.

Was the application called faad or faad2 ? If it is called faad2 then the custom-convert.conf needs to have [faad2] and not [faad].

That did it. faad was not in SC's path. Copied it over to SC's Bin/darwin directory and now it's working.

And you know what? It's working perfectly. No hiss, perfect quality.

So my files are all right and this has got to be a bug in mov123 or whatever.

Strange that no one else has noticed this yet?

bpa
2008-06-30, 14:51
All mov123 does is call QuickTime libraries to decode so the problem is in QuickTime.

Variations of this problem have been reported from time to time on Windows platform but it seems to only affect a small number of systems.

funkahdafi
2008-06-30, 15:06
All mov123 does is call QuickTime libraries to decode so the problem is in QuickTime.

Variations of this problem have been reported from time to time on Windows platform but it seems to only affect a small number of systems.

Well please excuse my ignorance here but simply pushing this to Quicktime is sort of easy. I doubt it is a quicktime problem. These files play well in quicktime and/or iTunes and in fact any other app here that uses quicktime. Except for SC/mov123. I rather suspect this to be an issue with SC or how SC uses mov123.

As I have reported in another thread a couple of times already the default configuration coming with SC still makes use of big endian even though you must not do this on an Intel based platform. No one seems to care about this either. This may or may not be related, but it gives you some sort of clue as to how Slim Devices seems to handle the Mac platform.

I personally wouldn't be so arrogant (no offense) to simply push the problem elsewhere. Something is wrong - out of the box for paying customers - and that should be investigated.

If the next update is not going to fix this problem and I will have to resort to the "faad hack", I am going to carry that little box back to Logitech so they can keep it. I bought support for AAC on Mac and it's not working.

Sorry, I don't mean you. I just hope someone from Logitech is reading this.

bpa
2008-06-30, 15:16
The code for mov123 is online and can be read easily and IIRC there is no processing of audio data except through QuickTime library calls. That said, mov123 seem to use an older supported but not preferred library interface and perhaps that is where the error is creeping in and why existing applications have no problem.

The only way to prove/disprove whether Quicktime is the issue would be to install older versions of Quicktime library and see if the problem is in all of them or not.

Alternatively save the output from mov123 (i.e. no SC involved) of an audio fragment which demonstrates the hiss and compare the binary file to the mov123 output from a system where no hiss is heard.

This is user forum - if you want Logitech to examine this issue - log a bug and describe the bug and how using faad is a workaround and so identifies mov123 as source of problem.

funkahdafi
2008-06-30, 23:40
A bug was already filed.

Thanks for your help though, I appreciate it!!

Cheers
Sascha

funkahdafi
2008-07-30, 15:47
Don't change convert.conf. If you put these lines in the custom-convert.conf file in the same folder as convert.conf. SC will reads the custom file after the the convert.conf and use the faad rules. Restart SC and check Setting/Advanced/Filetype that faad is being used for mov.


that's strange now... I just upgraded 7.0.1 to the 7.1.0 release. gues what. my custom-convert.conf was deleted. so was the faa binary that I copied to the server's bin directory.

I thought that at least the custom-convert.conf would be preserved?

bpa
2008-07-30, 15:51
You should log that as a bug.

funkahdafi
2008-10-05, 09:12
any news on this? this bug STILL exists, even in the newest version. mov123 still only outputs hiss unless you change the endian setting.

and the custom-convert.conf still gets deleted upon SC upgrades.

bpa
2008-10-05, 09:22
Whats the bug number and I'll add some info to move it along.

funkahdafi
2008-10-05, 09:51
http://bugs.slimdevices.com/show_bug.cgi?id=8434

funkahdafi
2008-10-05, 09:51
I also had opened this one:
http://bugs.slimdevices.com/show_bug.cgi?id=8444

but it has less activity. might just combine the two.

grrman
2008-10-12, 19:18
any news on this? this bug STILL exists, even in the newest version. mov123 still only outputs hiss unless you change the endian setting.

and the custom-convert.conf still gets deleted upon SC upgrades.

Still a bug, see 9638.

Pete

funkahdafi
2008-10-15, 07:12
Still a bug, see 9638.

Pete

nope. that one does not apply to this problem. in that case, mov123 won't decode at all. in this case however, it decodes only rubbish.

bpa
2008-10-15, 07:20
Have you logged your problems as a bug ? if not then they will not be solved.

funkahdafi
2008-10-15, 08:00
Have you logged your problems as a bug ? if not then they will not be solved.

yes. read this thread :D

bpa
2008-10-15, 08:35
Sorry missed your posts and only saw grrmans.

I see the custom-convert bug is at the end of 8434.

austinmilbarge
2009-05-03, 11:24
Noticing the same hiss problem here. A little about my setup..

SC 7.3.2 running on a Thecus N5200PRO -->
Wired ethernet to SB Duet Receiver -->
Coax out to CA DACMagic -->
Analog out to Arcam A65+

I'm noticing the problem exclusively on AAC/mp4 files, regardless of bit rate.

I have tried inserting the faad work around (as described earlier in thread) into my custom-convert file. After I did this, I heard no change with default file type settings. Tried disabling everything except WAV output, which led to the controller showing the track playing but no audio coming out of my speakers.

FYI, I've tried playing back the same tracks through ITunes to an airport express running through the same DAC and they sound great, so the problem is not with the tracks.

Any ideas?

jo-wie
2009-05-03, 13:14
Have you tried the latest 7.3.3 version of SC? The bug report notes

http://bugs.slimdevices.com/show_bug.cgi?id=9638

that the bug is fixed in the 7.3 version.

austinmilbarge
2009-05-04, 18:42
Have you tried the latest 7.3.3 version of SC? The bug report notes

http://bugs.slimdevices.com/show_bug.cgi?id=9638

that the bug is fixed in the 7.3 version.

Running as a module on my Thecus N5200. 7.3.2 is the latest I can install. This hissing AAC issue remains unresolved for me, and is being experienced by some other Thecus users as well. It seems to be a faad issue.