PDA

View Full Version : SqueezeCenter shows Duet Receiver Off when it is On...



AndrewFG
2008-06-07, 10:59
Hi,

I have a Transporter, a Duet Receiver and a Duet Controller to rule them all.

When I go to bed I connect the Controller to the Transporter and command it off (Transporter turns off); then I connect the Controller to the Duet Receiver and command it off (Receiver turns off; LED off). Then I turn off my PC.

But in the morning, when I turn on my PC again, the Transporter is still off like it should be, but the Receiver is on (white LED), and when I look in the SqueezeCenter web UI, it reports the Transporter as off (correct) and it also reports the Receiver as off (which is untrue, since it is on, with white LED).

Am I missing something here? Or is this a bug?

Zaragon
2008-06-08, 05:24
Daft point but are you sure it's white and not blue. The one I have you sometimes can't see the difference but notice it when it changes. Othertimes it's so blue you can't miss it :)

When you switch both players off, you are only putting them into a different 'on' state, they never actually power down. It just commands the transporter to display 'off' screens and the receiver to turn off the coloured LED.

When you turn off the PC (assuming it is the one hosting SC they are connected to) both would report loss of SqueezeCenter connectivity, the receiver with a blue light. From memory the receiver has an error message for a while before it blanks it's displays.

When you turn the PC back on in the morning they both reconnect and should return to the 'off' status. Whilst it is possible that you have discovered a bug it could also be that you are seeing the receiver at the point it reconnects (hence white) before it is commanded to return to it's 'off' status thus turning off the LED.

It may be worth factory resetting the receiver and then set it up again.

Incidentally if the receiver is on but SC/Controller thinks it's off what happens when you try to turn it on and then off again?