PDA

View Full Version : Help - PC going to sleep when using Squeezebox...!!



jtc
2008-05-28, 12:24
Hi folks.

I have recently fixed a Shuttle PC and plan to dedicate it to being a SqueezeCentre server, so that my main machine is freed up. It's an older Shuttle PC running Windows XP SP2, and as far as I can tell everything about it is fairly standard.

My problem is that I have set the power management so that it sleeps after a certain period of activity - in this case 1 minute (for testing purposes). Despite having the 'prevent PC from sleeping when playing music' plugin activated, the machine still sleeps.

Any ideas? I could increase the sleep period up to (say) 10 minutes, but I presume the same thing will apply - except after 10 minutes rather than 1?

Or, and I'm going on a hunch here, is it because there is no real activity whilst a song is playing (leading Windows to think it is 'idling')? In which case I'd guess increasing to 10 minutes ought to do the trick for all but the longest songs. Even if this is the case, is there a way of telling Windows to 'stay awake' whilst a Squeezebox or SoftSqueeze is active?

Many thanks,

John

PS. If I can't get around this problem I may look to try Ubuntu on this machine, though as XP is on it already I'd prefer to minimise the amount of extra work involved.

jmack
2008-06-08, 22:01
I have recently fixed a Shuttle PC and plan to dedicate it to being a SqueezeCentre server, so that my main machine is freed up. It's an older Shuttle PC running Windows XP SP2, and as far as I can tell everything about it is fairly standard.

My problem is that I have set the power management so that it sleeps after a certain period of activity...Despite having the 'prevent PC from sleeping when playing music' plugin activated, the machine still sleeps.

If I can't get around this problem I may look to try Ubuntu on this machine, though as XP is on it already I'd prefer to minimise the amount of extra work involved.

I just bought a new Shuttle K45 PC & am having the same trouble with Ubuntu 8.04. It doesn't recognize streaming music as an activity. It shuts down after the set time, playing music or not.

In addition, I can't get it to Wake-on-lan as it is advertised to do. The bios only has a Wake-on-PCI function. The techs at Shuttle seem to think this is an oversight requiring an as yet not available bios update, but they have no explanation for the going to sleep problem.

Not too impressed with it so far. It is NOT a quiet unit, even with a speed adjustable CPU fan. I would not want this in my media room. My 6 year old Dell desktop is MUCH quieter.

The Shuttle uses 66W max, 45W at idle & 9W in Suspend, but since I can't get the auto sleep & wake functions to work, the Suspend mode is not much use. I am having to leave it on all the time, so it may be Greener than standard desktop, it is not ideal.

Although it is very responsive with SS7, if I had it to do again, the Shuttle would not be my first choice.

finnbrodersen
2008-06-08, 22:43
...
My problem is that I have set the power management so that it sleeps after a certain period of activity - in this case 1 minute (for testing purposes). Despite having the 'prevent PC from sleeping when playing music' plugin activated, the machine still sleeps.

...


I have the same problem also on a WinXP machine.

jo-wie
2008-06-09, 04:16
@jmack

For Ubuntu you should have a look at the script from feelfree in the German forum. It's scheduled by a cron job every 5 minutes.

http://forums.slimdevices.com/showthread.php?t=48514&page=2

Best regards,

jo-wie

jmack
2008-06-09, 20:05
@jmack

For Ubuntu you should have a look at the script from feelfree in the German forum. It's scheduled by a cron job every 5 minutes.

http://forums.slimdevices.com/showthread.php?t=48514&page=2

Best regards,

jo-wie

Thanks for the reply jo-wie.

My German is none too good & being a total newbie at Linux, I don't really follow the script, but it seems to me that if I run a cron job continuously, it will never shut down, or will only shut down at a specified time.

What I want is for the server to shut down a set time after the music stops & wake when I turn on the Squeezebox.

I am surprised that streaming music is not seen as an activity.

jo-wie
2008-06-10, 00:25
Hello Jmack,

hint: http://www.google.com/language_tools?hl=en you can translate a webpage. Not the best translation but it should help.

The script is scheduled every 5 minutes and it "sniffs on the network card and measures the difference of the SB and SC network traffic" between schedules! This script sees the music streaming as an activty and shuts down only when minimum network activity is reached between the scans. I guess this is the solution you're looking for. I could not test because I do not have the hardware yet but Feelfree told me it's working fine.

Best regards,

jo-wie

jmack
2008-06-15, 17:42
Hello Jmack,

hint: http://www.google.com/language_tools?hl=en you can translate a webpage. Not the best translation but it should help.

The script is scheduled every 5 minutes and it "sniffs on the network card and measures the difference of the SB and SC network traffic" between schedules! This script sees the music streaming as an activty and shuts down only when minimum network activity is reached between the scans. I guess this is the solution you're looking for. I could not test because I do not have the hardware yet but Feelfree told me it's working fine.

Best regards,

jo-wie

Thanks jo-wie

I will try it when I get my Shuttle back. I have been talking to tech support & they suggest that I send it back as there appears to be a problem with the unit. When they have updated the bios to fix WOL, I will get a new one. I hope my Ubuntu installation will recognize the new machine & not be affected the way Windows is by a hardware change.

jmack

MrSinatra
2008-06-15, 20:42
r u sure the driver itself doesn't have any WOL settings?

jo-wie
2008-06-16, 00:26
Eventually you have to initialize the card first with "ethttool -s eth0 wol g" and enabling "Wake on PCI".

jo-wie

jmack
2008-06-16, 11:44
r u sure the driver itself doesn't have any WOL settings?

Which driver & how do I access it? And no, where linux is concerned, I am not sure of anything, ;-) but tech support at Shuttle said the bios needs an update to make it work.


Eventually you have to initialize the card first with "ethttool -s eth0 wol g" and enabling "Wake on PCI".

jo-wie

OK, I will try this when I get it back.

Thanks both of you for your support
jmack