PDA

View Full Version : problem with ogg file playback



sbyrne
2008-05-26, 08:40
<OffTopic>I apologize in advance for being unable to search the forums. I'm running Firefox 3 and it seems that forum code doesn't play nicely...so searching doesn't work</OffTopic>

I have a squeezebox duet and it won't play some of my ogg files. Other ogg files playback just fine. I've pasted the output of running ogginfo (on linux) on one of the files that does not play below. I'm not sure if this problem is due to the bitrate or what, but it's annoying because the file (when encountered by the squeezebox receiver) causes playback to stop until I issue a skip command. Thoughts? (Please?) <edit>Sorry, I failed to mention that the file plays perfectly on every other platform I can play it on (Winamp on Windows XP, Ubuntu inside of Amarok, etc)</edit>

Processing file "rush/permanent waves/Rush-Permanent Waves-Freewill.ogg"...

New logical stream (#1, serial: 00005667): type vorbis
Vorbis headers parsed for stream 1, information follows...
Version: 0
Vendor: Xiphophorus libVorbis I 20010910
Channels: 2
Rate: 44100

Nominal bitrate: 192.000000 kb/s
Upper bitrate not set
Lower bitrate not set
User comments section follows...
title=Freewill
artist=Rush
album=Permanent Waves
Vorbis stream 1:
Total data length: 4921690 bytes
Playback length: 5m:24.426s
Average bitrate: 121.363390 kb/s
Logical stream 1 ended

CatBus
2008-05-26, 21:06
This ogg file was encoded with a VERY old encoder, and probably trips up the built-in decoder somehow.

You can set the server to transcode to FLAC, which will work around the problem with minimal hassle, and/or you can file a bug to see if the decoder can be fixed, and/or you can re-encode the song using a more modern encoder.

In general, I recommend the aoTuV series of Vorbis encoders. Haven't had a problem with them yet.

sbyrne
2008-05-27, 19:42
I purchased this file as an ogg download and did not rip from source myself. Consequently, I don't have the option to try and re-encode it. I'm *very* new to slim devices and I'm not sure about your suggestion to use flac to transcode. Can you elaborate?

Mnyb
2008-05-27, 20:20
Go to settings (rigth bottom corner in SC webpage).

then the settings page will popup.

Then the advanced tab.

From there select "File Types" from the dropdown meny to the left.

There you can set SC's behavior to every file type including OGG

sbyrne
2008-05-27, 20:28
There you can set SC's behavior to every file type including OGG

And I've seen this page before, but the interface is (obviously) not intuitive and leaves me wondering what the heck I do to effect any sort of transcoding.

I see the column headers labeled "file format", "stream format", and "decoder", but that doesn't tell me a damn thing.

Further help for the newb?

Mnyb
2008-05-27, 21:02
I don't have any OGG files myself, so i can not experiment with this, somebody else have to chime in here.
Do experiments with this, you wont damage anything, you can always restore the settings to what it was before.

A guess would be that setting the OGG Vorbis box in OGG Vorbis to disabled (is native per default ) would do it.

Then I suppose SC would use either AIFF, FLAC or MP3 to play ogg files.


EDIT: is any off the aviable check boxes for Ogg greyed out ?

CatBus
2008-05-27, 21:20
From the main page:
Settings/Advanced
From the dropdown, choose File Types
Under Ogg Vorbis, make sure something is selected for FLAC, and that Ogg Vorbis is disabled (NOT native)
Then click "Apply"

My condolences on this particular file--Ogg Vorbis reached version 1.0 in 2002, so it was encoded with a very early beta encoder from 2001. You may run into problems with it other than this.

sbyrne
2008-05-28, 05:47
From the main page:
Settings/Advanced
From the dropdown, choose File Types
Under Ogg Vorbis, make sure something is selected for FLAC, and that Ogg Vorbis is disabled (NOT native)
Then click "Apply"

My condolences on this particular file--Ogg Vorbis reached version 1.0 in 2002, so it was encoded with a very early beta encoder from 2001. You may run into problems with it other than this.

Thanks! I'll give it a shot.
Going forward, I was thinking of transcoding the file from ogg to mp3. I've never had any problem playing the file on my linux box, so maybe transcoding it would be best?

Anyway, that file types settings screen needs a brief intro at the top... ;)

CatBus
2008-05-29, 14:46
Myself, I honestly would transcode the file so that you're at least dealing with a file that will work reliably everywhere you want it. If you transcode to something lossless like FLAC, you won't lose any audio quality in the conversion, but the result will have lossy audio quality combined with a lossless file size. If disk space and portability aren't big worries for you, you could go this route. You could even go this route for a while, change your mind, and then transcode to lossy later.

Give a nice good critical listen to the result of a lossy-to-lossy transcode before you delete the original. Lossy compression is forever.

The good news is that this is a decently high-bitrate file for its age. So the quality is probably a pretty good starting-off point for lossy transcoding, is that's what you decide to do. Most modern Ogg files are transparent at 192kbps, but your encoder didn't have these optimizations so the quality is going to be lower. Be on the lookout for metallic sounding artifacts and pre-echo.

Phil Karn
2008-06-14, 04:30
Mnyb wrote:
> I don't have any OGG files myself, so i can not experiment with this,
> somebody else have to chime in here.
> Do experiments with this, you wont damage anything, you can always
> restore the settings to what it was before.
>
> A guess would be that setting the OGG Vorbis box in OGG Vorbis to
> disabled (is native per default ) would do it.
>
> Then I suppose SC would use either AIFF, FLAC or MP3 to play ogg files.
>
>

I've just run into this same problem with a set of ogg files from the 15
October 2004 Live at the Patio concert by Robert Walter's 20th Congress
hosted on archive.org:

http://ia310125.us.archive.org/2/items/RWTC2004-10-15.akg.flac16/

If I disable built-in player ogg decoding in the "files" configuration
tab, then Squeezecenter transcodes ogg to FLAC that my Squeezebox 2
plays just fine.

I can't determine which encoder or options were used to produce the
troublesome ogg files.

I downloaded the FLAC version of a song from that set. It plays fine, of
course. I encoded it into ogg using oggenc version 1.2.0 on Linux with
default options. Unlike the version on archive.org, my locally created
ogg file plays fine on my Squeezebox 2.

So it's confirmed. The problem is in the Ogg Vorbis decoder in the
Squeezebox firmware. It cannot decode some Ogg Vorbis files that other
decoders handle just fine. Since there appears to be no easy way to tell
which files can't be decoded in the player, the only viable workaround
until the firmware can be fixed is to completely disable built-in Ogg
Vorbis decoding and decode it on the server.

I like Ogg Vorbis and the other open audio formats as much as anyone,
but I've been wondering about its utility built into a player. I guess
it's useful when streaming remote "radio" stations (or song archives)
that generate it when your local computer is off.

Since Ogg Vorbis is a better lossy codec than MP3, in theory it could do
better than MP3 for bit rate limiting. But it looks like MP3 is
hardwired into the bit rate limiter, probably because it was the only
lossy codec available in the player at the time. There's no reason Ogg
Vorbis couldn't become the default bit rate limiter for Squeezeboxes
that implement it correctly. That could also avoid possible legal
problems in relying on LAME.

redalpha3
2009-01-02, 13:03
From the main page:
Settings/Advanced
From the dropdown, choose File Types
Under Ogg Vorbis, make sure something is selected for FLAC, and that Ogg Vorbis is disabled (NOT native)
Then click "Apply"



This has worked for my problem which was similar. Thanks for the good information.