PDA

View Full Version : convert.conf almost works ...



Sam
2004-03-01, 20:50
I recently started using Slimserver to stream tunes from home to my computer at
work. This worked great, except that my home cable modem provider's limited
upload speed prevented anything ripped at more than 128Kb/s from getting out.

But, after a little looking, I found the perfect solution in [slimserver home
dir]/server/convert.conf ... installing lame and adding the following line
causes anything streamed to a non-Slim device get transcoded on-the-fly down to
96Kb/s:

mp3 mp3 http *
$lame$ --silent --mp3input -b 96 $FILE$ -

This is almost perfect ... now I can listen to my music collection at work.
But, when listening at home via another computer, I'd like to have full quality,
not 96Kb/s. After reading the comments in convert.conf (couldn't find
documentation anywhere else), it seemed like the solution was simply to replace
the "*" above with either my home machine's IP or MAC address ... but this
doesn't seem to work. Adding another entry as above but replacing the first
line with any of the following and replacing the second line with " -" did not
seem to work (everything streamed to my home machine was still 96Kb/s):

mp3 mp3 http 192.168.1.102 (my home machine's IP)
mp3 mp3 http 192.168.1.*
mp3 mp3 http 00:02:dd:34:e9:62 (home machine's MAC)

Any ideas how to make this work?

kdf
2004-03-01, 21:12
Quoting Sam <shaabans (AT) hotmail (DOT) com>:

> not 96Kb/s. After reading the comments in convert.conf (couldn't find
> documentation anywhere else), it seemed like the solution was simply to
> replace
> the "*" above with either my home machine's IP or MAC address ... but this
> doesn't seem to work. Adding another entry as above but replacing the first
> line with any of the following and replacing the second line with " -" did
> not
> seem to work (everything streamed to my home machine was still 96Kb/s):
>
> mp3 mp3 http 192.168.1.102 (my home machine's IP)
This should work, however it depends on what IP the slimserver sees for your pc.
If this IP address is also the PC that you use for slimserver, you would need
127.0.0.1. If you haven't yet assigned a name in slimserver for your other pc's
connection, look in player settings and you will see the IP as slimserver sees
it. You would then be able to use the following:

mp3 mp3 http *
$lame$ --silent --mp3input -b 96 $FILE$ -

mp3 mp3 http 192.168.1.102
-

> mp3 mp3 http 192.168.1.*
partial wildcards are not yet supported.

> mp3 mp3 http 00:02:dd:34:e9:62 (home machine's MAC)
MAC works for hardware players only

Sam
2004-03-02, 06:55
> This should work, however it depends on what IP
> the slimserver sees for your pc.

You're absolutely right - it was seeing my wireless router's IP, not that of the
pc in question, and now it works fine. Also, thanks for the tip on wildcards -
I wasn't sure if partials would work.

Thanks for the help!
Sam