PDA

View Full Version : FLAC Problem | Problem: Unable to play file type for



DiSNEYN
2008-05-14, 12:45
Hello!

I try to play the new Nine Inch Nail album encoded with FLAC.

I have an old SliMP3 Device and on the server computer i run the latest version of the SqueezeCenter software.

In the Squeezecenter log file looks like this:

"[08-05-14 21:40:07.4973] Slim::Player::TranscodingHelper::getConvertCommand (297) Error: Didn't find any command matches for type: flc format: mp3
[08-05-14 21:40:07.5604] Slim::Player::TranscodingHelper::getConvertCommand (297) Error: Didn't find any command matches for type: flc format: mp3
[08-05-14 21:40:07.5608] Slim::Utils::Misc::msg (1241) Warning: [21:40:07.5606] Use of uninitialized value in concatenation (.) or string at /<C:\Program\SQUEEZ~1\server\SQUEEZ~1.EXE>Slim/Player/Source.pm line 1899.
[08-05-14 21:40:07.5611] Slim::Player::Source::openSong (1903) Error: Couldn't create command line for flc playback for [file:///R:/-%20BACKUP%20MP3ARKIV%20-/-FLAC-/Nine%20Inch%20Nails%20-%20The%20Slip%20-%20Flac/10%20Demon%20Seed.flc]
[08-05-14 21:40:07.5646] Slim::Player::Source::playmode (384) Error: Couldn't gotoNext song on playlist, stopping
"

Someone that can tell me whats wrong?

Thanks from Hans / Sweden

andyg
2008-05-14, 12:55
Make sure you have LAME installed and enable Settings -> Advanced -> File Types -> FLAC -> MP3 (flac/lame)

DiSNEYN
2008-05-14, 22:15
Make sure you have LAME installed and enable Settings -> Advanced -> File Types -> FLAC -> MP3 (flac/lame)

Thanks! Now it works! Great, but why don't make this setting standard and bundle the lame.exe encoder/decoder in the package?

Else it would be great if this problem (and solution :-) ) was in the FAQ!

Thanks for a great product, i've been using my SliMP3 since 2002 and i'm still happy about it!

Greetings from Hans / Sweden

bonzuccio
2008-05-14, 23:00
I have the same problem with wavpack
but either flac -> mp3 and Wavpack -> mp3 are "disabled"..
running on sc 7.1 I thought would solve the problem

radish
2008-05-15, 06:21
Thanks! Now it works! Great, but why don't make this setting standard and bundle the lame.exe encoder/decoder in the package?

lame can't be included in the download for legal reasons.



Else it would be great if this problem (and solution :-) ) was in the FAQ!

http://slimdevices.custhelp.com/cgi-bin/slimdevices.cfg/php/enduser/std_adp.php?p_faqid=6063
http://wiki.slimdevices.com/index.php/LAMEForTranscoding

But it's not always easy to find if you don't know what you're looking for :)

DiSNEYN
2008-05-15, 06:53
lame can't be included in the download for legal reasons.


http://slimdevices.custhelp.com/cgi-bin/slimdevices.cfg/php/enduser/std_adp.php?p_faqid=6063
http://wiki.slimdevices.com/index.php/LAMEForTranscoding

But it's not always easy to find if you don't know what you're looking for :)

Ah, I see.

I did a search in the FAQ on the error-message i got on my SliMP3, that give me no results. Maybe that error message could be a searchtag for that message?

Anyway, thanks for the solution for my problem!.

Greetings from Sweden!
/Hans