PDA

View Full Version : SB3 spontaneously reboots itself



anvil
2008-05-14, 06:27
Hello.

I have had my SB3 for about half a year and I am extremly happy with it.... but there is something (small) that bothers me...

Sometimes when Iīm listening to music the player reboots itself and then start playing the same song over again (this time no reboot).

Iīve also noticed that it sometimes, when itīs in "standby mode", it power up (the Logitech logo and then the welcome message appears) and then down.

Would it be possible to turn on some kind of logging to be able to track this?

Thanks!

msui772
2008-05-14, 06:49
As I haven't found the way to link to another thread here is the text of the advice given to me to get logging working. To be honest it didn't help me much but with some luck it will help you. I had a problem with a rebooting SB3 after an upgrade. I traced it to a particular version of the firmware and I downgraded again and it worked fine. I recently upgraded and it seems fine again so don't despair ;-)



Under Server Settings in the Web Interface is a page called debugging. Tick a relevant flag (at a guess and only a guess, I would say either of the ones that have a "full" output option) and open up the log window. Then when Slimserver crashes, see if there is any output that may explain what happens just before the crash.

As the logs get quite big, quite quickly, you may be better off running the log from the command line. Assuming a standard Slimserver directory install, Shut down Slimserver,

In the Desktop of your PC, Start, run, cmd, "c:\program files\slimserver\server\slim.exe --d_**** --logfile=c:\scanlog.txt"

Where d_**** is the name of the debugging flag you want to run. This should run Slimserver as normal and dump the scan into a separate file called scanlog.txt.

Sike
2008-05-14, 06:50
A shot in the dark would be: Turn off the JVC remote commands in the players settings on the server.

anvil
2008-05-14, 10:10
Thanks for the tips...

msui772: I canīt seem to find the page called "debugging" (I use SC7).

And you wrote "when SlimServer crashes"... itīs actually not that thatīs happening... itīs my squeezebox that restarts itself.

Even though... thanks :)

sike: I did what you wrote... letīs see if it helps.

Mnyb
2008-05-14, 10:25
Could this be a power supply problem ? it may be rebooting because it's powering up again ?
try to wiggle the conector on the SB3 and also check that the supply is properly conected.

msui772
2008-05-19, 02:12
Thanks for the tips...

msui772: I canīt seem to find the page called "debugging" (I use SC7).

And you wrote "when SlimServer crashes"... itīs actually not that thatīs happening... itīs my squeezebox that restarts itself.

Even though... thanks :)

sike: I did what you wrote... letīs see if it helps.

Hi, sorry I didn't think to check the squeezecenter. You can find it by going to the settings page (button at bottom right of main page. Choose Advanced tab and in the drop down list choose Logging.
I only upgraded to squeezecenter last week and I thought it was working but unfortunately I spoke too soon. One of my 4 SB3s reboots after playing a few seconds of music (wired or wireless, radio or mp3, on any version of firmware > 69). I have re-opened my support request but am not too optimistic. I suspect I will be stuck in slimserver v6.5.0 land for the rest of my days...
Actually it was in text I quoted from someone that it said "slimserver crashes" but it applied to when the Squeezebox crashes.
I strongly advise you to open a request with Logitech technical support (logitech_sms_en@mailca.custhelp.com)
or http://www.slimdevices.com/redir.html?http://slimdevices.custhelp.com/cgi-bin/slimdevices.cfg/php/enduser/ask.php
as the more visibility this issue has the more likely it is to get resolved...

Do let us know if you find a solution :-)

Michael

anvil
2008-06-07, 00:58
Update and problem solved(?).

I followed Mnybs and Sikes recommendations and my Squeezebox havenīt rebooted itself since (knock on wood!).

Thanks for the help guys!