View Full Version : Squeezecenter connection dropping

2008-05-13, 08:07
I haven't been able to use my SB3 system reliably for a few weeks & wonder if anyone can help.
Whether I'm listening to music or not, the SB3 display goes blank for no reason. I right click to connect to SC7 & it seems to wake but fails to connect. If I setup the network on the SB3 from scratch, it may work for a few minutes before switching off again. Sometimes it will go blank, then fire itself up again or even go back to the Logitech logo & reset itself without me touching a button (see log below).
Problems started after I bought an SMC router. I took it back & swapped for another incase it was faulty. No difference. I now have a Netgear DG834GT but the same problems happen. Network strength 50% or so. Wireless PC works OK.
I've replaced the SB3 with a new one & tried another SB3 power supply but no difference.
I've removed SC7 & reverted to SS6 without success so I'm back on SC7 now. I followed all rules re up/downgrades.
I've done factory resets on SB3 & routers - no joy.
Squeezenetwork doesn't work reliably either.

My sys is:
Win XP svc 2 cp1252
SB3 firmware 88

SC7 logfile (extract below) indicates a timeout problem which may be the cause but I don't know how to fix.

Slim::Web::JSONRPC::requestMethod (383) request not dispatchable!
[08-05-12 21:05:40.6745] Slim::Web::JSONRPC::requestMethod (383) request not dispatchable!
[08-05-12 21:05:50.6773] Slim::Web::JSONRPC::requestMethod (383) request not dispatchable!
[08-05-12 22:39:20.3002] Slim::Web::JSONRPC::requestMethod (383) request not dispatchable!
[08-05-12 22:39:30.3152] Slim::Web::JSONRPC::requestMethod (383) request not dispatchable!
[08-05-12 22:39:30.3188] Slim::Web::JSONRPC::requestMethod (383) request not dispatchable!
[08-05-12 22:55:10.2865] Slim::Web::JSONRPC::requestMethod (383) request not dispatchable!
[08-05-12 22:55:20.4210] Slim::Web::JSONRPC::requestMethod (383) request not dispatchable!
[08-05-12 22:55:20.4251] Slim::Web::JSONRPC::requestMethod (383) request not dispatchable!
[08-05-12 23:12:52.0924] Slim::Networking::Async::_connect_error (157) Failed to connect:
[08-05-12 23:12:52.0935] Slim::Networking::Async::_async_error (256) Error: [Connect timed out]
[08-05-12 23:12:52.0940] Slim::Networking::Async::HTTP::_http_error (264) Error: [Connect timed out]
[08-05-12 23:12:52.0950] Slim::Networking::SqueezeNetwork::Players::_player s_error (133) Unable to get players from SN: Connect timed out, retrying in 300 seconds
[08-05-13 12:54:04.8570] Slim::Networking::Async::_connect_error (157) Failed to connect:
[08-05-13 12:54:04.8744] Slim::Networking::Async::_async_error (256) Error: [Connect timed out]
[08-05-13 12:54:04.8748] Slim::Networking::Async::HTTP::_http_error (264) Error: [Connect timed out]
[08-05-13 12:54:04.8758] Slim::Networking::SqueezeNetwork::PrefSync::_syncD own_error (354) Sync Down failed: Connect timed out, will retry in 59606
[08-05-13 15:34:08.8319] Slim::Hardware::IR::executeButton (991) Error: Subroutine for irCode: [play] does not exist!


John Riedl
2009-02-14, 15:30
I've been having the same problem Muggo describes. Does anyone have a resolution? It's very frustrating. My SB1 will play for a few minutes to a few hours with no problem, then suddenly lose the connection to SqueezeCenter. I have to redo the network setup, and then all is well for a little while again.

SB1 firmware 40
SqueezeCenter 7.3.1
An SB3 and an SB Player on the same net show no problems.



2009-02-15, 07:51
Have you tried a wired connection from computer to SB?

John Riedl
2009-02-15, 08:40
I can't speak for muggo, but I have not yet tried a wired connection. Is there a reason to think that the wired connection might show the same problem?


2009-02-15, 09:09
Running a wired connection will rule out wireless interference problems - if the problem goes away when running wired, the problem is likely to be in your wireless setup (either other networks on the same channel as yours or wireless network strength or similar).

However, muggo's problem doesn't look obviously like a wireless issue - this is a problem in connecting to Squeezenetwork, which is a bit odd if you're trying to connect to Squeezecenter at the time. Couple of thoughts - can you play internet radio when connected to Squeezecenter (not Squeezenetwork)? If not, try powering down the Squeezebox and Squeezecenter, reboot your router, then power up the SB and SC, then try connecting to Squeezenetwork. Any improvement?

Second, check your Squeezenetwork setup - is your player registered when you log into the Squeezenetwork website, does it show as connected to SN? It may be worth deleting the player from Squeezenetwork and adding it as a new player using the pin.

Also, what av/firewall are you running on the box running SC?

John Riedl
2009-02-15, 11:15
Interesting idea. I've been assuming the problem is something with the wireless. I'll give it a try wired to be sure.

My firewall setup is unusual: I run a Smoothwall firewall with the wireless on purple and the wired on green. The firewall bridges permitted connections from purple to green, but denies general traffic. One effect of that denial is that the sb1 cannot "find" the squeezecenter; I have to tell it the specific IP address. (But, after it connects, it stays connected for up to several hours before losing the connection.) How does the sb1 try to recover from a temporary network outage? I'm speculating here, but if it were to try again to search for squeezecenter, it would fail in exactly the way it fails now. Any idea how I might get it to *only* use the IP address I give it for squeezecenter, and never to search? Alternatively, how does it do the search? Perhaps I could get the firewall to bridge the search.


2009-02-15, 14:00
I notice you are using an older version of SC software. You might try uninstalling the version you have and downloading the current one which I think is 7.3.2 Another thing you might try if you haven't is to unplug your
SB for abot 10 minutes after you have uninstalled the current version of SB and before you install the new one.

John Riedl
2009-02-16, 06:32
I tried my SB1 on wired, and it ran for 8 hours, no problem. I then moved it to a different location and tried it on wireless. Again, 8 hours, no problem. I then moved it back to its original location, and thought to try "test networking". It reports several (5? 6?) protocol errors with various lengths (ff71, and some others), and then resets. In the logs I see:

[09-02-16 07:14:54.9513] Slim::Web::JSONRPC::requestMethod (383) request not dispatchable!
[09-02-16 07:14:54.9611] Slim::Web::JSONRPC::requestMethod (383) request not dispatchable!

Now, when I try to restart the SB1 it goes directly into the "test networking" menu, reports protocol errors, and then restarts.


2009-02-16, 09:25
I have an SB2 but you might try disconnecting the power for a few minutes then re-power the unit holding down the Add button on the remote if you have one. With the SB2 this re-sets the unit to factory settings so you will have to go through the set up process again.