PDA

View Full Version : Remote not working



bigjp
2008-05-12, 05:30
My SB3 remote just stopped working the other night. I dropped it off the coffee table, which is not a bad fall, but I guess that did it in. I tried putting new batteries in and still nothing. I then took it apart and couldn't find anything obviously broken. One thing that I thought might be wrong is that on one side the batteries are connected directly to the board, but on the side with the metal piece that slides in and out it is just touching the underside of the remote board. It doesn't appear to have any metal piece that connects it. Is this piece just supposed to touch the board or is there a metal piece that is supposed to connect it that may have fallen off? I couldn't find anything in the remote that could've broken off, but I guess it could be possible. Just throwing this out there just in case.

So is my remote dead or is there something else that could be wrong? I've been wanting a universal remote for a while, and used this as an excuse to order a Logitech Harmony One. So I'll be good with that soon, but I'd still like to have the original working in case I decide to sell it at some point. Since I took it apart (and didn't do a pretty job of it), I'm sure I killed the warranty on it. Will I have to buy a new one, or do you think it could still be replaced since I've had it for less than a year? I know an email to them would answer that, but I just wanted to get an opinion or know the experience of others.

Thanks!