PDA

View Full Version : SqueezeCenter shows 0 artists



track2
2008-05-11, 22:06
I'm using version 7.0 of SqueezeCenter server on Windows Server 2003 (32-bit). When I perform a scan, it picks up all my music but shows 0 artists. When I check the scan log I see this entry:


[08-05-11 04:09:36.2337] Slim::Utils::SQLHelper::executeSQLFile (85) Error: Couldn't execute SQL statement: [INSERT INTO contributor_album (role,contributor,album) SELECT DISTINCT role,contributor,album FROM contributor_track,tracks where tracks.id=contributor_track.track;] : [DBD::mysql::db do failed: Cannot add or update a child row: a foreign key constraint fails (`slimserver/contributor_album`, CONSTRAINT `contributor_album_ibfk_1` FOREIGN KEY (`album`) REFERENCES `albums` (`id`) ON DELETE CASCADE) at /<C:\PROGRA~1\SQUEEZ~1\server\scanner.exe>Slim/Utils/SQLHelper.pm line 83, <$fh> line 36.

Any ideas why this is happening?

pablolie
2008-05-11, 22:27
make sure your ripping software includes the information that is needed by the server...

track2
2008-05-11, 22:57
The correct tags are most definitely in all of my tracks, whether they're FLAC or MP3.

Siduhe
2008-05-12, 00:22
There are a couple of things that can commonly cause "by 0 artists" - what antivirus/security program are you using and how is it set up to allow the Squeezecenter scan?

If not, does the problem at the same point on the scan every time (i.e. on a specific file or folder)? If so, the file may be corrupted. Try moving outside of the scan target and do a full rescan to see if that sorts the problem.

http://forums.slimdevices.com/showthread.php?t=46620&highlight=artists

nathan_h
2010-01-25, 20:28
I too have this problem. All the tracks and albums are showing up, but zero artists. This happened even when I uninstalled AVG so there was no antivirus software interference.

I'm using server version 7.4.1 on a Windows 7 box.