PDA

View Full Version : Connection reset by remote host



benyus
2008-05-08, 18:33
The message "connection reset by remote host" has suddenly started showing up when I'm listening to Internet Radio via Squeezebox Network. Happening even with low bandwidth stations. It stops, rebuffers, and stutters back on eventually. Lots of cutouts--driving me mad, mainly because I am so hooked on SB!

My internet connection (satellite) is fine, and signal strength is 51%

Any suggestions?

I am using Apple Time capsule, have firmware 88, and it's been working like a charm.

Thanks, Janine

NewBuyer
2008-05-08, 23:33
Exactly the same thing has recently started happening with me too. We use a wired SB3 with high-speed internet. Strange (and frustrating)...

bpa
2008-05-08, 23:58
A possible explanation is as follows.

Satellite connection have large TCP windows because of the longer delays which means a larger number of unacknowledged packets will be held in the SB compared to a terrestrial link. Packets are only acked when they are played.

If packets are not acknowledged within a timeperiod (say 2 mins) the link will be reset. If you are listening to a stations using MP3 - it is possible the SB has buffered 2 mins of audio and so it would be 2 mins before the last packet is acknowledged and hence link resets. The timeout value will depend on the station.

If this is your problem then it will happen more often with stations that use lower bitrate - so more likely with a 64kbp/sec stream compared to a 192kbits/sec.

Dr. T
2008-05-24, 20:55
I, too, get frequent interruptions of internet radio stations. This began right after upgrading (?downgrading?) to SqueezeCenter 7.0. I do have a satellite internet connection, but that worked reliably when using versions 6.0-6.5.

I do not believe bpa's explanation is correct. The interruptions occur after 10-30 seconds of listening, not 2 minutes. I believe there is a bug in the SqueezeCenter 7 code that affects only some users (depending on their computer and network hardware). Perhaps if enough of us complain, they'll get it fixed.

MABderHelvetier
2008-06-15, 16:45
Hello

I have the same problem with my Squeezebox 3 Wireless. When using it in wireless mode, it often stops playing and shows the message "connection reset by remote host". It's like in Dr. T case, the interruptions occur after 10-30 seconds of listening. The strange thing is that the signal strength is over 50% and the network test results in 100%, even with the highest rate of kbps. After chaning to wired connection, this problems never happened.

drewe181
2008-08-12, 06:42
i don't know about internet radio but i do get the same poblem just listening to music. it's annoying the hell out of me. my wireless strength ranges from about 50%-75% and i have never had this problem before i upgraded.

luga00
2008-09-01, 02:01
I too had this problem at the weekend.

I noticed that two of my SB3's had the same IP address even though I was using automatic IP assign.

Giving each of them a unique address (manually) fixed this for me.

Gibbo
2008-09-04, 11:33
Been having this same problem, I seem to have solved mine now too. Turns out one of my 2 players was set to auto ip and the other static, the auto one was assuming the same as the static. changed it to manual and assigned it a different one, but for some reason it kept on changing back? even after turning everything off and restarting. A factory reset on the culpret seems to have solved it though.