PDA

View Full Version : SB3 behaving like those trick candles that won't blow out



TiredLegs
2008-05-05, 13:03
EDIT: I just did some more searching around in the bug database, and it looks like I have encountered bug #7702 http://bugs.slimdevices.com/show_bug.cgi?id=7702, in which Random Mix appears to be the culprit.

*****

I've seen several instances of a particular strange behavior, and I'm trying to determine where the problem lays. On some occasions, when I power off an SB3, less than a minute later, it turns itself back on and continues playing. Once the SB3 is in this state, if I hit the power off again on the remote, the same thing happens: it's back to life in under a minute. The only way I have figured out to get it to stay off in this situation is to pause the music before powering off. Then everything behaves normally.

A few pertinent facts and observations:

- I'm running Squeezecenter 7.0.1 on a Buffalo Linkstation Pro (with FreeLink Linux). This may or may not be related to the problem. One of the reasons I'm posting this in the General Discussion forum is to see if anyone else has experienced the same thing with non-Linux installations. I took a quick look in the bug database, and I didn't see anything that looked like this problem, but then again, it wasn't clear to me what search terms I should have been using.

- I have three SB3s, and I have seen this behavior on two of them, so it's not the specific SB3 unit. (My third SB3 doesn't get used as much as the other two, so perhaps I just haven't used it enough lately to encounter the problem.)

- The times this problem has occurred have all been when playing Random Mix. However, I play Random Mix much of the time, and most of those times this problem does not occur. I'm not convinced Random Mix necessarily has anything to do with it, but it might.

- I would estimate the problem happens about one out of five times I turn off an SB3, but it's not consistent. I can't make it happen just by turning an SB3 on and off five or even ten times in a row.

- A significant symptom that the SB3 will turn itself back on is when I power it off, its screen goes completely blank rather than showing the date and time screensaver that's normally displayed when the device is "off" (actually a standby state). If I see a blank screen, I know it's coming back to life on its own.

- One of the times the problem occurred, I had the Squeezecenter window open in my browser, and I could see that even though I had turned off the SB3, Squeezecenter showed that the music was still playing. When the SB3 restarted itself about 30 seconds later, it was playing at the point where Squeezecenter had already advanced. In other words, Squeezecenter never paused or stopped the music during the period when the SB3 was off. On that occasion, I checked the Squeezecenter log immediately afterward, and there did not appear to be any entries or errors related to this happening.

Anybody else seen behavior like this?

chill
2008-05-05, 13:18
I can't really help with the diagnosis, but I just wanted to say that I've seen this behaviour too. It's only happened once, a few days ago, and the only way that I found to fix it was by restarting SqueezeCenter.

- I'm runing SqueezeCenter 7.0.1 on a Windows XP PC.

- I have a couple of Squeezeboxes, but only the offending SB3 had power connected at the time. When the other one is powered, it is set to synchronise with the first one. Maybe this is significant?

- I've never used Random Mix, so in my case it can't be that.

Chris

TiredLegs
2008-05-05, 13:46
- I have a couple of Squeezeboxes, but only the offending SB3 had power connected at the time. When the other one is powered, it is set to synchronise with the first one. Maybe this is significant?

The first time I encounter the problem, my Squeezeboxes were synchronized, and I suspected that was a factor. (I did not suspect Random Mix at that time.) However, I have since un-synchronized the players, and the problem still occurs.