PDA

View Full Version : Squeezebox working but not Duet Controller



Beagle
2008-05-03, 07:01
OK. I've gotten a lot closer to making this whole thing work. I reluctantly turned on DHCP at my Linux server and was able to get both the receiver and the controller operational to some extent.

1) I can used the controller to browse squeezenetwork and command the receiver to play the different things available there.

2) I can log into squeezenetwork from my laptop and command the receiver to play from there.

3) I can hit my local server, http://192.168.2.2:9000, from my laptop, get into squeezecenter, and also command the receiver to play my entire music library. Sounds GREAT. It shows the receiver as a valid player.

And here is where is all falls apart. I can not see nor select my local server from the controller. When I try to change music sources, the only thing listed is Squeezenetwork. I tried to manually add the IP address of my server and that didn't help.

While I do now have access to my local library, etc, I really want to have control from the Duet. Kind of at a loss now.

Help?

MW

jaffacake
2008-05-03, 07:21
I've had many similar issues. I'd recommend the following from my experiences:

1) Ensure you check the controller for any software updates on the controller.

2) Restart the SqueezeCenter software on your server, maybe even reboot the whole box. This should ensure all the processes are running as required.

3) Turn the controller off and on again.

Does it now see the SqueezeCenter?

Mine sees it, but connectivity is still very intermittent. No idea why.

kraxeler
2008-05-03, 19:06
Had similar problems just now. Rebooting the wireless router enabled everything again.

Beagle
2008-05-04, 19:13
1) Ensure you check the controller for any software updates on the controller.
Done!


2) Restart the SqueezeCenter software on your server, maybe even reboot the whole box. This should ensure all the processes are running as required.
Done!


3) Turn the controller off and on again.
Done!


Does it now see the SqueezeCenter?
Nope! :(

Skunk
2008-05-04, 19:33
You could try installing softsqueeze on the laptop to see if it will access the server: http://forums.slimdevices.com/showthread.php?p=277537

You don't have a password set for the web interface do you? http://forums.slimdevices.com/showthread.php?t=44418

I got better search results using this string in Google, FWIW: controller can't find server site:forums.slimdevices.com

Zaragon
2008-05-05, 04:46
From what I recall of your network configuration from another thread, you have all devices in an IP range of 192.168.0.x, you have now tried it with DHCP enabled on your Linux box.

First thing, is the subnet mask correctly defined. It could be set to a number of variations but more usually for that set of network addresses it would be 255.255.255.0 This would need to either be set manually into each device or set in the DHCP scope. Also the default route should be set as the router again in each device or the DHCP scope.

Since you have DCHP on the Linux platform I'm assuming this has a static IP. Does the router also have a static IP rather than dynamic (a dynamically assigned static IP is also OK). This wouldn't stop the devices communicating to the local server but could stop internet access if it is wrong.

When configuring the controller it determines if there is a local SqueezeCenter by looking for the broadcast that the SqueezeCenter puts out. This can sometimes take several seconds to register on the controller. To be able to see this broadcast it is important that both devices are on the same subnet on the same logical ethernet segment. Some firewalls may block broadcasts, though you mention that you don't have any configured, some Linux distro do come with one enabled by default. The option to go to SqueezeNetwork is hard coded as a destination.

Whilst unlikely there may also be an option in the wireless router to not forward broadcasts to the wireless.

What is potentially confusing about this is that the controller can communicate with the SqueezeNetwork successfully and your receiver can communicate with both. Even manually entering the SqueezeCenter IP address fails to allow it to connect.

My thoughts on this center around a mis-configuration of IP most likely on the Linux server or something blocking IP communication. Also of note I believe as another poster mentioned if the SqueezeCenter is password protected it won't allow the controller to connect, though it should still find it.

Have you tried some basic connectivity checks when everything is on the network (say when the controller is talking to the SqueezeNetwork) try pinging the controller from the linux server and your XP and if you can connect to it via SSH from the controller to the Linux server. These should of course be successful. If they are not then resolving that problem should help enormously.

Beagle
2008-05-05, 06:48
I think I've tried just about everything you've pointed out. My Linux server does have a static IP as does my wireless router. Masks are all set to 255.255.255.0. I fairly certain that the biggest hurdle was to use DHCP as that way, the controller and the receiver picked up a proper DNS configuration. When I tried to manually assign addresses to the controller and the receiver, it makes the assumption that your DNS is going to be somewhere in the same subnet, which for me it is not.

I am able to ping everything on the network. I did log into the controller both from my laptop and from the server using ssh. It can ping back to the server from the controller. So I'm fairly certain that everyone is talking nicely from a TCP standpoint. I've got my wireless router (Belkin) set as just a plain access point without anything special set. My intent is for it to be totally transparent to the network. So now you've got me wondering if it is somehow blocking the broadcast from squeezecenter. I've got a Linksys sitting around so I may trying putting that in and see what I get.

While I'll admit that I'm not a "Certified Network Engineer", I have been working with network setups for well over 20 years. I would hope for the sake of the Duet, that Logitech can make this somewhat easier to setup. I just can't imagine that the typical home user can think of this as a plug and play device. I would expect a lot of returns in the first 30 days.