View Full Version : Squeezebox - Problem: Network appears disconnected

Simon Turner
2004-02-29, 04:21
I'm not enjoying this thread much.

Since my last two posts I have checked that my Windows DHCP server is
working correctly. It is.
I have also tried setting up my Squeezebox with a static IP address. The set
up appears to be going ok (i.e. I've set it's IP address, netmask, gateway
and even told it the address of the Slimserver - which is running!) until I
get to:
"Set up complete, press right to use Squeezebox" (or something pretty close
to this). I hit right and one of two things happens:
1) I receive *exactly* this message "roblem: Network appears disconnected.
Please check your network connection"... yes, no "P".
2) The Squeezebox screen goes black

Then things either work, i.e. I can go back through the set up menus, or i
have to take the power off the Squeezebox to get it going again.
In desperation (even tho i know it won't work) I've tried to upgrade the
firmware... the Squeezebox appears to freeze on the "Ready to update this
Squeezebox" screen. I have to pull the power plug out to get it to work


I'm sure there used to be a screen where i could choose to use either wired
or wireless networking. I can't access it now. Anyhow. I tried plugging it
into my network using a long forgotten ethernet cable just incase the
Squeezebox felt it needed one, but no joy. I am not 100% sure it is a normal
ethernet cable (i.e. not a patch cable or whatever). It has "Cable Master"
written on it if this means anything, but nothing else that would indicate
it is anything but a normal ethernet cable.

Simon Turner
Brighton UK

> -----Original Message-----
> From: discuss-bounces (AT) lists (DOT) slimdevices.com
> [mailto:discuss-bounces (AT) lists (DOT) slimdevices.com]On Behalf Of Simon Turner
> Sent: 29 February 2004 06:27
> To: SlimDevices List
> Subject: FW: [slim] Squeezebox - Problem: Network appears disconnected
> I should have added that I have also unscrewed the arial, played
> about with
> it, screwed it back, unscrewed it again, licked it (cos it likes
> that), put
> it back etc etc.
> .....maybe i won't dump the CDX just yet.
> Simon
> My Squeezebox does not appear to be able to connect to my
> wireless network.
> As it attempts to get an IP address via the DHCP server it
> displays Problem:
> Network appears disconnected. Please check your Ethernet
> connection. I have
> checked my wireless network and all is fine (i.e. my other devices connect
> to to with no problem). I've power cycled the Squeezebox and placed it
> within two foot of my WNAP. I've even rebooted the PC hosting Slimserver,
> all to no avail.
> I did wonder if the Squeezebox may think I am now on a wired
> network, but my
> access to the Squeezebox menu appears to be severely limited so I can't
> check.
> Help!
> The following points may be relevant:
> * I updated to Slimserver latest nightly build some time earlier today and
> updated the Firmware (now registers as version 8). It has worked correctly
> with this firmware most of the day.
> * I cannot currently power down the Squeezebox using the remote's power
> button. I have to switch it off at the mains to reboot it.
> * Initially I was going to update the firmware today because I was
> experiencing drop outs when playing Flacs (as my buffer kept emptying).
> However, I was forced to update immediately when the Squeezebox refused to
> output any sound whatsoever.
> Two other very quick points.
> How can I tell how full my buffer is (currently I can sometimes see a
> progress bar on the track listing screen as I've set this up in the server
> advanced settings, but the progress bar is not always visible)?
> How can I do a quick check on what my wireless network strength
> is? I'm sure
> I can access a menu item that displays this information but I just can't
> seem to find it.
> Thanks for any help,
> Simon Turner
> Brighton UK