View Full Version : FW: Squeezebox - Problem: Network appears disconnected

2004-02-29, 04:20
Hi Simon

I take from your description that Squeezebox found
your AP, but is unable to get an IP address via
DHCP. Some points to check:

Are you using WEP encryption?
Have you doublechecked the WEP keys?
Have you tried without WEP encryption?
Does Squeezebox get an IP address in wired mode?
Have you tried with a static IP address?

You should also make sure you are running your
AP in 'Shared key' mode. The parameter is in the
wireless settings and is named 'Authentication type'
in my Netgear 624.

Squeezebox (and other devices) cannot transmit
data or get an IP in 'Open System' mode.

Last thing. Did you turn on MAC access list? Meaning
that only devices in that list can connect and
use you AP? If yes, you need to add Squeezebox to
that list, or turn off that feature first.

Some info about the 'Authentication type' that I
found in the manual of my Netgear 624.

Assuming WEP is turned on.

'Open system': The authentication process is NOT
encrypted, only data transmission. That means,
every wireless device can connect to an AP in that
mode (even without a WEB key set). But such a
device would only 'see' the unencrypted packets.

'Shared key': The authentication process AND the
data transmission is encrypted. So only devices
with a valid WEB key are able to connect, transmit
and receive data.

That's what I understood form the manual and it
also fits with my experience.

Please correct me if you think I got it wrong.

Hope that helps

--- Simon Turner <simon (AT) brighton (DOT) co.uk> wrote:
> I should have added that I have also unscrewed the
> arial, played about with
> it, screwed it back, unscrewed it again, licked it
> (cos it likes that), put
> it back etc etc.
> .....maybe i won't dump the CDX just yet.
> Simon
> My Squeezebox does not appear to be able to connect
> to my wireless network.
> As it attempts to get an IP address via the DHCP
> server it displays Problem:
> Network appears disconnected. Please check your
> Ethernet connection. I have
> checked my wireless network and all is fine (i.e. my
> other devices connect
> to to with no problem). I've power cycled the
> Squeezebox and placed it
> within two foot of my WNAP. I've even rebooted the
> PC hosting Slimserver,
> all to no avail.
> I did wonder if the Squeezebox may think I am now on
> a wired network, but my
> access to the Squeezebox menu appears to be severely
> limited so I can't
> check.
> Help!
> The following points may be relevant:
> * I updated to Slimserver latest nightly build some
> time earlier today and
> updated the Firmware (now registers as version 8).
> It has worked correctly
> with this firmware most of the day.
> * I cannot currently power down the Squeezebox using
> the remote's power
> button. I have to switch it off at the mains to
> reboot it.
> * Initially I was going to update the firmware today
> because I was
> experiencing drop outs when playing Flacs (as my
> buffer kept emptying).
> However, I was forced to update immediately when the
> Squeezebox refused to
> output any sound whatsoever.
> Two other very quick points.
> How can I tell how full my buffer is (currently I
> can sometimes see a
> progress bar on the track listing screen as I've set
> this up in the server
> advanced settings, but the progress bar is not
> always visible)?
> How can I do a quick check on what my wireless
> network strength is? I'm sure
> I can access a menu item that displays this
> information but I just can't
> seem to find it.
> Thanks for any help,
> Simon Turner
> Brighton UK