PDA

View Full Version : Slimserver won't scan through a shortcut!



roll - gybe
2008-04-28, 16:51
Hello all, I moved some things around today. Specifically, I took my unprotected files out of my iTunes library on my C drive and made a new C drive file for them.

Then I went into slimserver and unclicked "use itunes"
Then I went into my D drive flac folder that is set up as my music folder and put a shortcut in to my new folder on the C drive.

SS will not pick up the music files, no matter how I scan.

Any thoughts? is there a new bug or something?

I used to have this set-up, and it's not working anymore!

fyi, using Vista

SuperQ
2008-04-28, 17:28
Unlike on Linux/UNIX, shortcuts on windows are not filesystem native. Basically they are regular files which some programs know how to open. I suppose squeezecenter could detect .lnk files and use the Win32::OLE perl module to dereference them.

roll - gybe
2008-04-28, 17:39
thanks for the repsonse, but can you explain what that means!? thanks!

radish
2008-04-28, 18:38
SqueezeCenter does follow windows shortcuts normally, obviously something isn't working here. Could you post the version you're using? Also try going to the logging page and enabling debug logging for scan, and then rescan and see if there are any errors in the logfile.

roll - gybe
2008-04-28, 19:34
I'm using SS 6.54 - I'd rather not upgrade right now...
I'll have to figure out the logging page.

I actually had the shortcut set up on my old, XP system - not the new Vista set up. So it's never actually worked on this computer now that I think of it.

btw - I put a bunch of the files into my actual SS music folder to make sure there wasn't a problems with them. They work just fine.

Ben Sandee
2008-04-28, 21:33
On Mon, Apr 28, 2008 at 9:34 PM, roll - gybe <
roll.-.gybe.38lxkc1209436502 (AT) no-mx (DOT) forums.slimdevices.com> wrote:

>
> I'm using SS 6.54 - I'd rather not upgrade right now...
> I'll have to figure out the logging page.
>
> I actually had the shortcut set up on my old, XP system - not the new
> Vista set up. So it's never actually worked on this computer now that
> I think of it.


Make sure SlimServer has permission to read the files that are being pointed
at. In particular, if SlimServer is running as a service you may have to
open up the permissions a bit or run it as a specific user.

Ben

roll - gybe
2008-04-29, 06:02
Thanks Ben, I found that one on the internet and I tried for an hour to make it work. The "run as administrator" box was greyed out. I think I might have to set up an admin account or something.

I have already tried running SS as an administrator. grr.

eweitzman
2008-05-03, 10:01
I have the same problem with a new, freshly downloaded and installed SqueezeCenter 7 on Windows 2000 SP3. There are shortcuts in the music folder that point to directories elsewhere. None of them get scanned. The directories are located on a network drive that has been mounted with a drive letter.

This FAQ says it should just work: http://slimdevices.custhelp.com/cgi-bin/slimdevices.cfg/php/enduser/std_adp.php?p_faqid=5992&p_created=1168548350&p_sid=8sWRoP2j&p_accessibility=0&p_redirect=&p_lva=&p_sp=cF9zcmNoPTEmcF9zb3J0X2J5PSZwX2dyaWRzb3J0PSZwX 3Jvd19jbnQ9MTgsMTgmcF9wcm9kcz0wJnBfY2F0cz0mcF9wdj0 mcF9jdj0mcF9wYWdlPTEmcF9zZWFyY2hfdGV4dD1tdXNpYyBmb 2xkZXJz&p_li=&p_topview=1 This is a show stopper for me, so any help would be much appreciated.

- Eric

radish
2008-05-03, 20:44
Try this:

http://slimdevices.custhelp.com/cgi-bin/slimdevices.cfg/php/enduser/std_adp.php?p_faqid=5967

In other words, try UNC instead of drive letters.

frankL
2009-07-21, 14:59
I actually had the shortcut set up on my old, XP system - not the new Vista set up. So it's never actually worked on this computer now that I think of it.

I think the shortcuts from XP don't translate to Vista/Windows 7 very well. I had the same problem when I upgraded from XP to Windows 7. I deleted the shortcuts and made new ones. Everything is working now.