PDA

View Full Version : SSH Connection Trouble..



UGADawg
2008-04-27, 15:12
I'm sure this is a common problem with a quick answer, but I've been looking and cannot find it.. sorry if this gets posted all the time.

I have openSSH configured on my home machine through Cygwin. I can access it using it remotely Putty, and UltraVNC connects fine.

I just installed squeeze center on the home machine, and installed SoftSqueeze on my laptop. I have access to my neighbors wifi connections here in my apartment complex, so that's how I test my connection from an outside source.

Anyway, I cannot get SoftSqueeze to tunnel to my home computer. I am guessing I don't have the tunneling set up correctly. Do I need to connect to cygwin using Putty first, and then start up SoftSqueeze, or just use SoftSqueeze?

I have a DynDNS account set up. I just to know what ports and addresses to put in what box!

Thanks.

UGADawg
2008-04-27, 15:42
Ok, I got SoftSqueeze up and running. For some reason, when I hovered over SqueezeCenter in my server tray, it said it was stopped and the option to start it was grayed out. I had to restart my computer; didn't know how to fix it.

I have SSH running through SoftSqueeze right now. Is there a way I could run it through putty? Or would there be any point (security wise)?

I read somewhere that the initial username and password are send unencrypted from SoftSqueeze, but using putty to OpenSSH it is not.. not sure how true that is..

Anyway, I tried setting up two tunnels (in addition to my UltraVNC tunnel) ports 9001, and 3483. I turned off SSH from within SoftSqueeze and changed server in the Basic tab to localhost or 127.0.0.1. When I ran SoftSqueeze, it would not play any music, and according to my network monitor on the server, there was no network activity. How can I make this work?


EDIT: Works now.. I read in a past post to use port 9001, needed to be 9000. I'll reiterate what I did encase anybody is wondering:

(Remember this is to connect through a Putty SSH tunnel, not use the SSH included in the program)

On SERVER end (desktop at home in my situation):
- Install OpenSSH in XP using Cygwin (fairly straight forward, do a Google search)
- Configure router for your server (forward port 22 to your server computer)
- Remember, you do NOT need to forward ports 9000 and 3483 to use SSH - that is the point! Better security.
- Install and run SqueezeCenter (somehwhere in Settings, I chose for it to run at startup (requires user name and password to be stored) in case I'm away for a few weeks and my computer restarts due to power outage, etc)

On CLIENT end (laptop in my situation)
- Using Putty, created a tunnel (Under Connection, SSH, Tuunnels in the option tree) -> (Source port: 9000, Destination: 127.0.0.1:9000)
- Create another tunnel -> (Source port: 3483, Destination: 127.0.0.1:3483)
- In options tree under SSH, Set "Preferred SSH protocol version:" to "2 only" (supposedly exploit found in version 1)
- Go back to Session at the top of the tree, put your home routers IP address in or your Dynamic DNS if you have it registered, click connect.
- Install and open SoftSqueeze, in Settings, under Basic tab, put "localhost" into SqueezeCenter Hostname box.
- Make sure the box is NOT checked under use SSH tunnel (you've already established you tunnel using Putty)
- Click ok, and you should be up and running.