PDA

View Full Version : stream.mp3 tag question



ddewey
2008-04-24, 13:10
There has to be an easy answer to this I'm missing....

I do a lot of streaming from my Squeezecenter to work. Works great,
no complaints music-wise.

However.... the tag set that comes across in the stream appears to
be only TITLE, ie, track number.songtitle. No artist or album
information.

I cannot figure out how to get additional/different tag information
into the stream. At a minimum I'd like to get rid of the track
number and just have artist - songtitle.

I've been through every setting I can think of. I originally
thought it might be a winamp problem, but I have the same issue with
mediamonkey playing the stream.

Searching the forum found only one unanswered, similar question from
2005.

Suggestions?

ddewey
2008-04-26, 07:21
Quoting Dave Dewey (ddewey (AT) cyberthugs (DOT) com):

>
> There has to be an easy answer to this I'm missing....
>
> I do a lot of streaming from my Squeezecenter to work. Works great,
> no complaints music-wise.
>
> However.... the tag set that comes across in the stream appears to
> be only TITLE, ie, track number.songtitle. No artist or album
> information.
>
> I cannot figure out how to get additional/different tag information
> into the stream. At a minimum I'd like to get rid of the track
> number and just have artist - songtitle.
>
> I've been through every setting I can think of. I originally
> thought it might be a winamp problem, but I have the same issue with
> mediamonkey playing the stream.
>
> Searching the forum found only one unanswered, similar question from
> 2005.

Bump... come on, someone's gotta be dying to tell me how dumb I am
to not be able to figure this out...

Empty_One
2008-05-02, 18:36
I don't think anybody knows. I asked a similar questions a few weeks ago, and nobody answered.

pski
2008-05-04, 13:56
There has to be an easy answer to this I'm missing....

I do a lot of streaming from my Squeezecenter to work. Works great,
no complaints music-wise.

However.... the tag set that comes across in the stream appears to
be only TITLE, ie, track number.songtitle. No artist or album
information.

I cannot figure out how to get additional/different tag information
into the stream. At a minimum I'd like to get rid of the track
number and just have artist - songtitle.

I've been through every setting I can think of. I originally
thought it might be a winamp problem, but I have the same issue with
mediamonkey playing the stream.

Searching the forum found only one unanswered, similar question from
2005.

Suggestions?

Is there a reason you don't use SoftSqueeze?

Empty_One
2008-05-04, 23:29
Well, the reason I don't use softsqueeze is that it doesn't work for me. I have no problems connecting to my machine while I am work with winamp, foobar2k, itunes, or any other media player. However, I cannot get softsqueeze to work.

Do you know if it is possible to get additional information thru the stream?

JJZolx
2008-05-04, 23:47
Well, the reason I don't use softsqueeze is that it doesn't work for me. I have no problems connecting to my machine while I am work with winamp, foobar2k, itunes, or any other media player. However, I cannot get softsqueeze to work.

Do you know if it is possible to get additional information thru the stream?

Have you looked at the Title Format for the player? I don't recall whether or not it's applicable to stream.mp3, but it's the only place you might have any control over the info. When you connect from work SqueezeCenter will create a player identified by IP address. Check the Player Settings under Basic Settings > Title Format.

JJZolx
2008-05-04, 23:53
Have you looked at the Title Format for the player? I don't recall whether or not it's applicable to stream.mp3, but it's the only place you might have any control over the info. When you connect from work SqueezeCenter will create a player identified by IP address. Check the Player Settings under Basic Settings > Title Format.

Oh well... Should have tried it myself first. Looks like there's no such Title Format option when connecting through stream.mp3.

JJZolx
2008-05-05, 00:36
Oh well... Should have tried it myself first. Looks like there's no such Title Format option when connecting through stream.mp3.

But... It looks like you can:

- Shut down SqueezeCenter
- Edit the server.prefs file
- Modify the 'titleFormat:' and 'titleFormatCurr:' entries for the client
- Restart the server

The prefs file isn't hard to understand - client sections begin with '_client:' then the MAC address or IP address. The titleFormat: is a multiline entry (the formats from which to choose) and titleFormatCurr: is a single line, the currently chosen one.

Look at the Title Formats under Server Settings > Interface > Title Format. If the format yuo want isn't already in the list then add it. Count down (starting with 0) and note the number. As an example, let's say it's 8. Then edit the title format section in the prefs file to read:



titleFormat:
- 8
titleFormatCurr: 0

ddewey
2008-05-05, 18:35
PERFECT.

That works great, JJZolx. Thank you very much!

This is a great solution for someone like me that only streams from one location with a static IP (work). However, if your streaming IP changes a lot managing the tag display this way could be a major PITA.

I think it would be great to have an easy-to-use configuration option to choose the title display for remote players - it only makes sense. The behavior is so different it's jarring - you want it to work the same way as a 'real' player, and there isn't any good reason why it doesn't.

Anyway, thanks for the workaround!

andyg
2008-05-05, 19:45
I think there's a bug here, the title format should be visible for stream.mp3 clients.

Empty_One
2008-05-10, 05:35
But... It looks like you can:

- Shut down SqueezeCenter
- Edit the server.prefs file
- Modify the 'titleFormat:' and 'titleFormatCurr:' entries for the client
- Restart the server

The prefs file isn't hard to understand - client sections begin with '_client:' then the MAC address or IP address. The titleFormat: is a multiline entry (the formats from which to choose) and titleFormatCurr: is a single line, the currently chosen one.

Look at the Title Formats under Server Settings > Interface > Title Format. If the format yuo want isn't already in the list then add it. Count down (starting with 0) and note the number. As an example, let's say it's 8. Then edit the title format section in the prefs file to read:



titleFormat:
- 8
titleFormatCurr: 0

Thank you verymuch for this information.