PDA

View Full Version : Lecture à partir d'Internet - problèmes curieux



gguigui
2008-04-24, 02:40
Bonjour,

je souhaite utiliser squeezecenter depuis mon bureau pour écouter de la musique en streaming via internet. Malheureusement, je n'arrive pas à grand chose. Le port 9000 est bien ouvert dans ma freebox.
Mais :
- hier, ça marchait correctement (avec Winamp uniquement, pas WMP ou Media Player Classic) sauf que le son était très mauvais : sauts, sons étranges comme si j'écoutais par moment à travers de l'eau. Problème de transcodage ? Mais pourquoi, alors que j'ai bien installé lame et que mon PC a un core 2 duo E8200, et ne devrait donc pas avoir de problème à transcoder à la volée. Ou un autre problème ?
- aujourd'hui : je lance une lecture, tout se passe bien, quand winamp est sur stop la lecture suit son cours (mais ça ne me sert à rien, évidemment). Dès que je lance la lecture sur Winamp, pouf, ça vide la liste de lecture !

Bon, entretemps je ne sais pas ce que j'ai fait, mais le problème de la liste de lecture qui se vide seul n'apparaît plus. Par contre, le problème des sauts dans la lecture continue. Alors que je suis en transcodage 96kbps, que le test de ma connexion au boulot m'indique un débit descendant de 470 ko/s et que je suis chez moi (Paris) en offre Freebox dégroupé.

Quelqu'un a-t-il une idée ?

Merci d'avance !

gguigui
2008-04-24, 10:13
Ouhla...
En une journée, un fichier server.log de 11 Go !

Et toujours la même ligne dedans :

"Slim::Networking::Select::select (245) Error: Select task failed: Can't call method "streamformat" on an undefined value at /<C:\PROGRA~1\SQUEEZ~1\server\SQUEEZ~1.EXE>Slim/Web/HTTP.pm line 1974."

Heeeelp !

mherger
2008-04-24, 11:00
> En une journée, un fichier server.log de 11 Go !

Arrête SC, supprime le fichier, redémarre.

> Et toujours la même ligne dedans :
>
> "Slim::Networking::Select::select (245) Error: Select task failed:
> Can't call method "streamformat" on an undefined value at
> /<C:\PROGRA~1\SQUEEZ~1\server\SQUEEZ~1.EXE>Slim/Web/HTTP.pm line
> 1974."

Tu la trouves tous les quelques secondes? Quel format de fichier est-ce que tu utilises? Si ça continue, merci de télécharger une petite copie de ce fichier.

--

Michael

gguigui
2008-04-24, 23:53
Pour le fichier, c'est effectivement ce que j'avais fait, le supprimer. Pas trop le choix, d'ailleurs, vu qu'il bouffait toute la place de ma partition système :)

Pour les types de fichier, j'utilise quasi-uniquement du MP3 et du FLAC, et pour transcoder j'utilise la version de lame 3.98 beta 8. J'ai essayé à différents débits de transcodage.

Pour le fichier, je refais le test aujourd'hui, et j'envoie le fichier ce soir.

gguigui
2008-04-25, 01:23
Evidemment, aujourd'hui ça marche...

Il y a là un petit côté aléatoire qui me laisse franchement perplexe !