PDA

View Full Version : Streaming Issues



Brad Moody
2004-02-26, 16:32
Hi. I cannot consistently stream from home computer to work. Stream keeps being interrupted, buffer stays empty for a while, then refills sometimes quickly, sometimes not so quickly. Play eventually resumes but at some point, the cycle begins again. Average probably an interruption a minute, of 10 seconds to a minute duration. Prepared to believe it's sorry Time Warner/Earthlink cable connection problem but some of the debug messages seemed like maybe more is going on.

Have successfully "transcoded" 320 kbps MP3's to 96 kbps (verified by info on Winamp Screen) but problem still exists.

Details:

Internet Connection: Earthlink Cable (Home) Through Linksys BEFW11S4 Router (For Squeezebox--Works Great)
Logix T1 (Work)
System: Mac OSX 10.3 Home/PC Windows '98 Work
Slimserver: 5.1.1

Attached is a text file showing lines from the debug flags that I set (HTTP, remotestream and stream I think) if it helps.

Thanks,
b
M. Bradford Moody
Watt, Beckworth and Thompson, L.L.P.
1010 Lamar Suite 1600
Houston, Texas 77002
713-650-8100 ext. 108
713-650-8141 (Fax)
bmoody (AT) wbtllp (DOT) com

kdf
2004-02-26, 17:05
Quoting Brad Moody <bmoody (AT) wbtllp (DOT) com>:

> Hi. I cannot consistently stream from home computer to work. Stream keeps
> being interrupted, buffer stays empty for a while, then refills sometimes
> quickly, sometimes not so quickly. Play eventually resumes but at some
> point, the cycle begins again. Average probably an interruption a minute, of
> 10 seconds to a minute duration. Prepared to believe it's sorry Time
> Warner/Earthlink cable connection problem but some of the debug messages
> seemed like maybe more is going on.
>
> Have successfully "transcoded" 320 kbps MP3's to 96 kbps (verified by info on
> Winamp Screen) but problem still exists.
>
>

The debug looks more like web server activity than music streaming. However,
one thing you should try is increasing the buffer in Winamp. Look in
preferences, for the MPEG decoder input plugin. Select the streaming tab and
increase the buffer from the default of 32 to something like 128 or 256. You'll
give yourself room to recover from a lot more network latency that way. The
cost is only a delay in startup time.

-kdf