PDA

View Full Version : SB3 loses wireless signal, shaking restores it



4mula1
2008-04-18, 06:32
My parents have an SB3 and lately it's developed an issue where it fall off the wireless network. I found that if I shake it things begin to work again. I go into Current Settings to view the wireless signal strength. When it's off the network the signal strength is 0%, pick it up and hold it, still 0%, give it a shake, 60%+.

To try to determine whether or not it's a problem with their wireless router I brought over one of my SB3s and put it in the same location as the other SB3. Mine worked flawlessly, and theirs required the shake at one point. I am pretty confident that their wireless router is working fine (my wifi enabled phone had no issues either).


Their SB3 also fails to connect to the network after a firmware upgrade or regular restart. Give it a shake and everything is kosher.

I'm not sure what to do, but opinions are wanted. It was a Christmas gift in 2006 so I have a feeling it's out of warranty.

Any thoughts?

aubuti
2008-04-18, 06:37
At some point after Logitech bought SD they went from a 1-year to a 2-year warranty. I think the 2-year took effect before Christmas 2006, so it probably is still under warranty, unless you do your Christmas shopping really early. Even if it is out of warranty, Logi/SD will do most out-of-warranty repairs for US$90 plus shipping.

And, if it's as simple as a loose wireless card in the SB3, you could probably fix it yourself if you're handy with a screwdriver (I think you need a torx).

Good luck.

JimC
2008-04-18, 11:29
My parents have an SB3 and lately it's developed an issue where it fall off the wireless network. I found that if I shake it things begin to work again. I go into Current Settings to view the wireless signal strength. When it's off the network the signal strength is 0%, pick it up and hold it, still 0%, give it a shake, 60%+.

To try to determine whether or not it's a problem with their wireless router I brought over one of my SB3s and put it in the same location as the other SB3. Mine worked flawlessly, and theirs required the shake at one point. I am pretty confident that their wireless router is working fine (my wifi enabled phone had no issues either).


Their SB3 also fails to connect to the network after a firmware upgrade or regular restart. Give it a shake and everything is kosher.

I'm not sure what to do, but opinions are wanted. It was a Christmas gift in 2006 so I have a feeling it's out of warranty.

Any thoughts?

It sounds like the wireless card is loose. You can certainly RMA the unit, but you could--if you're comfortable--open up the case and reseat the wireless card to see if it corrects the problem. It's not that hard, it's just a couple of screws on the back to get the case open. Take the wireless card out, clean the edge connector, and then reseat the card. If you have it, use compressed air (or a camera lens brush/bulb) to blow out the connector on the SB3 circuit board before reseating the card.


-=> Jim