PDA

View Full Version : no audio from oggs on fedora 8 64bit



richardsk
2008-04-12, 05:10
I downloaded a podcast from theregister but I get no audio playing it in squeezeCenter 7.0. I'm running on fedora 8 64bit.

The ogg plays ok in totem & ogg123 but in squeezecenter there's no audio and elpased time repeatedly counts up to 8 seconds then resets to 0.

Any ideas what might be wrong or how to fix it ?

thanks
Richard

PS.
page : http://www.theregister.co.uk/2008/04/12/open_season_15/
ogg : http://go.theregister.com/podcast/2008/04/11/open_season_15_faithful.ogg

smc2911
2008-04-12, 05:25
This could be out of date advice, but ages ago I had problems with ogg on a 64b ubuntu machine and sorted it out by upgrading sox.

richardsk
2008-04-12, 06:14
This could be out of date advice, but ages ago I had problems with ogg on a 64b ubuntu machine and sorted it out by upgrading sox.

thanks for the suggestion. I've got the latest sox from the fedora repository 13.0.0, but there is a newer version on the sox website.
I might try building it from source but I'm not seeing sox in ps.
thanks
Richard

richardsk
2008-04-12, 06:15
I'm getting this in the server log :-
[08-04-12 14:08:33.6929] Slim::Player::Source::notSupported (743) Error: Decoder does not support file format, skipping track
[08-04-12 14:08:33.6937] Slim::Player::Source::errorOpening (1609) Error: While opening current track, so mark it as already played!
[08-04-12 14:08:33.6946] Slim::Player::Source::errorOpening (1609) Backtrace:

frame 0: Slim::Utils::Log::logBacktrace (/usr/lib/perl5/vendor_perl/Slim/Player/Source.pm line 1609)
frame 1: Slim::Player::Source::errorOpening (/usr/lib/perl5/vendor_perl/Slim/Player/Source.pm line 745)
frame 2: Slim::Player::Source::notSupported (/usr/lib/perl5/vendor_perl/Slim/Networking/Slimproto.pm line 769)
frame 3: Slim::Networking::Slimproto::_stat_handler (/usr/lib/perl5/vendor_perl/Slim/Networking/Slimproto.pm line 381)
frame 4: Slim::Networking::Slimproto::client_readable (/usr/lib/perl5/vendor_perl/Slim/Networking/Select.pm line 243)
frame 5: (eval) (/usr/lib/perl5/vendor_perl/Slim/Networking/Select.pm line 243)
frame 6: Slim::Networking::Select::select (/usr/libexec/squeezecenter-server line 503)
frame 7: main::idle (/usr/libexec/squeezecenter-server line 453)
frame 8: main::main (/usr/libexec/squeezecenter-server line 1005)

smc2911
2008-04-12, 06:42
What ogg settings have you got under Advanced > File types?

richardsk
2008-04-12, 06:56
ogg vorbis:-

AIFF - sox
FLAC - sox/flac
MP3 - Disabled
Ogg Vorbis - Native

smc2911
2008-04-13, 04:12
Hmmm. I'm out of ideas, I'm afraid. Anyone else?