View Full Version : Virgin Radio UK goes fast and skips

2008-04-11, 19:25
I have an SB3 which is now running SqueezeCenter 7 but was previously running SlimServer 6.5.4.

For about the last month I've occasionally tried to flip on Virgin Radio UK, found in the Internet Radio section. It connects to the stream buffers, and plays -- but what it sounds like is very strange. It plays fast (but on-pitch) but it's almost like it's playing 1/3 second chunks of the stream out of order as well. Sometimes in these 'skips' it will make a really nasty noise like when you've got corrupt MP3 data. It does this for 15 seconds or so, and then stops, re-buffers, and goes back to playing fast/chopped up, etc.

I finally just came downstairs and tried SoftSqueeze on my computer, and it's playing fine - so it's not my server I wouldn't think (both the Squeezebox and Softsqueeze prefs are set to direct stream, and by the looks of my firewall activity they are both talking directly to smgradio.com)

I pulled the plug on the SqueezeBox for a bit and tried again, but still same thing.

Other streams seem just fine. I listen to Radio David Byrne occasionally for instance, flipped through some of the 80's streams, etc.

Anyone have this happening or any idea what the ?!#* might be going on? It's the most bizarre thing.

2008-04-12, 11:07
I noticed the same thing while listening to Virgin Radio UK. For me, it only happens in certain time of the day, like evenings, but not in the morning. I am using Duet with SqueezeNetwork.

2008-04-12, 14:37
Hmm. Well I'm glad it's not just me :)

It has to be something strange with their particular stream and something in the SB3's ability to decode it correctly; I just went into the SqueezeCenter prefs and turned on 'Proxied Streaming', and the SB plays it fine now.

I'll file a bug report..

2008-04-16, 00:18
hi guys!
i'm glad that i've found some other members having this problem.
i already thought i'd have to send in my squeezebox3.
hope that will be fixed sometime in future releases.
in the meantime i will try the 'Proxied Streaming' setting.