PDA

View Full Version : SB2 will no longer connect when router security is on



BigTex
2008-04-10, 15:35
I recently reformatted and reinstalled systems on my laptop and desktop. As part of the process, I reset the router and reprogrammed it with a new network name and login code.

I have a SB2 that used to work fine with WPA TKIP. When I started reprogramming everything, I thought I would try WPA2 AES. The Squeezebox seemed to work fine with that. But I also have an XBox 360, and their wireless network device will only work with WPA, not WPA2. So I had to change the router (linksys wrt300n) to WPA TKIP. Now the laptop, print server, XBox 360 work fine...but the SB2 does not.

The SB2 logs into the network fine when wireless security is set to off. It can log in to SqueezeNetwork and play music wirelessly off my computers. The network strength is 87%, so I don't think that's the issue.

But when I turn on WPA TKIP and dial in the preshared key, it tries to connect for 30 seconds and then gives me the "Wireless encryption failure" error. I am 100% sure I am typing the psk in correctly, paying attention to case. I have factory reset the router twice (and it has the latest firmware). I have factory reset the Squeezebox twice. I have changed the psk and typed in the new one after a factory reset. No dice. All of my other WPA-TKIP devices work fine.

Like I said, none of this is an issue when security is turned off (and its the same whether SSID broadcast is enabled or disabled). And I am 100% sure I am typing in the key correctly into Squeezebox.

One other weird bit of behavior--if it gives me the wireless encryption error, it says, go left to go back, go right to try again. If I go right, it does the same thing. If I go left, it gives me the "enter your WPA password" screen...but it doesn't give me a cursor or arrow or highlighted box over a character or anything, so no chance to edit the PSK. In addition, if I go up or down (as if to change the character that the missing highlight box would be over), the box resets, with the Logitech and Squeezebox splash screens...every time I choose up or down at the "Enter your WPA password," as long as one has been entered. I can't ever edit it without doing a factory reset to erase the WPA password I put in before.

Chris

BigTex
2008-04-10, 21:41
Ok I've narrowed it down a bit. It's the TKIP encryption. Squeezebox and the router talk to each other and the rest of the network happily with AES encryption (WPA or WPA2, it works with both), or with no encryption, but they won't talk to each other if I use TKIP encryption.

Problem is, I've got a wireless printserver that will only talk to my computer in WPA-TKIP or WPK2-AES. My XBox360 wireless network device will only communicate in WPA, not WPA2. So WPA-TKIP leaves out the SB2, WPA-AES leaves out the printserver, and WPA2-AES leaves out the XBox.

I'd really like to make this work in WPA-TKIP, since this all worked before I reset my router in WPA-TKIP. I've got the most up-to-date firmware for the router, so I don't have a way to change the way it handles TKIP. But it worked before with this firmware without having to fix it. And all the other devices connect to the network with TKIP encryption just fine.

So I wonder if the issue is on the Squeezebox end of the encryption problem.

Anyone have any ideas how to troubleshoot this TKIP-specific problem?