PDA

View Full Version : How to turn off annoying crossfade?



benslim
2008-04-06, 22:32
Been through the setup several times and can't find the OFF button.

This should NOT be on by default.

Thanks!

haunyack
2008-04-06, 22:37
... the setup

Hi benslim,
What version SS/SC for "the setup"?

.

benslim
2008-04-06, 22:40
SqueezeCenter Version: 7.0 - 17793 - Windows XP - EN - cp1252

I've been through it twice since I wrote for help. Still don't see it in the "Settings".

aubuti
2008-04-07, 04:33
SqueezeCenter Version: 7.0 - 17793 - Windows XP - EN - cp1252

I've been through it twice since I wrote for help. Still don't see it in the "Settings".
It's a per player setting, so look under Settings > Players > Audio > Crossfade

benslim
2008-04-08, 21:13
Okay, I found it, and I changed it to none, clicked Apply.

It still crossfades. How to do it permanently and forever kill it?

aubuti
2008-04-08, 21:48
That should have taken care of it. Call tech support.

ModelCitizen
2008-04-08, 22:06
Crossfade is off by default.

MC

benslim
2008-04-08, 22:27
In my installation, crossfade is NOT off by default.

I think I've tracked down the issue after backtracking from the HTML back to several pm files and finally to the prefs file (transitionDuration). It looks like the software, SqueezeCenter, is lifting the settings from the Squeezebox itself. So even when I change it in SqueezeCenter, it doesn't change it on the Squeezebox, and the Squeezebox then overwrites my SqueezeCenter settings when the next song starts - what fun!

So far so good. Man, I can't stand crossfades.

I'm guessing that SC should update the SB, but it doesn't. Bug? -prolly.

Also, crossfade is no longer an option in my interface - forever gone from SC anyway.

benslim
2008-04-08, 22:38
Thought I fixed it. It still crossfades. Next, I will use a hammer.

ModelCitizen
2008-04-09, 04:57
If it is a bug it's a very odd bug indeed and not one that I've ever heard reported before.

If, as you say, the Crossfade config setting is missing from Settings > Players > Audio > Crossfade, and crossfade came as "on" by default then most likely there is something wrong with your installation or your set up.

Without any input from the wise (Michael Herger, are you there?) I'd be tempted to try a *completely* fresh installation of SC 7 (or even 7.0.1), backing up your settings before entirely uninstalling and deleting any vestiges of Program Files/SqueezeCenter and C:\Documents and Settings\All Users\Application Data\SqueezeCenter. Then make sure the firmware on your players is updated (if required) and then try playing a couple of tracks (without changing any settings!).

If this doesn't fix it then there's a ghost in your machine.

MC

FredFredrickson
2008-04-09, 06:23
The duet remote has options for crossfading, but I've never seen it work...it's possible it's because squeezecenter has crossfading on by default, but it's set to 0 seconds, so it doesn't really do anything..

benslim
2008-04-09, 10:24
The installation is 3 days old. The unit is 3 days old. Crossfade was ON by default. Firmware is upgraded, as of 3 days ago. Crossfade cannot be turned off. I can turn it off for a single song, but when the next song plays, Crossfade is back. Crossfade is NOT missing - if only it were...

Seriously, if I can't fix this, the unit is going back, and I'm going back to my Roku.

aubuti
2008-04-09, 10:42
The installation is 3 days old. The unit is 3 days old.
To repeat: call tech support. What you're seeing isn't a common problem, and tech support is much better equipped to walk you through resolving this problem than this users' forum is.

toby10
2008-04-09, 11:12
The installation is 3 days old. The unit is 3 days old. Crossfade was ON by default. Firmware is upgraded, as of 3 days ago. Crossfade cannot be turned off. I can turn it off for a single song, but when the next song plays, Crossfade is back. Crossfade is NOT missing - if only it were...

Seriously, if I can't fix this, the unit is going back, and I'm going back to my Roku.

Is it possible his cross fade option on SN is setting it back to "on"?? I know SC and SN are synced for some basic settings.

Siduhe
2008-04-09, 11:15
Or something in the install isn't allowing him to write updated preferences. I agree, this is a job for support.

ModelCitizen
2008-04-09, 11:35
Seriously, if I can't fix this, the unit is going back, and I'm going back to my Roku.

Please do.

MC

benslim
2008-04-09, 16:00
ModelCitizen, is your son impressed with your 1,243 posts? I know I am.

EnochLight
2008-04-09, 18:35
ModelCitizen, is your son impressed with your 1,243 posts? I know I am.

You should be. Now call tech support and stop whining about your Roku. ;-)

aubuti
2008-04-13, 17:56
Funny thing, but I started getting this on one of my players today. I was playing some random mix, turned crossfade on, and couldn't turn it off, or at least not for more than one track. Then I realized it was almost certainly the Transition Updater plugin that was taking over. Transition Updater looks at a playlist, and only crossfades for tracks that are not consecutive album tracks. My recollection was that on previous versions (for SS 6.x) if you turned off crossfade globally, it wouldn't crossfade anything, but that doesn't seem to be the case now. Or maybe I'm misremembering. As soon as I put on an entire album, I could turn crossfade off in SC settings, and it would stay that way. And if I try to turn crossfade when playing an album, Transition Updater turns it off again.

Later I'll try to verify this diagnosis by switching off the Transition Updater plugin.

I doubt this is the source of the OP's (benslim) problem, because with a new install and a clear dislike for crossfades, it's highly unlikely he would have installed the Transition Updater plugin.