PDA

View Full Version : SB menu navigation slow since SC 7.0



Longfield
2008-03-27, 11:42
Hi,

I have upgraded my system (running on Ubuntu 8.04) from Slimserver to SqueezeCenter. This has brought my SB Model 3 to Firmware version 86.

Since then, I experience very slow menu navigation at SB startup, but this disappears as soon as I play music on the SB.

It is strange, because the SqueezeCenter seems to run fine according to the logs (except for the know database error on shutting down the server and the mDNS error when starting it up).

Here is the log for start-stop-start:

[08-03-27 08:16:17.4576] Slim::Networking::mDNS::startAdvertising (110) Error: Couldn't find mDNSResponderPosix binary! Aborting!
2008-03-27 08:22:09 squeezecenter_safe stopped.
[08-03-27 08:22:12.1140] Slim::Schema::forceCommit (1363) Warning: Trying to commit transactions before DB is initialized!
[08-03-27 08:22:12.1171] Slim::Schema::Storage::throw_exception (67) Error: DBI Connection failed: DBI connect('hostname=127.0.0.1;port=9092;database=sli mserver:mysql_socket=/var/lib/squeezecenter/cache/squeezecenter-mysql.sock','slimserver',...) failed: Can't connect to MySQL server on '127.0.0.1' (111) at /usr/share/squeezecenter/CPAN/DBIx/Class/Storage/DBI.pm line 652
[08-03-27 08:22:12.1179] Slim::Schema::Storage::throw_exception (67) Backtrace:

frame 0: Slim::Utils::Log::logBacktrace (/usr/share/perl5/Slim/Schema/Storage.pm line 67)
frame 1: Slim::Schema::Storage::throw_exception (/usr/share/squeezecenter/CPAN/DBIx/Class/Storage/DBI.pm line 658)
frame 2: DBIx::Class::Storage::DBI::_connect (/usr/share/squeezecenter/CPAN/DBIx/Class/Storage/DBI.pm line 616)
frame 3: DBIx::Class::Storage::DBI::_populate_dbh (/usr/share/squeezecenter/CPAN/DBIx/Class/Storage/DBI.pm line 543)
frame 4: DBIx::Class::Storage::DBI::ensure_connected (/usr/share/perl5/Slim/Schema/Storage.pm line 27)
frame 5: (eval) (/usr/share/perl5/Slim/Schema/Storage.pm line 27)
frame 6: Slim::Schema::Storage::dbh (/usr/share/perl5/Slim/Schema.pm line 244)
frame 7: (eval) (/usr/share/perl5/Slim/Schema.pm line 244)
frame 8: Slim::Schema::disconnect (/usr/sbin/squeezecenter-server line 964)
frame 9: main::cleanup (/usr/share/perl5/Slim/bootstrap.pm line 368)
frame 10: Slim::bootstrap::sigint (/usr/share/perl5/Slim/bootstrap.pm line 402)
frame 11: Slim::bootstrap::theEND (/usr/sbin/squeezecenter-server line 1001)
frame 12: main::END (/usr/sbin/squeezecenter-server line 0)
frame 13: (eval) (/usr/sbin/squeezecenter-server line 0)

[08-03-27 08:22:12.1191] Slim::Schema::Storage::dbh (38) Warning: Unable to connect to the database - trying to bring it up!
2008-03-27 15:46:38 squeezecenter_safe started.
[08-03-27 15:46:57.3875] Slim::Networking::mDNS::startAdvertising (110) Error: Couldn't find mDNSResponderPosix binary! Aborting!

I tried to search in the forum about this issue, however I found nothing. Does anyone have an idea ?

mherger
2008-03-27, 23:29
> Since then, I experience very slow menu navigation at SB startup, but
> this disappears as soon as I play music on the SB.

Menu navigation on the player? Did you give your player a name? There's an
issue with SC7.0 if your player doesn't have a name, locking up the player
interface for several seconds.

Michael

Longfield
2008-03-28, 07:15
Yes on the player.

And I think I have not given the player a name (since I own only one for now ...).

I am going to try this after work and report back here. Thanks for the quick answer !

OK, looks like it resolved my problem ! Thanks again !

SimonD
2008-03-29, 06:49
many thanks for the advice in naming SB3 -working fine now