PDA

View Full Version : SC 7 Scanning Issue



mrdo
2008-03-25, 12:57
i'm having problems scanning my library using squeezecenter 7 running under vista ultimate. everything worked fine under my previous versions of slimserver.

i'm currently getting the following in the scanner log :

[08-03-25 19:02:42.3909] MP3::Info::_parse_v2tag (850) Warning: Use of uninitialized value in string eq at C:\PROGRA~1\SQUEEZ~1\server\lib/MP3/Info.pm line 850, <$fh> line 1.

does anyone have any ideas as to what is wrong ?

thanks in advance

craig

JJZolx
2008-03-25, 13:02
That's just a warning and may not have any effect on the scan's outcome.

What problems exactly are you having with the scanning?

mrdo
2008-03-25, 13:22
hi there,

scanner.exe stops working under windows. the tags seem to be ok and the tracks that the scanner is failing on haven't been changed in quite a while ...

cheers !

c

JJZolx
2008-03-25, 13:32
scanner.exe stops working under windows. the tags seem to be ok and the tracks that the scanner is failing on haven't been changed in quite a while ...

Do you end up with fewer tracks/albums than you expect?

Turn on some additional logging - under Server Settings > Advanced > Logging. Set 'scan', 'scan.import' and 'scan.scanner' to 'Debug' and then run a full clear/rescan. See what errors you get.

mherger
2008-03-25, 13:41
> scanner.exe stops working under windows. the tags seem to be ok and the
> tracks that the scanner is failing on haven't been changed in quite a
> while ...

First make sure it's not the well known McAfee issue. Then you might give 7.0.1 a try where we've added a few fixes to file name/path handling, especially related to non-latin characters.

And then you should run the scan with scan.scanner=debug and upload the resulting scanner.log.

--

Michael

mrdo
2008-03-25, 15:20
looks like 7.01 has solved my problems for the moment.

thanks for all your help guys.

:-)

robroe
2008-03-26, 15:28
I've been having this issue too, the scanner gets to about 7000 out of 7400 tracks and dies and restarts (using MusicIP integration). I have missing tracks and I'm going to turn a bit more logging on to try and work out what is going on. I think it must be a dodgy tag, although SlimServer and iTunes etc were ok with it.

Is there an "official" release of 7.0.1 or do I have to get one from the nightlies?

Thanks

radish
2008-03-26, 15:31
Is there an "official" release of 7.0.1 or do I have to get one from the nightlies?


7.0.1 hasn't been officially released yet.

robroe
2008-03-27, 03:28
7.0.1 hasn't been officially released yet.

But it's possible to get hold of it somehow??

mherger
2008-03-27, 03:41
>> 7.0.1 hasn't been officially released yet.
>
> But it's possible to get hold of it somehow??

http://www.slimdevices.com/downloads/nightly/latest/trunk/

--

Michael

robroe
2008-03-27, 04:14
Thank you.