PDA

View Full Version : Server.log filling up (>13G after 6 weeks)



MuckleEck
2008-03-23, 08:51
I have been using SC7 on Windows Home Server with two plug-ins (Weather/Date/Time and Alien BBC)

My server.log file was just enormous (13.4G) so decided to find out why.

The server.log file was filling up with

08-03-23 15:47:36.8853] Slim::Utils::Strings::string (363) Error: missing string PLUGIN_WEATHERTIME_TODAY
[08-03-23 15:47:36.8856] Slim::Utils::Strings::string (363) Backtrace:

frame 0: Slim::Utils::Log::logBacktrace (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Utils/Strings.pm line 363)
frame 1: Slim::Utils::Strings::string (Plugins/WeatherTime/Plugin.pm line 2053)
frame 2: Plugins::WeatherTime::Plugin::retrieveWeather (Plugins/WeatherTime/Plugin.pm line 1810)
frame 3: Plugins::WeatherTime::Plugin::tictac (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Utils/Timers.pm line 198)
frame 4: (eval) (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Utils/Timers.pm line 198)
frame 5: Slim::Utils::Timers::checkTimers (slimserver.pl line 506)
frame 6: main::idle (slimserver.pl line 43)
frame 7: PerlSvc::Startup (perlsvc line 851)
frame 8: PerlSvc::_startup (slimserver.pl line 0)
frame 9: (eval) (slimserver.pl line 0)

I have switched ALL logging to off, and the above is still repeating every second.

Any ideas how to stop this?

kdf
2008-03-23, 10:46
On 23-Mar-08, at 8:51 AM, MuckleEck wrote:

>
> frame 9: (eval) (slimserver.pl line 0)
>
> I have switched ALL logging to off, and the above is still repeating
> every second.
>
> Any ideas how to stop this?
disable weather/date/time. it seems to have a rather bad timer bug
that eventually explodes into 'insane number of timers' and many
backtraces like the one you included.
The author of the plugin needs to have a look at it. Most likely the
tictac() function simply needs to make sure that when it executes,
that it kills all other pending timers for tictac().
-kdf

JJZolx
2008-03-23, 23:08
Why, if all logging levels are set to "Off" would anything at all be written to the logs? Apparently these entries were at the "Error" level. Are there events that will bypass the logging settings and be written to the logs no matter what?

MuckleEck
2008-03-24, 02:54
Why, if all logging levels are set to "Off" would anything at all be written to the logs? Apparently these entries were at the "Error" level. Are there events that will bypass the logging settings and be written to the logs no matter what?

This is something that I would like answered as well, currently I have switched the plug-in off and no logging is taking place.

However I do not understand, as you have pointed out, why logging is still occurring when all logging is off.

barks
2008-04-18, 18:51
Wow, I just looked at my server.log and found it to be almost 28Gig! How do you clear the log, just delete it?

SqueezeCenter Version: 7.0 - 17793 - Windows Vista - EN - cp1252
Squeezebox v3 Firmware: 86
SBR Firmware: 22
SBC Version 7.0 r2097

JJZolx
2008-04-18, 18:59
Wow, I just looked at my server.log and found it to be almost 28Gig! How do you clear the log, just delete it?

SqueezeCenter Version: 7.0 - 17793 - Windows Vista - EN - cp1252
Squeezebox v3 Firmware: 86
SBR Firmware: 22
SBC Version 7.0 r2097

Yes, you can just delete it. You'll probably have to stop SqueezeCenter first.

I would think a 28GB log is pretty unlikely unless you've raised the logging levels on at least one of the logging settings. Before shutting down SC7 you'll probably want to reset them. The default level for all of them is 'Error'. Don't forget to tick the checkbox at the top of the page that says 'Save logging settings for use at next application restart' and then to hit the 'Apply' button.

barks
2008-04-18, 19:13
Thanks Jim, I never changed any of the default settings. Just never looked at the log. I deleted it and everything seems to be fine. Current log just has just a few lines after restarting SC. ~Mike

JJZolx
2008-04-18, 19:19
Thanks Jim, I never changed any of the default settings. Just never looked at the log. I deleted it and everything seems to be fine. Current log just has just a few lines after restarting SC. ~Mike

I'd take a careful look at what's being put in the file then. Something is causing a _lot_ of errors.