PDA

View Full Version : Sub Folder Problems with SqueezeCenter



Evidica
2008-03-18, 07:41
I just replaced my Slimserver software to SqueezeCenter and now any music files in sub folders of my music directory are hit or miss. Only half of my music is showing up now. If it isnt in a folder it shows up fine, if it is only one folder level down it will show up two, but if it is more than one level down it wont work.

For instance, my music path is E:\Music\ and in that I have a folder of varios Irish .mp3's so they work fine since it is E:\Music\Irish\ but my Incubus music will not show up which is located at E:\Music\Incubus\[Album Name]\ any ideas why?

mherger
2008-03-18, 07:54
> For instance, my music path is E:\Music\ and in that I have a folder of
> varios Irish .mp3's so they work fine since it is E:\Music\Irish\ but my
> Incubus music will not show up which is located at
> E:\Music\Incubus\[Album Name]\ any ideas why?

Your issue doesn't sound familiar to me - except if I had seen non-latin characters in those path names.

I have recently checked in a few changes to the scanner/path handling code. This is in the 7.0.1 nightly build. Feel free to give it a try.

Whatever you do: set logging for scan.scanner to debug before you do your next scan. Then upload the resulting scanner.log (and turn that debugging off, as it will spill your disk with a lot of data!).

--

Michael

Evidica
2008-03-18, 08:35
Here is what the log showed:

[08-03-18 10:28:53.5674] MPEG::Audio::Frame::broken (618) Warning: Use of uninitialized value in right bitshift (>>) at C:\PROGRA~1\SQUEEZ~1\server\lib/MPEG/Audio/Frame.pm line 618, <$mpeg> chunk 5.

[08-03-18 10:28:53.5680] MPEG::Audio::Frame::broken (619) Warning: Use of uninitialized value in right bitshift (>>) at C:\PROGRA~1\SQUEEZ~1\server\lib/MPEG/Audio/Frame.pm line 619, <$mpeg> chunk 5.

[08-03-18 10:28:53.5683] MPEG::Audio::Frame::broken (620) Warning: Use of uninitialized value in right bitshift (>>) at C:\PROGRA~1\SQUEEZ~1\server\lib/MPEG/Audio/Frame.pm line 620, <$mpeg> chunk 5.

[08-03-18 10:28:53.5686] MPEG::Audio::Frame::broken (621) Warning: Use of uninitialized value in right bitshift (>>) at C:\PROGRA~1\SQUEEZ~1\server\lib/MPEG/Audio/Frame.pm line 621, <$mpeg> chunk 5.

[08-03-18 10:28:53.5691] MPEG::Audio::Frame::broken (618) Warning: Use of uninitialized value in right bitshift (>>) at C:\PROGRA~1\SQUEEZ~1\server\lib/MPEG/Audio/Frame.pm line 618, <$mpeg> chunk 12.

[08-03-18 10:28:53.5695] MPEG::Audio::Frame::broken (619) Warning: Use of uninitialized value in right bitshift (>>) at C:\PROGRA~1\SQUEEZ~1\server\lib/MPEG/Audio/Frame.pm line 619, <$mpeg> chunk 12.

[08-03-18 10:28:53.5698] MPEG::Audio::Frame::broken (620) Warning: Use of uninitialized value in right bitshift (>>) at C:\PROGRA~1\SQUEEZ~1\server\lib/MPEG/Audio/Frame.pm line 620, <$mpeg> chunk 12.

[08-03-18 10:28:53.5701] MPEG::Audio::Frame::broken (621) Warning: Use of uninitialized value in right bitshift (>>) at C:\PROGRA~1\SQUEEZ~1\server\lib/MPEG/Audio/Frame.pm line 621, <$mpeg> chunk 12.

Evidica
2008-03-21, 06:29
well, I guess that didnt help. It is frustrating that I paid for a product that works great for so long. Then Logitech buys the company and decides to release SqueezeCenter with a different look and feel and at the same time, breaks the indexing fuction so now I can only see half my music.

ds2021
2008-03-21, 07:04
All my music is more than 2 folder levels deep, some as much as 4 or 5. I am not seeing this problem either.

If you place a problem folder directly in the root music folder, does it then play normally?

Have you done a complete rescan with "Clear Library and Rescan Everything" selected?

Does this happen if you navigate by album folder as well as via tags (i.e., album, artist, genre, etc.)?

I do not understand your log errors, but it does appear that there is some problem. It may be advisable to contact support directly.