PDA

View Full Version : Transporter Studdering with AAC



jrgeoffrion
2008-03-17, 09:33
I've had my Transporter for over a year and love it. However, about 3 weeks ago, it "studders" when playing Apple Lossless music. I have no problem with MP3. It sounds a little like a disc skipping.

I'm running Vista x64, 2Gb RAM, and SlimServer 6.5.4. Never had a problem until 3 weeks ago. I obviously played with something but I don't know where and how to fix the issue.

I think the problem resides with the AAC converter but that's the extent of my diagnostic and solution. :(

Any help would be greatly appreciated.

bpa
2008-03-17, 09:47
Do you have SATA disks with an nVidia adaptor ?

Try the solution in post #12 of this thread.

http://forums.slimdevices.com/showthread.php?t=40001&page=2

jrgeoffrion
2008-03-17, 10:10
I think that may be it... Let me try and I'll see if that solves the problem.

jrgeoffrion
2008-03-17, 10:22
I think that may be it... Let me try and I'll see if that solves the problem.

Maybe I'm dense (probably), but I didn't find an "solution" to the "bug"... Anyone want to spoon feed me?

amcluesent
2008-03-17, 12:56
Try this - http://forums.slimdevices.com/showpost.php?p=253734&postcount=13

Uses faad to transcode the m4a.

bpa
2008-03-17, 13:23
The suggested posts are part of threads and the solution is clearer if the whole thread is read.

That said - if your system has SATA disk with an nVidia interface then the problem is probably in the QuickTime libraries so you have to use a new decoder - change from mov123.exe to faad.exe. The rules for handling conversion are in the convert.conf file in the Slimserver directory tree. The AAC format falls under the "MOV" file type.

So you need to do the following
1. Download a Windows version for faad.exe ( probably from here http://www.rarewares.org/aac-decoders.php ) and copy into your Slimserver Bin/MSWin32...(I forget the fullname) directory.
2. Edit the convert.conf file with Wordpad (not Notepad). Change the mov123 lines for mp3 and flc as follows (taken from wiki AAC entry). You can add the "mov wav" lines as well. If the executable in installed in step 1 is called faad2.exe then change the faad to faad2.


# Transcoding for AAC files.
mov flc * *
[faad] -w -f 2 $FILE$ | [flac] -cs --totally-silent --compression-level-0 --endian little --sign signed --channels 2 --bps 16 --sample-rate 44100 -

mov mp3 * *
[faad] -w -f 2 $FILE$ | [lame] --resample 44100 --silent -q $QUALITY$ -b $BITRATE$ -x -r - -

mov wav * *
[faad] -w -f 2 $FILE$

3. Restart Slimserver and check Server Setting/Filetypes - that MOV now have 3 entries enbaled to use faad.

jrgeoffrion
2008-03-17, 13:59
The suggested posts are part of threads and the solution is clearer if the whole thread is read.

That said - if your system has SATA disk with an nVidia interface then the problem is probably in the QuickTime libraries so you have to use a new decoder - change from mov123.exe to faad.exe. The rules for handling conversion are in the convert.conf file in the Slimserver directory tree. The AAC format falls under the "MOV" file type.

So you need to do the following
<sni>

Thanks a bunch for the detailed explanations... I was missing the "Edit the convert.conf file with Wordpad (not Notepad)"... I think my issue is solved.

You guys are great!

Kind regards,

JR
http://www.jrgeoffrion.com