PDA

View Full Version : This URL works with SN, not with SC



short_y
2008-03-16, 16:30
http://www.streamaudio.com/listen?station=KFOG_FM

This URL resolves just fine with SqueezeNetwork and generates a 6 URL playlist. If I enter it in my newly installed SC7 I get a timeout error and no entries generated for my playlist. I'm pretty sure this worked fine with SS 6.5.4.

Any suggestions beyond the obvious ones (don't use that URL; find another station; resolve the URL by hand and manually key in the results; etc.)?

mherger
2008-03-16, 23:53
> http://www.streamaudio.com/listen?station=KFOG_FM
>
> This URL resolves just fine with SqueezeNetwork and generates a 6 URL
> playlist. If I enter it in my newly installed SC7 I get a timeout error
> and no entries generated for my playlist.

Timeouts very likely are due to some (temporary) networking issue. Try
again, or increase the timeout setting in Settings -> Advanced ->
Networking.

Michael

short_y
2008-03-17, 07:52
Sorry, I shoulda said in my original post that this occurred repeatedly over the space of an hour or so and I switched back and forth between SN and my SC installation. Haven't had a chance to try it today. I guess as much as anything, I'm curious if anyone else sees the same thing with their SC installation. I've got it installed on a Win XP box. I've been running SS for about 2 years and only just upgraded to the release version of SC yesterday.

short_y
2008-04-06, 15:21
OK, finally had a chance to get back to this and I can confirm that it doesn't work from SC but does from SN. I switched back and forth between a connection to SC and a connection to SN and it repeatedly works with SN but not with SC. I tried hitting the server with curl to see what it returns and I got a 302 object moved but the new location was the same as what I sent. IIRC, the server keys on User Agent or something and returns a URL that has variables embedded in it. If the issuer can't substitute for the variables, you get nuthin'. Tried it in Firefox with NoScript installed and the URL I get returned is

http://www.streamaudio.com/listen/default_gonew.asp?headertext=&Owner=&station=KFOG_FM&PortalFormat=&OptIn=&streamtype=&filename=

Make sense to anyone?

short_y
2008-04-10, 16:05
Bump.

Anyone?

bpa
2008-04-10, 16:19
The URL you gave is actually of a web page - which has an ASX URL buried in it amongst a number ofother URLs (which SC thinks should be played). The ASX URL timeouts but the ASX has 3 URLs.

mms://uni6.susq.streamaudio.com/KFOG_FM
mms://1.uni6.susq.streamaudio.com/KFOG_FM
mms://2.uni6.susq.streamaudio.com/KFOG_FM

Try them with http instead of mms - it worked OK for
http://uni6.susq.streamaudio.com/KFOG_FM

short_y
2008-04-11, 08:55
Thanks, bpa, I'll hang on to those URLs but what I'm really curious about is why the original URL resolves OK and plays with SqueezeNetwork but not with SqueezeCenter. Might this be considered a bug?