PDA

View Full Version : SBC wake up computer



improvisato
2008-03-15, 10:46
Here's my setup:
SqueezeCenter Version: 7.0 - 17793 - Windows XP - EN - cp1252
Server IP address: 192.168.1.100
Perl Version: 5.8.8 MSWin32-x86-multi-thread
MySQL Version: 5.0.22-community-nt
Platform Architecture: 586

Here's what I want to happen:
When I set my computer to S3 sleep mode, I want it to go standby. If I'm listening via SqueezeNetwork, I want my SBR to continue playing like normal and have the computer stay asleep. If I use the SBC to browse for an artist in SqueezeCenter, I want the SBC to wake up the computer.

My network properties show three enable/disable controller settings:
- Wake on magic packet
- Wake on pattern
- WakeOnLAN from PowerOff

In messing around with various settings on enable/disable, I get two outcomes:
- The computer goes to sleep but then immediately starts back up again (this is obvisouly not what I want)
- The computer goes to sleep (this is partially what I want, except....)

I can't get the SBC to wake up the computer when I try to switch from SqueezeNetwork back to SqueezeCenter.

Any ideas?

Mark Lanctot
2008-03-24, 07:21
The SBC doesn't support WOL yet.

syburgh
2008-03-24, 07:28
Vote for enhancement #5378 (http://bugs.slimdevices.com/show_bug.cgi?id=5378), maybe scheduled for SC 7.1

sunset-squeeze
2008-03-24, 16:01
This works for me.

1. Only enable wake on magic packet. (Others may prevent SB from going to sleep.)
2. I believe the SB only sends Wake on LAN magic packet when you press the power button. Try that. (I'm not sure if its sends one when you switch from Squeeze Netork to Squeeze Center.) You should see the message "Waking Up Squeeze Center.)

improvisato
2008-03-25, 09:58
The SBC doesn't support WOL yet.


Vote for enhancement #5378 (http://bugs.slimdevices.com/show_bug.cgi?id=5378), maybe scheduled for SC 7.1

Thanks Mark and syburgh. I'll keep an eye open for this bug fix.


This works for me.

1. Only enable wake on magic packet. (Others may prevent SB from going to sleep.)
2. I believe the SB only sends Wake on LAN magic packet when you press the power button. Try that. (I'm not sure if its sends one when you switch from Squeeze Netork to Squeeze Center.) You should see the message "Waking Up Squeeze Center.)

Sunset, is your fix for the SB? My WOL question relates to the Duet.

sunset-squeeze
2008-03-25, 10:04
Yes its for the Squeeze Box 3 working with Sqeeze Center 7.

sl789
2008-03-28, 02:08
Hi Sunset !

I has SC7 installed on Linux Fedora Core 3 and when I go to Advanced and click on Network I don't see any WOL related tabs like wake on magic packet. Is it only for Windows version ?

That's the Status

-------------------
SqueezeCenter Version: 7.0 - 17793 - Red Hat - EN - utf8
Server IP address: 192.168.0.120
Perl Version: 5.8.5 i386-linux-thread-multi
MySQL Version: 5.0.51a-community

Platform Architecture: i686-linux
----------------------

That's what I have on Advanced->Network

--------------------------------


Web Proxy


Web Server Port Number


Radio Station Buffer Seconds


Radio Station Timeout


Maximum WMA Stream Bitrate


Synchronized Players Startup Delay


UPnP Client


Bonjour Name
.

PSSO
2008-03-28, 03:25
http://bugs.slimdevices.com/show_bug.cgi?id=5378

sunset-squeeze
2008-03-28, 05:41
Hi sl789,

In Windows I set Wake on Lan for the Network Adapter under the Device Manager (under the Power Magagement Tab). I have attached a picture of this screen.

I'm not familiar with Linux, so I can't help you there.

On my PC there is a light on on or near the network adapter even when the computer is off (but is plugged in). I believe this indicates the ability to Wake On LAN. You might want to look for that. Also there are some BIOS setting relating to WOL. The presence of these might indicate you computer is WOL capable.

sl789
2008-03-28, 12:51
Hi Sunset !

Thanks for the info. I'll check my Linux settings (I switched to Linux on my 8 years old laptop which I use as music server only recently, since it was regulary loosing connections with SB3 each couple of days while running both Slim Server and Slim Center, don't know what was the problem). Linux/SC7 is very stable (actually never lost connection) at least for now, so if only I master WOL that's will be nearly perfect.