PDA

View Full Version : Difference in scanning Ubuntu v Vista?



kesey
2008-03-12, 13:55
When I do a Squeezecenter 7.01 Scan (Clear Library and Rescan Everything) in Ubuntu, the following Scans are done:
Directory Scan (6825 of 6825)00:05:53
Playlist Scan (514 of 514)00:01:45
Merge Various Artists (521 of 521) 00:00:27
Artwork Scan (521 of 521) 00:01:53
Database Optimize: Complete 00:00:07 TOTAL 10:05

In Vista 32 Ultimate the following Scans are done:
Directory Scan (6686 of 6686)00:06:27
Playlist Scan (506 of 506)00:01:50
Merge Various Artists (27 of 520) 00:00:27 TOTAL 06:49:13

The Problem: In Ubuntu, after a scan on an Album Browse, I see Album Art. In Vista (and XP) I see no Album Art, unless I play an Album and then the Album Cover for the Album played shows.

Can someone tell me how to get Squeezecenter to perform the Album Artwork scan on Vista/XP please?

Note: I'm as yet baffled as to the reason for the differences in Directory sizes
regards and TIA,

kesey

JJZolx
2008-03-12, 14:09
Looks like something is causing the scanning on Vista to abort. There have been a lot of reports of problems with SqueezeCenter running on Vista, usually firewall and/or directory permission issues. See the sticky topic at the top of this forum about running on Vista for some fixes.

It's too bad that the scan status is reported like that... it makes it appear to have completed when obviously it died.

kesey
2008-03-15, 06:25
Looks like something is causing the scanning on Vista to abort. There have been a lot of reports of problems with SqueezeCenter running on Vista, usually firewall and/or directory permission issues. See the sticky topic at the top of this forum about running on Vista for some fixes.

It's too bad that the scan status is reported like that... it makes it appear to have completed when obviously it died.

I tried all sorts of shenanigans (it's St. Patrick's weekend after all) to get the scan to complete, including going back to Slimserver. Nothing worked, so I reinstalled Squeezeserver (7.01-17889), went to the Cache folder below and deleted everything in it. I then rescanned and voila, the scan completed - including scans of Arthwork and Data Optimize. Artwork is now happily showing.
Cache Folder: C:\ProgramData\SqueezeCenter\Cache

Re: Vista. I have Ultimate 32 installed and must say that I've never had any trouble with it. I note that the Scan problems have been happening with XP Pro SP2 also. I've deleted the Cache there and re-scanned, and the full scan is now completing and artwork is showing thereafter.

The cleanest method of getting the scan to complete in Vista and in XP seems to be to delete the cache file and then to reboot the computer. As Squeezecenter starts it will do an automatic music scan because it will find an empty cache (having been deleted prior to re-boot): there's therefore no need to open up Squeezecenter settings to do it.