PDA

View Full Version : Bug: Settings don't stick in Opera



strindberg
2008-03-08, 01:08
I have been using Opera for accessing SC for a while now, due to the bug which makes Firefox hog all the CPU when displaying SC. I have noticed an annoying problem: when using Opera, some visual settings disappear every time you restart the browser, settings which are saved when using Firefox.

More specifically, I am talking about the settings for showing and sorting albums (the little menu in the left hand corner where you can choose "Text only", "Small Artwork", "Sort by..." etc), and whether or not you want to display artwork in the playlist (the menu in the bottom right, with alternatives "Hide Artwork", "Show Artwork").

It's a bit of a pain having to adjust these everytime I start the browser. And I am still longing for the day when I can return to Firefox...

mherger
2008-03-08, 07:19
> More specifically, I am talking about the settings for showing and

These are parameters which are stored as cookies in your browser. Check Settings->Advanced->Cookies: there are options to accept/deny cookies, and have them deleted on closing the browser. Make sure the cookies are accepted and _not_ deleted.

There's also a button to get the full list of them. Do you see any cookie called "SqueezeCenter-..." in there?

--

Michael

strindberg
2008-03-08, 10:08
I have checked my Opera settings, and I have set it to "Accept cookies", and made sure "Delete cookes on exit" is unchecked. Still no luck.

I do have a bunch of SC cookies, but again, it doesn't seem to work.

This is Opera 9.25 on Windows XP.

strindberg
2008-03-09, 07:03
I think I found the problem: Opera doesn't seem to save cookies for "raw" ip addresses.

I usually connect to the (private) ip address of my SC: http://192.168.1.8:9000. After checking all the settings in Opera, and restarting a couple of times, I noticed that all the cookies set by SC were lost on every restart.

I changed the address to the local name of the SC server: http://august:9000, and now the cookies last over a restart. Go figure.

So I suppose this puts it down to a Opera bug (or feature?).

mherger
2008-03-09, 11:02
> I usually connect to the (private) ip address of my SC:
> http://192.168.1.8:9000. After checking all the settings in Opera, and
> restarting a couple of times, I noticed that all the cookies set by SC
> were lost on every restart.

Wow, I never noticed this...

> So I suppose this puts it down to a Opera bug (or feature?).

I'd say so.

--

Michael