PDA

View Full Version : SlimServer 5.1 and iTunes playlists



Eric Schurr
2004-02-10, 19:43
Funny you should ask....

As a test, I closed the server browser window with the option set to
close the server process. Then I restarted it from the Windows GUI and
the playlists were empty!

I closed the window/server again, and restarted it from the command line
(not with the debug options) and the playlists returned.

Again, I closed the window/playlists and started the server from the GUI
and the playlists were there, also. So I can't seem to make the
playlists go away now. I'm not complaining, but it's disturbing to not
know what makes them disappear.

Weird science...

Eric Schurr
eschurr (AT) comcast (DOT) net


-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of kdf
Sent: Tuesday, February 10, 2004 6:29 PM
To: Slim Devices Discussion
Subject: [slim] SlimServer 5.1 and iTunes playlists

Quoting eschurr (AT) comcast (DOT) net:

> If you've set the player to use iTunes, then it should be able to read

> > in the iTunes Music Library.xml file and use the playlists therein.
> >
> > What do you have set for your Saved Playlists folder?
>
> C:\Program Files\SlimServer\server\Playlists
>
> as kdf suggested, I ran the slimserver.exe with --d_itunes and
--d_info and
> SlimServer started up with no complaints. And now all the playlists
are
> visible! I don't know what fixed it, but i'm happy!
>
> thanks for all your help. Can't live without my Squeezebox!

does it still work when you go back to your normal way of starting it?
Those
options were for debugging. Surprising that they alone should have
fixed it.
however, if simple restart fixed it, I'm certainly not going to
complain :)

-kdf
(hides the dead chicken)